summaryrefslogtreecommitdiffstats
path: root/php-aws-sdk3.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-06-22 08:59:21 +0200
committerRemi Collet <remi@remirepo.net>2017-06-22 08:59:21 +0200
commit335dfab2c68637ec73f8d0e6aaee3dcc3aae7e8e (patch)
treef45b9df387b5256d51a32aa426a8fe10c09b2f34 /php-aws-sdk3.spec
parent8927fcd20bb10cfa4af940b4981868acc2841eb1 (diff)
v3.30.0 (backported from Fedora)
Diffstat (limited to 'php-aws-sdk3.spec')
-rw-r--r--php-aws-sdk3.spec24
1 files changed, 16 insertions, 8 deletions
diff --git a/php-aws-sdk3.spec b/php-aws-sdk3.spec
index b2e438e..5e7b4bf 100644
--- a/php-aws-sdk3.spec
+++ b/php-aws-sdk3.spec
@@ -12,8 +12,8 @@
%global github_owner aws
%global github_name aws-sdk-php
-%global github_version 3.29.9
-%global github_commit fdb015e0905fccf25b35a78e6fda02673df97dc8
+%global github_version 3.30.0
+%global github_commit c84ce7a758ce3bbe8ff54abfa2e0646941fe5fc4
%global composer_vendor aws
%global composer_project aws-sdk-php
@@ -98,12 +98,14 @@ BuildRequires: php-openssl
BuildRequires: php-pcre
BuildRequires: php-simplexml
BuildRequires: php-spl
-## phpcompatinfo (computed from version 3.26.0)
+## phpcompatinfo (computed from version 3.30.0)
BuildRequires: php-curl
BuildRequires: php-date
BuildRequires: php-filter
BuildRequires: php-hash
+BuildRequires: php-iconv
BuildRequires: php-libxml
+BuildRequires: php-mbstring
BuildRequires: php-reflection
BuildRequires: php-session
BuildRequires: php-xml
@@ -120,12 +122,14 @@ Requires: php-composer(guzzlehttp/psr7) < %{guzzle_psr7_max_ver}
Requires: php-composer(guzzlehttp/psr7) >= %{guzzle_psr7_min_ver}
Requires: php-composer(mtdowling/jmespath.php) < %{jmespath_max_ver}
Requires: php-composer(mtdowling/jmespath.php) >= %{jmespath_min_ver}
-# phpcompatinfo (computed from version 3.26.0)
+# phpcompatinfo (computed from version 3.30.0)
Requires: php-date
Requires: php-filter
Requires: php-hash
+Requires: php-iconv
Requires: php-json
Requires: php-libxml
+Requires: php-mbstring
Requires: php-pcre
Requires: php-session
Requires: php-simplexml
@@ -235,11 +239,12 @@ export AWS_ACCESS_KEY_ID=foo
export AWS_SECRET_ACCESS_KEY=bar
: Upstream tests
-RETURN_CODE=0
# 7.2: There were 8 errors:
-for PHP_CLI in php php56 php70 php71; do
- if which $PHP_CLI; then
- $PHP_CLI %{_bindir}/phpunit -d memory_limit=1G --verbose --testsuite=unit \
+RETURN_CODE=0
+PHPUNIT=$(which phpunit)
+for PHP_EXEC in "" php56 php70 php71; do
+ if [ -z "$PHP_EXEC" ] || which $PHP_EXEC; then
+ $PHP_EXEC $PHPUNIT -d memory_limit=1G --verbose --testsuite=unit \
--bootstrap bootstrap.php || RETURN_CODE=1
fi
done
@@ -260,6 +265,9 @@ exit $RETURN_CODE
%changelog
+* Wed Jun 21 2017 Shawn Iwinski <shawn@iwin.ski> - 3.30.0-1
+- Updated to 3.30.0 (RHBZ #1449422)
+
* Wed Jun 21 2017 Remi Collet <remi@remirepo.net> - 3.29.9-1
- Update to 3.29.9