summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-02-24 08:59:14 +0100
committerRemi Collet <remi@remirepo.net>2020-02-24 08:59:14 +0100
commit8c9069ba7407068a5897b0bae8a83d69dc8bb8fd (patch)
treef36d3a1c6456f9c189d1f9e34e8b7fee69ca9a1b
parenteb7f4ac5eef50f2c9f437b0aa5595df8aa59c50c (diff)
v3.133.20 from Fedora
-rw-r--r--composer.json9
-rw-r--r--php-aws-sdk3.spec49
2 files changed, 37 insertions, 21 deletions
diff --git a/composer.json b/composer.json
index 20e3353..09018b6 100644
--- a/composer.json
+++ b/composer.json
@@ -17,10 +17,10 @@
},
"require": {
"php": ">=5.5",
- "guzzlehttp/guzzle": "^5.3.3|^6.2.1",
+ "guzzlehttp/guzzle": "^5.3.3|^6.2.1|^7.0",
"guzzlehttp/psr7": "^1.4.1",
- "guzzlehttp/promises": "~1.0",
- "mtdowling/jmespath.php": "~2.2",
+ "guzzlehttp/promises": "^1.0",
+ "mtdowling/jmespath.php": "^2.5",
"ext-pcre": "*",
"ext-json": "*",
"ext-simplexml": "*"
@@ -37,7 +37,8 @@
"nette/neon": "^2.3",
"andrewsville/php-token-reflection": "^1.4",
"psr/cache": "^1.0",
- "psr/simple-cache": "^1.0"
+ "psr/simple-cache": "^1.0",
+ "sebastian/comparator": "^1.2.3"
},
"suggest": {
"ext-openssl": "Allows working with CloudFront private distributions and verifying received SNS messages",
diff --git a/php-aws-sdk3.spec b/php-aws-sdk3.spec
index d4b5833..a59c082 100644
--- a/php-aws-sdk3.spec
+++ b/php-aws-sdk3.spec
@@ -2,7 +2,7 @@
#
# Fedora spec file for php-aws-sdk3
#
-# Copyright (c) 2016-2019 Shawn Iwinski <shawn@iwin.ski>
+# Copyright (c) 2016-2020 Shawn Iwinski <shawn@iwin.ski>
#
# License: MIT
# http://opensource.org/licenses/MIT
@@ -12,8 +12,8 @@
%global github_owner aws
%global github_name aws-sdk-php
-%global github_version 3.111.0
-%global github_commit a31376012346118b2b88df6d2f0c185af71e3096
+%global github_version 3.133.20
+%global github_commit c5f84f9edafb6372dafdbc87cb588772761179ca
%global composer_vendor aws
%global composer_project aws-sdk-php
@@ -30,17 +30,17 @@
# NOTE: Min version not 1.4 because autoloader required
%global doctrine_cache_min_ver 1.4.1
%global doctrine_cache_max_ver 2.0
-# "guzzlehttp/guzzle": "^5.3.3|^6.2.1"
+# "guzzlehttp/guzzle": "^5.3.3|^6.2.1|^7.0"
%global guzzle_min_ver 5.3.3
-%global guzzle_max_ver 7.0
-# "guzzlehttp/promises": "~1.0"
+%global guzzle_max_ver 8.0
+# "guzzlehttp/promises": "^1.0"
%global guzzle_promises_min_ver 1.0
%global guzzle_promises_max_ver 2.0
# "guzzlehttp/psr7": "^1.4.1"
%global guzzle_psr7_min_ver 1.4.1
%global guzzle_psr7_max_ver 2.0
-# "mtdowling/jmespath.php": "~2.2"
-%global jmespath_min_ver 2.2
+# "mtdowling/jmespath.php": "^2.5"
+%global jmespath_min_ver 2.5
%global jmespath_max_ver 3.0
# "psr/cache": "^1.0"
%global psr_cache_min_ver 1.0
@@ -52,6 +52,13 @@
# Build using "--without tests" to disable tests
%global with_tests 0%{!?_without_tests:1}
+# Range dependencies supported?
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+%global with_range_dependencies 1
+%else
+%global with_range_dependencies 0
+%endif
+
%{!?phpdir: %global phpdir %{_datadir}/php}
Name: php-aws-sdk3
@@ -72,7 +79,7 @@ BuildArch: noarch
BuildRequires: php-cli
## composer.json
BuildRequires: php(language) >= %{php_min_ver}
-%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+%if %{with_range_dependencies}
BuildRequires: (php-composer(guzzlehttp/guzzle) >= %{guzzle_min_ver} with php-composer(guzzlehttp/guzzle) < %{guzzle_max_ver})
BuildRequires: (php-composer(guzzlehttp/promises) >= %{guzzle_promises_min_ver} with php-composer(guzzlehttp/promises) < %{guzzle_promises_max_ver})
BuildRequires: (php-composer(guzzlehttp/psr7) >= %{guzzle_psr7_min_ver} with php-composer(guzzlehttp/psr7) < %{guzzle_psr7_max_ver})
@@ -95,7 +102,7 @@ BuildRequires: php-composer(fedora/autoloader)
BuildRequires: php-composer(theseer/autoload)
## composer.json
BuildRequires: php-composer(phpunit/phpunit)
-%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+%if %{with_range_dependencies}
BuildRequires: (php-composer(andrewsville/php-token-reflection) >= %{tokenreflection_min_ver} with php-composer(andrewsville/php-token-reflection) < %{tokenreflection_max_ver})
BuildRequires: (php-composer(aws/aws-php-sns-message-validator) >= %{aws_sns_message_validator_min_ver} with php-composer(aws/aws-php-sns-message-validator) < %{aws_sns_message_validator_max_ver})
BuildRequires: (php-composer(doctrine/cache) >= %{doctrine_cache_min_ver} with php-composer(doctrine/cache) < %{doctrine_cache_max_ver})
@@ -113,6 +120,7 @@ BuildRequires: php-composer(psr/cache) >= %{psr_cache_min_ver}
BuildRequires: php-composer(psr/simple-cache) < %{psr_simple_cache_max_ver}
BuildRequires: php-composer(psr/simple-cache) >= %{psr_simple_cache_min_ver}
%endif
+BuildRequires: php-curl
BuildRequires: php-dom
BuildRequires: php-json
BuildRequires: php-openssl
@@ -120,8 +128,7 @@ BuildRequires: php-pcntl
BuildRequires: php-pcre
BuildRequires: php-simplexml
BuildRequires: php-sockets
-## phpcompatinfo (computed from version 3.87.15)
-BuildRequires: php-curl
+## phpcompatinfo (computed from version 3.133.20)
BuildRequires: php-date
BuildRequires: php-filter
BuildRequires: php-hash
@@ -131,14 +138,16 @@ BuildRequires: php-mbstring
BuildRequires: php-posix
BuildRequires: php-reflection
BuildRequires: php-session
+BuildRequires: php-soap
BuildRequires: php-spl
+BuildRequires: php-tidy
BuildRequires: php-xml
BuildRequires: php-xmlwriter
%endif
# composer.json
Requires: php(language) >= %{php_min_ver}
-%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+%if %{with_range_dependencies}
Requires: (php-composer(guzzlehttp/guzzle) >= %{guzzle_min_ver} with php-composer(guzzlehttp/guzzle) < %{guzzle_max_ver})
Requires: (php-composer(guzzlehttp/promises) >= %{guzzle_promises_min_ver} with php-composer(guzzlehttp/promises) < %{guzzle_promises_max_ver})
Requires: (php-composer(guzzlehttp/psr7) >= %{guzzle_psr7_min_ver} with php-composer(guzzlehttp/psr7) < %{guzzle_psr7_max_ver})
@@ -156,7 +165,7 @@ Requires: php-composer(mtdowling/jmespath.php) >= %{jmespath_min_ver}
Requires: php-json
Requires: php-pcre
Requires: php-simplexml
-# phpcompatinfo (computed from version 3.87.15)
+# phpcompatinfo (computed from version 3.133.20)
Requires: php-date
Requires: php-filter
Requires: php-hash
@@ -166,6 +175,7 @@ Requires: php-mbstring
Requires: php-reflection
Requires: php-session
Requires: php-spl
+Requires: php-tidy
Requires: php-xmlwriter
# Autoloader
Requires: php-composer(fedora/autoloader)
@@ -212,6 +222,7 @@ require_once '%{phpdir}/Fedora/Autoloader/autoload.php';
\Fedora\Autoloader\Dependencies::required([
__DIR__.'/functions.php',
[
+ '%{phpdir}/GuzzleHttp7/autoload.php',
'%{phpdir}/GuzzleHttp6/autoload.php',
'%{phpdir}/GuzzleHttp/autoload.php',
],
@@ -280,7 +291,8 @@ sed -e 's/function testTracksAwsSpecificExceptions/function SKIP_testTracksAwsSp
-i tests/TraceMiddlewareTest.php
rm -f \
tests/Integ/GuzzleV5HandlerTest.php \
- tests/Integ/GuzzleV6StreamHandlerTest.php
+ tests/Integ/GuzzleV6StreamHandlerTest.php \
+ tests/S3/Crypto/S3EncryptionClientTest.php
: Skip tests that include 64-bit format codes on 32-bit PHP
if [ $(php -r 'echo PHP_INT_SIZE === 4 ? 32 : 64;') == 32 ]
@@ -305,8 +317,7 @@ export AWS_SECRET_ACCESS_KEY=bar
: Upstream tests
RETURN_CODE=0
PHPUNIT=$(which phpunit)
-# TODO 7.4 PHP Fatal error: Method GuzzleHttp\Psr7\CachingStream::__toString() must not throw an exception
-for PHP_EXEC in "" php71 php72 php73; do
+for PHP_EXEC in "" php72 php73 php74; do
if [ -z "$PHP_EXEC" ] || which $PHP_EXEC; then
$PHP_EXEC $PHPUNIT -d memory_limit=1G --verbose --testsuite=unit \
--bootstrap bootstrap.php || RETURN_CODE=1
@@ -329,6 +340,10 @@ exit $RETURN_CODE
%changelog
+* Sat Feb 22 2020 Shawn Iwinski <shawn@iwin.ski> - 3.133.20-1
+- Update to 3.133.20 (RHBZ #1750925)
+- Fix FTBFS (RHBZ #1799865)
+
* Mon Sep 09 2019 Shawn Iwinski <shawn@iwin.ski> - 3.111.0-1
- Update to 3.111.0 (RHBZ #1714768)