summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-02-22 11:33:58 +0100
committerRemi Collet <remi@remirepo.net>2019-02-22 11:33:58 +0100
commit02c38f125c7fa30fdbc3470a3dcd642caf17118c (patch)
tree6bd744df1483d9fbb3a734103e9e34ac4c0c2f86
parent04b3738dd511024cb2a8403d9f0f050e7f1d9ab4 (diff)
From Fedora:
* Thu Feb 21 2019 Shawn Iwinski <shawn@iwin.ski> - 3.87.15-1 - Update to 3.87.15 (RHBZ #1599469) - Remove php-composer(nette/neon) dependency
-rw-r--r--composer.json8
-rw-r--r--php-aws-sdk3.spec55
2 files changed, 41 insertions, 22 deletions
diff --git a/composer.json b/composer.json
index fc223b7..ca5dc4b 100644
--- a/composer.json
+++ b/composer.json
@@ -17,18 +17,19 @@
},
"require": {
"php": ">=5.5",
- "guzzlehttp/guzzle": "^5.3.1|^6.2.1",
+ "guzzlehttp/guzzle": "^5.3.3|^6.2.1",
"guzzlehttp/psr7": "^1.4.1",
"guzzlehttp/promises": "~1.0",
"mtdowling/jmespath.php": "~2.2",
"ext-pcre": "*",
"ext-json": "*",
- "ext-simplexml": "*",
- "ext-spl": "*"
+ "ext-simplexml": "*"
},
"require-dev": {
"ext-openssl": "*",
"ext-dom": "*",
+ "ext-pcntl": "*",
+ "ext-sockets": "*",
"phpunit/phpunit": "^4.8.35|^5.4.3",
"behat/behat": "~3.0",
"doctrine/cache": "~1.4",
@@ -40,6 +41,7 @@
"suggest": {
"ext-openssl": "Allows working with CloudFront private distributions and verifying received SNS messages",
"ext-curl": "To send requests using cURL",
+ "ext-sockets": "To use client-side monitoring",
"doctrine/cache": "To use the DoctrineCacheAdapter",
"aws/aws-php-sns-message-validator": "To validate incoming SNS notifications"
},
diff --git a/php-aws-sdk3.spec b/php-aws-sdk3.spec
index f6533c7..4db255e 100644
--- a/php-aws-sdk3.spec
+++ b/php-aws-sdk3.spec
@@ -2,7 +2,7 @@
#
# Fedora spec file for php-aws-sdk3
#
-# Copyright (c) 2016-2018 Shawn Iwinski <shawn@iwin.ski>
+# Copyright (c) 2016-2019 Shawn Iwinski <shawn@iwin.ski>
#
# License: MIT
# http://opensource.org/licenses/MIT
@@ -12,8 +12,8 @@
%global github_owner aws
%global github_name aws-sdk-php
-%global github_version 3.62.10
-%global github_commit b45b916eceb20d3c9e2b36e9e93e926a278d97ca
+%global github_version 3.87.15
+%global github_commit 21a4dd314e2a3c44b5538dd56d3770733a3d03e6
%global composer_vendor aws
%global composer_project aws-sdk-php
@@ -30,8 +30,8 @@
# NOTE: Min version not 1.4 because autoloader required
%global doctrine_cache_min_ver 1.4.1
%global doctrine_cache_max_ver 2.0
-# "guzzlehttp/guzzle": "^5.3.1|^6.2.1"
-%global guzzle_min_ver 5.3.1
+# "guzzlehttp/guzzle": "^5.3.3|^6.2.1"
+%global guzzle_min_ver 5.3.3
%global guzzle_max_ver 7.0
# "guzzlehttp/promises": "~1.0"
%global guzzle_promises_min_ver 1.0
@@ -42,9 +42,6 @@
# "mtdowling/jmespath.php": "~2.2"
%global jmespath_min_ver 2.2
%global jmespath_max_ver 3.0
-# "nette/neon": "^2.3"
-%global nette_neon_min_ver 2.3
-%global nette_neon_max_ver 3.0
# "psr/cache": "^1.0"
%global psr_cache_min_ver 1.0
%global psr_cache_max_ver 2.0
@@ -59,7 +56,6 @@ Version: %{github_version}
Release: 1%{?dist}
Summary: Amazon Web Services framework for PHP
-Group: Development/Libraries
License: ASL 2.0
URL: http://aws.amazon.com/sdkforphp
@@ -100,7 +96,6 @@ BuildRequires: php-composer(phpunit/phpunit)
BuildRequires: (php-composer(andrewsville/php-token-reflection) >= %{tokenreflection_min_ver} with php-composer(andrewsville/php-token-reflection) < %{tokenreflection_max_ver})
BuildRequires: (php-composer(aws/aws-php-sns-message-validator) >= %{aws_sns_message_validator_min_ver} with php-composer(aws/aws-php-sns-message-validator) < %{aws_sns_message_validator_max_ver})
BuildRequires: (php-composer(doctrine/cache) >= %{doctrine_cache_min_ver} with php-composer(doctrine/cache) < %{doctrine_cache_max_ver})
-BuildRequires: (php-composer(nette/neon) >= %{nette_neon_min_ver} with php-composer(nette/neon) < %{nette_neon_max_ver})
BuildRequires: (php-composer(psr/cache) >= %{psr_cache_min_ver} with php-composer(psr/cache) < %{psr_cache_max_ver})
%else
BuildRequires: php-composer(andrewsville/php-token-reflection) < %{tokenreflection_max_ver}
@@ -109,18 +104,17 @@ BuildRequires: php-composer(aws/aws-php-sns-message-validator) < %{aws_sns_mess
BuildRequires: php-composer(aws/aws-php-sns-message-validator) >= %{aws_sns_message_validator_min_ver}
BuildRequires: php-composer(doctrine/cache) < %{doctrine_cache_max_ver}
BuildRequires: php-composer(doctrine/cache) >= %{doctrine_cache_min_ver}
-BuildRequires: php-composer(nette/neon) < %{nette_neon_max_ver}
-BuildRequires: php-composer(nette/neon) >= %{nette_neon_min_ver}
BuildRequires: php-composer(psr/cache) < %{psr_cache_max_ver}
BuildRequires: php-composer(psr/cache) >= %{psr_cache_min_ver}
%endif
BuildRequires: php-dom
BuildRequires: php-json
BuildRequires: php-openssl
+BuildRequires: php-pcntl
BuildRequires: php-pcre
BuildRequires: php-simplexml
-BuildRequires: php-spl
-## phpcompatinfo (computed from version 3.36.20)
+BuildRequires: php-sockets
+## phpcompatinfo (computed from version 3.87.15)
BuildRequires: php-curl
BuildRequires: php-date
BuildRequires: php-filter
@@ -128,8 +122,10 @@ BuildRequires: php-hash
BuildRequires: php-iconv
BuildRequires: php-libxml
BuildRequires: php-mbstring
+BuildRequires: php-posix
BuildRequires: php-reflection
BuildRequires: php-session
+BuildRequires: php-spl
BuildRequires: php-xml
BuildRequires: php-xmlwriter
%endif
@@ -154,15 +150,16 @@ Requires: php-composer(mtdowling/jmespath.php) >= %{jmespath_min_ver}
Requires: php-json
Requires: php-pcre
Requires: php-simplexml
-Requires: php-spl
-# phpcompatinfo (computed from version 3.36.20)
+# phpcompatinfo (computed from version 3.87.15)
Requires: php-date
Requires: php-filter
Requires: php-hash
Requires: php-iconv
Requires: php-libxml
Requires: php-mbstring
+Requires: php-reflection
Requires: php-session
+Requires: php-spl
Requires: php-xmlwriter
# Autoloader
Requires: php-composer(fedora/autoloader)
@@ -172,6 +169,7 @@ Requires: php-composer(fedora/autoloader)
%if 0%{?fedora} >= 21
Suggests: php-curl
Suggests: php-openssl
+Suggests: php-sockets
Suggests: php-composer(doctrine/cache)
Suggests: php-composer(aws/aws-php-sns-message-validator)
%endif
@@ -254,15 +252,18 @@ require_once '%{buildroot}%{phpdir}/Aws3/autoload.php';
\Fedora\Autoloader\Dependencies::required([
__DIR__.'/bootstrap.classmap.php',
- '%{phpdir}/Nette/Neon/autoload.php',
'%{phpdir}/Psr/Cache/autoload.php',
]);
+
+class_alias('PHPUnit_Framework_Error_Warning', 'PHPUnit\\Framework\\Error\\Warning');
+class_alias('PHPUnit_Framework_Constraint_Callback', 'PHPUnit\\Framework\\Constraint\\Callback');
BOOTSTRAP
: Skip tests known to fail
sed 's/function testValidatesInput/function SKIP_testValidatesInput/' \
-i tests/Api/ValidatorTest.php
-sed -e 's/function testValidatesCallables/function SKIP_testValidatesCallables/' \
+sed -e 's/function testUserAgentAlwaysStartsWithSdkAgentString/function SKIP_testUserAgentAlwaysStartsWithSdkAgentString/' \
+ -e 's/function testValidatesCallables/function SKIP_testValidatesCallables/' \
-e 's/function testValidatesInput/function SKIP_testValidatesInput/' \
-i tests/ClientResolverTest.php
sed 's/function testEmitsDebugInfo/function SKIP_testEmitsDebugInfo/' \
@@ -274,13 +275,25 @@ rm -f \
tests/Integ/GuzzleV5HandlerTest.php \
tests/Integ/GuzzleV6StreamHandlerTest.php
+: Skip tests that include 64-bit format codes on 32-bit PHP
+if [ $(php -r 'echo PHP_INT_SIZE === 4 ? 32 : 64;') == 32 ]
+then
+ sed -e 's/function testPassesComplianceTest/function SKIP_testPassesComplianceTest/' \
+ -e 's/function testEmitsEvents/function SKIP_testEmitsEvents/' \
+ -e 's/function testThrowsOnUnknownEventType/function SKIP_testThrowsOnUnknownEventType/' \
+ -i tests/Api/Parser/DecodingEventStreamIteratorTest.php
+ sed -e 's/function testEmitsEvents/function SKIP_testEmitsEvents/' \
+ -e 's/function testThrowsOnUnknownEventType/function SKIP_testThrowsOnUnknownEventType/' \
+ -i tests/Api/Parser/EventParsingIteratorTest.php
+fi
+
export AWS_ACCESS_KEY_ID=foo
export AWS_SECRET_ACCESS_KEY=bar
: Upstream tests
RETURN_CODE=0
PHPUNIT=$(which phpunit)
-for PHP_EXEC in "" php70 php71 php72; do
+for PHP_EXEC in "" php70 php71 php72 php73; do
if [ -z "$PHP_EXEC" ] || which $PHP_EXEC; then
$PHP_EXEC $PHPUNIT -d memory_limit=1G --verbose --testsuite=unit \
--bootstrap bootstrap.php || RETURN_CODE=1
@@ -303,6 +316,10 @@ exit $RETURN_CODE
%changelog
+* Thu Feb 21 2019 Shawn Iwinski <shawn@iwin.ski> - 3.87.15-1
+- Update to 3.87.15 (RHBZ #1599469)
+- Remove php-composer(nette/neon) dependency
+
* Sat Jul 07 2018 Shawn Iwinski <shawn@iwin.ski> - 3.62.10-1
- Update to 3.62.10 (RHBZ #1563020)