summaryrefslogtreecommitdiffstats
path: root/php-aws-sdk.spec
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2013-12-30 10:17:11 +0100
committerRemi Collet <fedora@famillecollet.com>2013-12-30 10:17:11 +0100
commitbe70006cc94187965924e614ae06ece35a704293 (patch)
tree1d40fedf916b04e4e21f9b273defee572b98371d /php-aws-sdk.spec
parentb12e6fdcecdaedb103b9c555acc0224f488c2020 (diff)
php-aws-sdk: 2.5.0 (backport)
Diffstat (limited to 'php-aws-sdk.spec')
-rw-r--r--php-aws-sdk.spec77
1 files changed, 54 insertions, 23 deletions
diff --git a/php-aws-sdk.spec b/php-aws-sdk.spec
index 69c27fc..5fc8072 100644
--- a/php-aws-sdk.spec
+++ b/php-aws-sdk.spec
@@ -3,15 +3,12 @@
%global channelname pear.amazonwebservices.com
Name: php-aws-sdk
-Version: 1.6.2
-Release: 4%{?dist}
+Version: 2.5.0
+Release: 1%{?dist}
Summary: Amazon Web Services framework for PHP
Group: Development/Libraries
-#The entire source code is ASL 2.0 except
-# lib/cachecore/, lib/requestcore/, lib/yaml/ which are BSD
-# lib/dom/ which is MIT
-License: ASL 2.0 and BSD and MIT
+License: ASL 2.0
URL: http://aws.amazon.com/sdkforphp/
Source0: http://pear.amazonwebservices.com/get/sdk-%{version}.tgz
@@ -26,34 +23,50 @@ Requires(postun): %{__pear}
Requires: php(language) >= 5.2
Requires: php-pear(PEAR)
Requires: php-channel(%{channelname})
-Requires: php-xml
-Requires: php-mbstring
Requires: php-pdo
-Requires: php-pecl-apc
-Requires: php-pecl-memcache
-Requires: php-pecl-memcached
-Requires: php-xcache
-
+Requires: php-reflection
+Requires: php-spl
+Requires: php-simplexml
+Requires: php-ctype
+Requires: php-curl
+Requires: php-date
+Requires: php-dom
+Requires: php-hash
+Requires: php-json
+Requires: php-libxml
+Requires: php-mbstring
+Requires: php-openssl
+Requires: php-pcre
+Requires: php-session
+Requires: php-sqlite3
+Requires: php-Monolog
+Requires: php-symfony2-Yaml
+Requires: php-guzzle-Guzzle >= 3.7.0
+Requires: php-guzzle-Guzzle < 3.8
Provides: php-pear(%{pear_name}) = %{version}
Provides: php-pear(%{channelname}/%{pear_name}) = %{version}
%description
-Amazon Web Services SDK for PHP enables developers to build solutions for
-Amazon Simple Storage Service (Amazon S3), Amazon Elastic Compute Cloud
+Amazon Web Services SDK for PHP enables developers to build solutions for
+Amazon Simple Storage Service (Amazon S3), Amazon Elastic Compute Cloud
(Amazon EC2), Amazon SimpleDB, and more.
%prep
%setup -q -c
+# fix doc roles
sed -e '/_samples/s/role="php"/role="doc"/' \
- -e '/_docs/s/role="php"/role="doc"/' \
- -e '/_compatibility_test/s/role="php"/role="doc"/' \
- -e '/_sql/s/role="php"/role="doc"/' \
- -e '/LICENSE/s/role="php"/role="doc"/' \
- -e '/README/s/role="php"/role="doc"/' \
- package.xml >%{pear_name}-%{version}/%{name}.xml
+ -e '/sdk.class.php/s/md5sum="[0-9,a-z]\{32\}"//' \
+ -e '/_docs/s/role="php"/role="doc"/' \
+ -e '/_compatibility_test/s/role="php"/role="doc"/' \
+ -e '/_sql/s/role="php"/role="doc"/' \
+ -e '/LICENSE/s/role="php"/role="doc"/' \
+ -e '/README/s/role="php"/role="doc"/' \
+ package.xml >%{pear_name}-%{version}/%{name}.xml
+#remove aws.phar
+rm %{pear_name}-%{version}/aws.phar
%build
# Empty build section, most likely nothing required.
@@ -84,12 +97,30 @@ fi
%files
%defattr(-,root,root,-)
-%doc %{pear_docdir}/%{pear_name}
%{pear_xmldir}/%{name}.xml
%{pear_phpdir}/AWSSDKforPHP/
%changelog
+* Mon Dec 30 2013 Remi Collet <remi@fedoraproject.org> - 2.5.0-1
+- backport 2.5.0 for remi repo
+
+* Sun Dec 29 2013 Joseph Marrero <jmarrero@fedoraproject.org> - 2.5.0-1
+- update to latest upstrean version
+
+* Mon Nov 18 2013 Joseph Marrero <jmarrero@fedoraproject.org> - 2.4.10-1
+- update to latest upstream version
+- add php-symfony2-Yaml(version2) and php-Monolog
+- remove dependency php-symfony2-YAML(version1)
+- set version contraint for php-guzzle-Guzzle dependency
+
+* Mon Sep 09 2013 Joseph Marrero <jmarrero@fedoraproject.org> - 2.4.5-2
+- add guzzle dependency.
+- remove aws.phar file
+
+* Thu Sep 05 2013 Joseph Marrero <jmarrero@fedoraproject.org> - 2.4.5-1
+- Update to 2.4.5
+
* Sat May 04 2013 Remi Collet <remi@fedoraproject.org> - 1.6.2-4
- backport 1.6.2 for remi repo
@@ -97,7 +128,7 @@ fi
- Add dependencies
- Add license clarification
* Tue Apr 30 2013 Joseph Marrero <jmarrero@fedoraproject.org> - 1.6.2-3
-- Fix Source, remove empty folder _doc
+- Fix Source, remove empty folder _doc
* Mon Apr 29 2013 Joseph Marrero <jmarrero@fedoraproject.org> - 1.6.2-2
- Fix License, Fix Description, move doc files
* Mon Apr 29 2013 Joseph Marrero <jmarrero@fedoraproject.org> - 1.6.2-1