summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-04-12 12:31:29 +0200
committerRemi Collet <fedora@famillecollet.com>2016-04-12 12:31:29 +0200
commite077fcb752e5100c4cd17e556e8a47024935e7cc (patch)
tree86baf1d64ee3d77a0e4bd643f8a9d855a78e7fc6
parent05cc49bd47a9be587158c0d02db01bcdc043e4a9 (diff)
php-aws-sdk: 2.8.29
-rw-r--r--composer.json42
-rw-r--r--php-aws-sdk.spec7
2 files changed, 47 insertions, 2 deletions
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..4146c35
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,42 @@
+{
+ "name": "aws/aws-sdk-php",
+ "homepage": "http://aws.amazon.com/sdkforphp",
+ "description": "AWS SDK for PHP - Use Amazon Web Services in your PHP project",
+ "keywords": ["aws","amazon","sdk","s3","ec2","dynamodb","cloud","glacier"],
+ "type": "library",
+ "license": "Apache-2.0",
+ "authors": [
+ {
+ "name": "Amazon Web Services",
+ "homepage": "http://aws.amazon.com"
+ }
+ ],
+ "support": {
+ "forum": "https://forums.aws.amazon.com/forum.jspa?forumID=80",
+ "issues": "https://github.com/aws/aws-sdk-php/issues"
+ },
+ "require": {
+ "php": ">=5.3.3",
+ "guzzle/guzzle": "~3.7"
+ },
+ "suggest": {
+ "doctrine/cache": "Adds support for caching of credentials and responses",
+ "ext-apc": "Allows service description opcode caching, request and response caching, and credentials caching",
+ "ext-openssl": "Allows working with CloudFront private distributions and verifying received SNS messages",
+ "monolog/monolog": "Adds support for logging HTTP requests and responses",
+ "symfony/yaml": "Eases the ability to write manifests for creating jobs in AWS Import/Export"
+ },
+ "require-dev": {
+ "ext-openssl": "*",
+ "doctrine/cache": "~1.0",
+ "monolog/monolog": "~1.4",
+ "phpunit/phpunit": "~4.0",
+ "phpunit/phpunit-mock-objects": "2.3.1",
+ "symfony/yaml": "~2.1"
+ },
+ "autoload": {
+ "psr-0": {
+ "Aws": "src/"
+ }
+ }
+}
diff --git a/php-aws-sdk.spec b/php-aws-sdk.spec
index de2d635..3b46573 100644
--- a/php-aws-sdk.spec
+++ b/php-aws-sdk.spec
@@ -14,8 +14,8 @@
%global github_owner aws
%global github_name aws-sdk-php
-%global github_version 2.8.28
-%global github_commit cdc2c4f55b7c89b9bfd9899c3116b369d2e6fe63
+%global github_version 2.8.29
+%global github_commit 83b86d1bbbca452b00a1f0bbea6fcbb506c76650
%global composer_vendor aws
%global composer_project aws-sdk-php
@@ -194,6 +194,9 @@ rm -rf %{buildroot}
%changelog
+* Tue Apr 12 2016 Remi Collet <remi@fedoraproject.org> - 2.8.29-1
+- Update to 2.8.29
+
* Wed Apr 6 2016 Remi Collet <remi@fedoraproject.org> - 2.8.28-1
- Update to 2.8.28