summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-04-16 07:24:07 +0200
committerRemi Collet <fedora@famillecollet.com>2016-04-16 07:24:07 +0200
commit7a40330cace135e9c642f50ab275e02f31118df0 (patch)
treeaf6ce2076beb0a04d2425b10a1f0b0b32c6674f1
parent0080b3e937a134c91c3f9d6edd5a40c8b843d0cd (diff)
php-aws-php-sns-message-validator: backport
-rw-r--r--Makefile4
-rw-r--r--php-aws-php-sns-message-validator.spec16
2 files changed, 20 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/php-aws-php-sns-message-validator.spec b/php-aws-php-sns-message-validator.spec
index 3e1f1ca..6ea9012 100644
--- a/php-aws-php-sns-message-validator.spec
+++ b/php-aws-php-sns-message-validator.spec
@@ -1,3 +1,4 @@
+# remirepo spec file for php-aws-php-sns-message-validator, from:
#
# Fedora spec file for php-aws-php-sns-message-validator
#
@@ -35,6 +36,7 @@ License: ASL 2.0
URL: https://github.com/%{github_owner}/%{github_name}
Source0: %{url}/archive/%{github_commit}/%{name}-%{github_version}-%{github_commit}.tar.gz
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
# Tests
%if %{with_tests}
@@ -107,6 +109,8 @@ AUTOLOAD
%install
+rm -rf %{buildroot}
+
mkdir -p %{buildroot}%{phpdir}/Aws/Sns
cp -rp src/* %{buildroot}%{phpdir}/Aws/Sns/
@@ -125,12 +129,21 @@ $fedoraClassLoader->addPrefix('Aws\\Sns\\', __DIR__.'/tests-psr0');
BOOTSTRAP
%{_bindir}/phpunit --verbose --bootstrap bootstrap.php
+
+if which php70; then
+ php70 %{_bindir}/phpunit --verbose --bootstrap bootstrap.php
+fi
%else
: Tests skipped
%endif
+%clean
+rm -rf %{buildroot}
+
+
%files
+%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license LICENSE.md
%doc composer.json
@@ -140,5 +153,8 @@ BOOTSTRAP
%changelog
+* Sat Apr 16 2016 Remi Collet <remi@remirepo.net> - 1.1.0-1
+- backport for remi repository
+
* Mon Apr 11 2016 Shawn Iwinski <shawn@iwin.ski> - 1.1.0-1
- Initial package