summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-08-08 13:45:34 +0200
committerRemi Collet <remi@remirepo.net>2017-08-08 13:45:34 +0200
commit6c3e5957cb1a5a560b6f80f504b15ee902c16f49 (patch)
tree777576828722afc6dc921f08213d499182112c77
parent49114a66f18c1b57dfaee3e70fe6bc8db656dc1c (diff)
v3.4.0
-rw-r--r--.gitignore7
-rw-r--r--composer.json3
-rw-r--r--php-aura-di.spec39
3 files changed, 22 insertions, 27 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..1ab5c4f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/composer.json b/composer.json
index 37ddd36..bfccc6c 100644
--- a/composer.json
+++ b/composer.json
@@ -28,7 +28,8 @@
},
"require-dev": {
"mouf/picotainer": "~1.0",
- "acclimate/container": "~1.0"
+ "acclimate/container": "~1.0",
+ "phpunit/phpunit": "~5.7 || ~4.8"
},
"autoload-dev": {
"psr-4": {
diff --git a/php-aura-di.spec b/php-aura-di.spec
index 60bd503..636fe57 100644
--- a/php-aura-di.spec
+++ b/php-aura-di.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 76824bdeae99e46e6ae06f29e4bdf86063da86b9
+%global gh_commit f676b38a0d1c3b0d7897b0a082f4811eb8b08faa
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner auraphp
%global gh_project Aura.Di
@@ -19,16 +19,15 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{pk_owner}-%{pk_project}
-Version: 3.2.0
+Version: 3.4.0
Release: 1%{?dist}
Summary: A serializable dependency injection container
Group: Development/Libraries
License: MIT
URL: https://github.com/%{gh_owner}/%{gh_project}
-Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{gh_short}.tar.gz
+Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{name}-%{version}-%{gh_short}.tar.gz
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildArch: noarch
BuildRequires: php-composer(fedora/autoloader)
# Tests
@@ -40,7 +39,8 @@ BuildRequires: php-spl
BuildRequires: php-composer(phpunit/phpunit)
# From composer.json, "require-dev": {
# "mouf/picotainer": "~1.0",
-# "acclimate/container": "~1.0"
+# "acclimate/container": "~1.0",
+# "phpunit/phpunit": "~5.7 || ~4.8"
%endif
# From composer, "require": {
@@ -85,8 +85,6 @@ EOF
%install
-rm -rf %{buildroot}
-
mkdir -p %{buildroot}%{php_home}/%{ns_owner}
cp -pr src %{buildroot}%{php_home}/%{ns_owner}/%{ns_project}
@@ -103,33 +101,19 @@ require '%{buildroot}/%{php_home}/%{ns_owner}/%{ns_project}/autoload.php';
\Fedora\Autoloader\Autoload::addPsr4('Aura\\Di\\', dirname(__DIR__) . '/tests');
EOF
-# remirepo:11
-run=0
ret=0
-if which php56; then
- php56 %{_bindir}/phpunit --verbose || ret=1
- run=1
-fi
-if which php71; then
- php71 %{_bindir}/phpunit --verbose || ret=1
- run=1
-fi
-if [ $run -eq 0 ]; then
-%{_bindir}/phpunit --verbose
-# remirepo:2
-fi
+for cmd in php php56 php70 php71 php72; do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit --verbose || ret=1
+ fi
+done
exit $ret
%else
: Test suite disabled
%endif
-%clean
-rm -rf %{buildroot}
-
-
%files
-%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc *.md
@@ -139,6 +123,9 @@ rm -rf %{buildroot}
%changelog
+* Tue Aug 8 2017 Remi Collet <remi@remirepo.net> - 3.4.0-1
+- Update to 3.4.0
+
* Thu Dec 15 2016 Remi Collet <remi@fedoraproject.org> - 3.2.0-1
- update to 3.2.0
- License is now MIT