summaryrefslogtreecommitdiffstats
path: root/php-apigen-theme-bootstrap.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-apigen-theme-bootstrap.spec')
-rw-r--r--php-apigen-theme-bootstrap.spec8
1 files changed, 7 insertions, 1 deletions
diff --git a/php-apigen-theme-bootstrap.spec b/php-apigen-theme-bootstrap.spec
index 7d33a84..57a8044 100644
--- a/php-apigen-theme-bootstrap.spec
+++ b/php-apigen-theme-bootstrap.spec
@@ -6,6 +6,7 @@
#
# Please, preserve the changelog entries
#
+%global bootstrap 1
%global gh_commit 55a35b4a3a9a5fcaa6a8fc43fb304983cab98c6c
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20150717
@@ -33,8 +34,9 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Requires: php-composer(latte/latte) >= 2.2
Requires: php-composer(latte/latte) < 3
# For tree ownership
+%if ! %{bootstrap}
Requires: php-composer(%{composer_vendor}/apigen)
-
+%endif
# Composer
Provides: php-composer(%{composer_vendor}/%{composer_project}) = %{version}
@@ -69,6 +71,10 @@ rm -rf %{buildroot}
%license LICENSE
%doc *.md
%doc composer.json
+%if %{bootstrap}
+%dir %{_datadir}/%{composer_vendor}
+%dir %{_datadir}/%{composer_vendor}/themes
+%endif
%{_datadir}/%{composer_vendor}/themes/%{composer_project}