summaryrefslogtreecommitdiffstats
path: root/php-akamai-open-edgegrid-client.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-09-10 10:52:46 +0200
committerRemi Collet <remi@remirepo.net>2017-09-10 10:52:46 +0200
commite754db0dd82ffc887ea78b8d992918a1b157c401 (patch)
tree4f861284bb4e721e261639f6ccb9e4f31911c514 /php-akamai-open-edgegrid-client.spec
parent22e7b3e97d20f29d2610adfa34841357c6ffb9ca (diff)
v1.0.0 from FedoraHEADmaster
Diffstat (limited to 'php-akamai-open-edgegrid-client.spec')
-rw-r--r--php-akamai-open-edgegrid-client.spec30
1 files changed, 12 insertions, 18 deletions
diff --git a/php-akamai-open-edgegrid-client.spec b/php-akamai-open-edgegrid-client.spec
index bf0a052..69147dd 100644
--- a/php-akamai-open-edgegrid-client.spec
+++ b/php-akamai-open-edgegrid-client.spec
@@ -2,7 +2,7 @@
#
# Fedora spec file for php-akamai-open-edgegrid-client
#
-# Copyright (c) 2016 Shawn Iwinski <shawn@iwin.ski>
+# Copyright (c) 2016-2017 Shawn Iwinski <shawn@iwin.ski>
#
# License: MIT
# http://opensource.org/licenses/MIT
@@ -10,19 +10,17 @@
# Please preserve changelog entries
#
-%global github_owner akamai-open
+%global github_owner akamai
%global github_name AkamaiOPEN-edgegrid-php-client
%global github_version 1.0.0
-%global github_commit cb8ba9da0f0bf6a3fcdc12057f4fd0f5d995d6cb
-%global github_prerelease beta1
-%global github_release .%{github_prerelease}
+%global github_commit a368473f0f73fab96ffee03ee40d2f18694ff526
%global composer_vendor akamai-open
%global composer_project edgegrid-client
# "php": ">=5.5"
%global php_min_ver 5.5
-# "akamai-open/edgegrid-auth": "^1.0.0@beta"
+# "akamai-open/edgegrid-auth": "^1.0.0"
%global akamai_open_edgegrid_auth_min_ver 1.0
%global akamai_open_edgegrid_auth_max_ver 2.0
# "guzzlehttp/guzzle": "^6.1.1"
@@ -43,7 +41,7 @@
Name: php-%{composer_vendor}-%{composer_project}
Version: %{github_version}
-Release: 0.1%{?github_release}%{?dist}
+Release: 1%{?github_release}%{?dist}
Summary: Implements the Akamai {OPEN} EdgeGrid Authentication
Group: Development/Libraries
@@ -51,7 +49,6 @@ License: ASL 2.0
URL: https://github.com/%{github_owner}/%{github_name}
Source0: %{url}/archive/%{github_commit}/%{name}-%{github_version}-%{github_commit}.tar.gz
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
# Autoloader
BuildRequires: php-fedora-autoloader-devel
@@ -134,8 +131,6 @@ AUTOLOAD
%install
-rm -rf %{buildroot}
-
mkdir -p %{buildroot}%{phpdir}/Akamai/Open
cp -rp src %{buildroot}%{phpdir}/Akamai/Open/EdgeGrid
@@ -159,9 +154,10 @@ BOOTSTRAP
: Upstream tests
RETURN_CODE=0
-for PHP_EXEC in php php56 php70 php71; do
- if which $PHP_EXEC; then
- $PHP_EXEC %{_bindir}/phpunit --bootstrap bootstrap.php || RETURN_CODE=1
+PHPUNIT=$(which phpunit)
+for PHP_EXEC in "" php56 php70 php71 php72; do
+ if [ -z "$PHP_EXEC" ] || which $PHP_EXEC; then
+ $PHP_EXEC $PHPUNIT --bootstrap bootstrap.php || RETURN_CODE=1
fi
done
exit $RETURN_CODE
@@ -170,12 +166,7 @@ exit $RETURN_CODE
%endif
-%clean
-rm -rf %{buildroot}
-
-
%files
-%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc *.md
@@ -188,6 +179,9 @@ rm -rf %{buildroot}
%changelog
+* Fri Sep 08 2017 Shawn Iwinski <shawn@iwin.ski> - 1.0.0-1
+- Update to 1.0.0 (RHBZ #1487625)
+
* Sat Mar 11 2017 Shawn Iwinski <shawn@iwin.ski> - 1.0.0-0.1.beta1
- Update to 1.0.0beta1 (RHBZ #1408816)
- Added max versions to BuildRequires dependencies