summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-12-25 09:23:13 +0100
committerRemi Collet <fedora@famillecollet.com>2016-12-25 09:23:13 +0100
commitfd9a1418300d483db35cb1908ab3891e5622aa27 (patch)
treeabce38939b2d7bcf3284444fb4d563ae9fe31acd
parent577820a34848b73ff9e37216ab8f38b3b3eaaf84 (diff)
php-akamai-open-edgegrid-auth: sync with Fedora
-rw-r--r--php-akamai-open-edgegrid-auth.spec44
1 files changed, 18 insertions, 26 deletions
diff --git a/php-akamai-open-edgegrid-auth.spec b/php-akamai-open-edgegrid-auth.spec
index 7c192c6..6db0e58 100644
--- a/php-akamai-open-edgegrid-auth.spec
+++ b/php-akamai-open-edgegrid-auth.spec
@@ -45,7 +45,7 @@ BuildRequires: php-fedora-autoloader-devel
## composer.json
BuildRequires: php(language) >= %{php_min_ver}
BuildRequires: php-composer(phpunit/phpunit)
-## phpcompatinfo (computed from version 0.6.0)
+## phpcompatinfo (computed from version 0.6.1)
BuildRequires: php-date
BuildRequires: php-hash
BuildRequires: php-json
@@ -55,7 +55,7 @@ BuildRequires: php-reflection
# composer.json
Requires: php(language) >= %{php_min_ver}
-# phpcompatinfo (computed from version 0.6.0)
+# phpcompatinfo (computed from version 0.6.1)
Requires: php-date
Requires: php-hash
Requires: php-pcre
@@ -104,31 +104,19 @@ cp -rp src/* %{buildroot}%{phpdir}/Akamai/Open/EdgeGrid/
: Remove logging from PHPUnit config
sed '/log/d' phpunit.xml.dist > phpunit.xml
-%if 0%{?fedora} > 25
-: Temporarily skip test known to fail for PHP 7.1
-: See https://github.com/akamai-open/AkamaiOPEN-edgegrid-php/issues/2
-sed 's/function testTimestampFormat/function SKIP_testTimestampFormat/' \
- -i tests/Authentication/TimestampTest.php
-%endif
+BOOTSTRAP=%{buildroot}%{phpdir}/Akamai/Open/EdgeGrid/autoload-auth.php
+
+: Upstream tests
+%{_bindir}/phpunit --verbose --bootstrap $BOOTSTRAP
-# remirepo:11
-run=0
-ret=0
-if which php56; then
- php56 %{_bindir}/phpunit --bootstrap %{buildroot}%{phpdir}/Akamai/Open/EdgeGrid/autoload-auth.php || ret=1
- run=1
-fi
-if which php71; then
- sed 's/function testTimestampFormat/function SKIP_testTimestampFormat/' -i tests/Authentication/TimestampTest.php
- php71 %{_bindir}/phpunit --bootstrap %{buildroot}%{phpdir}/Akamai/Open/EdgeGrid/autoload-auth.php || ret=1
- run=1
-fi
-if [ $run -eq 0 ]; then
-%{_bindir}/phpunit --verbose \
- --bootstrap %{buildroot}%{phpdir}/Akamai/Open/EdgeGrid/autoload-auth.php
-# remirepo:2
-fi
-exit $ret
+: Upstream tests with SCLs if available
+SCL_RETURN_CODE=0
+for SCL in php56 php70 php71; do
+ if which $SCL; then
+ $SCL %{_bindir}/phpunit --bootstrap $BOOTSTRAP || SCL_RETURN_CODE=1
+ fi
+done
+exit $SCL_RETURN_CODE
%else
: Tests skipped
%endif
@@ -153,6 +141,10 @@ rm -rf %{buildroot}
%changelog
+* Sat Dec 24 2016 Shawn Iwinski <shawn@iwin.ski> - 0.6.1-1
+- Update to 0.6.1 (RHBZ #1405779)
+- Run upstream tests with SCLs if they are available
+
* Thu Dec 22 2016 Remi Collet <remim@remirepo.net> - 0.6.1-1
- update to 0.6.1