summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-04-17 08:46:44 +0200
committerRemi Collet <fedora@famillecollet.com>2015-04-17 08:46:44 +0200
commit920ef30e10913907b030ee81097f8c24c30eb296 (patch)
tree02fd18a25adcb351f7b0ce587f792de696bd0eb0
rename php-fastcgi-client to php-adoy-fastcgi-client
-rw-r--r--Makefile4
-rw-r--r--php-adoy-fastcgi-client.spec61
2 files changed, 65 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..91b0fd5
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../common/Makefile
+
diff --git a/php-adoy-fastcgi-client.spec b/php-adoy-fastcgi-client.spec
new file mode 100644
index 0000000..5661cf2
--- /dev/null
+++ b/php-adoy-fastcgi-client.spec
@@ -0,0 +1,61 @@
+Name: php-fastcgi-client
+Summary: Template/Presentation Framework for PHP
+Version: 1.0
+Release: 1%{?dist}
+
+URL: https://github.com/adoy/PHP-FastCGI-Client
+License: LGPLv2+
+Group: Development/Libraries
+# https://github.com/adoy/PHP-FastCGI-Client/archive/master.tar.gz
+Source0: PHP-FastCGI-Client-master.tar.gz
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildArch: noarch
+
+Requires: php-cli
+Requires: php-spl
+
+
+%description
+This PHP class handles the communication with a FastCGI (FCGI) application
+using the FastCGI protocol.
+
+The package provides a simple command line test command: fcgiget.
+
+
+%prep
+%setup -qn PHP-FastCGI-Client-master
+
+# Fix include path
+sed -e '/^require/s:fastcgi.php:PHP-FastCGI-Client/fastcgi.php:' \
+ -i fcgiget.php
+
+
+%build
+# empty build section, nothing required
+
+
+%install
+rm -rf %{buildroot}
+
+# install the class
+install -Dpm 644 fastcgi.php %{buildroot}%{_datadir}/php/PHP-FastCGI-Client/fastcgi.php
+
+# install the command
+install -Dpm 755 fcgiget.php %{buildroot}%{_bindir}/fcgiget
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%files
+%defattr(-,root,root,-)
+%doc LICENSE
+%{_bindir}/fcgiget
+%{_datadir}/php/PHP-FastCGI-Client
+
+
+%changelog
+* Tue Oct 13 2012 Remi Collet <remi@fedoraproject.org> - 1.0-1
+- Initial package