summaryrefslogtreecommitdiffstats
path: root/phinx.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-01-25 10:24:10 +0100
committerRemi Collet <remi@remirepo.net>2021-01-25 10:24:10 +0100
commita9d89c123a9d2bd32b8ea3adeb0aa9fa39a1b762 (patch)
treed18ad5574676464265ea568d8ae136ea13f022f2 /phinx.spec
parent010318d77ef2f14660d0bb7f1242c9d70c07c476 (diff)
update to 0.12.5
switch to phpunit9
Diffstat (limited to 'phinx.spec')
-rw-r--r--phinx.spec21
1 files changed, 15 insertions, 6 deletions
diff --git a/phinx.spec b/phinx.spec
index b35382c..508995b 100644
--- a/phinx.spec
+++ b/phinx.spec
@@ -1,6 +1,6 @@
# remirepo/fedora spec file for phinx
#
-# Copyright (c) 2016-2020 Remi Collet
+# Copyright (c) 2016-2021 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -10,7 +10,7 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit 05902f4a90790ce9db195954e608d5a43d4d6a7d
+%global gh_commit 9457e3879b0abc02a4022941a6a535141889432e
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner robmorgan
#global gh_date 20150820
@@ -19,7 +19,7 @@
%bcond_without tests
Name: %{gh_project}
-Version: 0.12.4
+Version: 0.12.5
Release: 1%{?gh_date?%{gh_date}git%{gh_short}}%{?dist}
Summary: Manage the database migrations for your PHP app
@@ -56,13 +56,18 @@ BuildRequires: php-spl
# For tests, from composer.json "require-dev": {
# "ext-json": "*",
# "ext-pdo": "*",
-# "phpunit/phpunit": ^8.5",
+# "phpunit/phpunit": ^8.5|^9.3",
# "sebastian/comparator": ">=1.2.3",
# "cakephp/cakephp-codesniffer": "^3.0",
# "symfony/yaml": "^3.4|^4.0|^5.0"
+%if 0%{?fedora} >= 32 || 0%{?rhel} >= 9
+%global phpunit %{_bindir}/phpunit9
+BuildRequires: phpunit9
+%else
%global phpunit %{_bindir}/phpunit8
BuildRequires: phpunit8
%endif
+%endif
# For autoloader
BuildRequires: php-composer(fedora/autoloader)
@@ -171,10 +176,10 @@ sed -e '/_ENABLED/s/true/false/;/SQLITE_ENABLED/s/false/true/' \
: Run upstream test suite
ret=0
-for cmd in "php %{phpunit}" php72 php73 php74; do
+for cmd in "php %{phpunit}" "php72 %{_bindir}/phpunit8" php73 php74 php80; do
if which $cmd; then
set $cmd
- $1 ${2:-%{_bindir}/phpunit8} \
+ $1 ${2:-%{_bindir}/phpunit9} \
--no-coverage || ret=1
fi
done
@@ -195,6 +200,10 @@ exit $ret
%changelog
+* Mon Jan 25 2021 Remi Collet <remi@remirepo.net> - 0.12.5-1
+- update to 0.12.5
+- switch to phpunit9
+
* Wed Aug 19 2020 Remi Collet <remi@remirepo.net> - 0.12.4-1
- update to 0.12.4
- drop dependency on cakephp/collection