summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-04-06 11:19:12 +0200
committerRemi Collet <remi@remirepo.net>2020-04-06 11:19:12 +0200
commitc81560fa567a8c84416500ce5afe466d4985a0b3 (patch)
treeefc79505c58a80c158351d848a33035fe13ea519
parentf3679ae11f123c9e79aece86e03aaa31a65fc120 (diff)
v0.11.5
-rw-r--r--composer.json11
-rw-r--r--phinx.spec22
2 files changed, 23 insertions, 10 deletions
diff --git a/composer.json b/composer.json
index 123e74f..dbb6392 100644
--- a/composer.json
+++ b/composer.json
@@ -29,13 +29,14 @@
"cakephp/collection": "^3.7",
"cakephp/database": "^3.7",
"symfony/console": "^3.4|^4.0|^5.0",
- "symfony/config": "^3.4|^4.0|^5.0",
- "symfony/yaml": "^3.4|^4.0|^5.0"
+ "symfony/config": "^3.4|^4.0|^5.0"
},
"require-dev": {
+ "ext-json": "*",
"phpunit/phpunit": ">=5.7,<8.0",
"sebastian/comparator": ">=1.2.3",
- "cakephp/cakephp-codesniffer": "^3.0"
+ "cakephp/cakephp-codesniffer": "^3.0",
+ "symfony/yaml": "^3.4|^4.0|^5.0"
},
"autoload": {
"psr-4": {
@@ -47,6 +48,10 @@
"Test\\Phinx\\": "tests/Phinx/"
}
},
+ "suggest": {
+ "ext-json": "Install if using JSON configuration format",
+ "symfony/yaml": "Install if using YAML configuration format"
+ },
"scripts": {
"check": [
"@test",
diff --git a/phinx.spec b/phinx.spec
index a4b3faa..30ed8c4 100644
--- a/phinx.spec
+++ b/phinx.spec
@@ -10,7 +10,7 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit 10e8c3f6b09111f4c0ef128d5a43375e15286cc5
+%global gh_commit 06c65d63ca22be27f278133f439ddcf0bd150635
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner robmorgan
#global gh_date 20150820
@@ -19,7 +19,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: %{gh_project}
-Version: 0.11.4
+Version: 0.11.5
Release: 1%{?gh_date?%{gh_date}git%{gh_short}}%{?dist}
Summary: Manage the database migrations for your PHP app
@@ -55,8 +55,11 @@ BuildRequires: php-json
BuildRequires: php-pcre
BuildRequires: php-spl
# For tests, from composer.json "require-dev": {
+# "ext-json": "*",
# "phpunit/phpunit": ">=5.7,<8.0",
# "sebastian/comparator": ">=1.2.3",
+# "cakephp/cakephp-codesniffer": "^3.0",
+# "symfony/yaml": "^3.4|^4.0|^5.0"
%global phpunit %{_bindir}/phpunit7
BuildRequires: phpunit7
%endif
@@ -67,9 +70,11 @@ BuildRequires: php-composer(fedora/autoloader)
# "php": ">=5.6",
# "cakephp/collection": "^3.7",
# "cakephp/database": "^3.7",
-# "symfony/console": "^3.4|^4.0",
-# "symfony/config": "^3.4|^4.0",
-# "symfony/yaml": "^3.4|^4.0"
+# "symfony/console": "^3.4|^4.0|^5.0",
+# "symfony/config": "^3.4|^4.0|^5.0"
+# From composer.json, "suggest": {
+# "ext-json": "Install if using JSON configuration format",
+# "symfony/yaml": "Install if using YAML configuration format"
Requires: php(language) >= 5.6
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-composer(cakephp/collection) >= 3.7 with php-composer(cakephp/collection) < 4)
@@ -165,10 +170,10 @@ sed -e '/_ENABLED/s/true/false/;/SQLITE_ENABLED/s/false/true/' \
: Run upstream test suite
ret=0
-for cmd in "php %{phpunit}" php71 php72 php73 php74; do
+for cmd in "php %{phpunit}" php72 php73 php74; do
if which $cmd; then
set $cmd
- $1 ${2:-%{_bindir}/phpunit6} \
+ $1 ${2:-%{_bindir}/phpunit7} \
--no-coverage || ret=1
fi
done
@@ -189,6 +194,9 @@ exit $ret
%changelog
+* Mon Apr 6 2020 Remi Collet <remi@remirepo.net> - 0.11.5-1
+- update to 0.11.5
+
* Thu Jan 2 2020 Remi Collet <remi@remirepo.net> - 0.11.4-1
- update to 0.11.4
- raise dependency on cake 3.7