summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-01-24 10:30:01 +0100
committerRemi Collet <remi@php.net>2022-01-24 10:30:01 +0100
commitbec0a5f03cd01bb859b00abf0e663b7fd869fe4b (patch)
tree934f0f5b0cf6e9573fa9b61feecbe682d3f9478e
parent7b61129cba2ec903ee2502e5ca7885416573be7a (diff)
update to 0.12.10
-rw-r--r--composer.json64
-rw-r--r--phinx.spec15
2 files changed, 50 insertions, 29 deletions
diff --git a/composer.json b/composer.json
index 8a1b680..52afaa3 100644
--- a/composer.json
+++ b/composer.json
@@ -2,34 +2,45 @@
"name": "robmorgan/phinx",
"type": "library",
"description": "Phinx makes it ridiculously easy to manage the database migrations for your PHP app.",
- "keywords": ["phinx", "migrations", "database", "db", "database migrations"],
+ "keywords": [
+ "phinx",
+ "migrations",
+ "database",
+ "db",
+ "database migrations"
+ ],
"homepage": "https://phinx.org",
"license": "MIT",
- "authors": [{
- "name": "Rob Morgan",
- "email": "robbym@gmail.com",
- "homepage": "https://robmorgan.id.au",
- "role": "Lead Developer"
- }, {
- "name": "Woody Gilk",
- "email": "woody.gilk@gmail.com",
- "homepage": "https://shadowhand.me",
- "role": "Developer"
- }, {
- "name": "Richard Quadling",
- "email": "rquadling@gmail.com",
- "role": "Developer"
- }, {
- "name": "CakePHP Community",
- "role": "Developer",
- "homepage": "https://github.com/cakephp/phinx/graphs/contributors"
- }],
+ "authors": [
+ {
+ "name": "Rob Morgan",
+ "email": "robbym@gmail.com",
+ "homepage": "https://robmorgan.id.au",
+ "role": "Lead Developer"
+ },
+ {
+ "name": "Woody Gilk",
+ "email": "woody.gilk@gmail.com",
+ "homepage": "https://shadowhand.me",
+ "role": "Developer"
+ },
+ {
+ "name": "Richard Quadling",
+ "email": "rquadling@gmail.com",
+ "role": "Developer"
+ },
+ {
+ "name": "CakePHP Community",
+ "role": "Developer",
+ "homepage": "https://github.com/cakephp/phinx/graphs/contributors"
+ }
+ ],
"require": {
"php": ">=7.2",
"cakephp/database": "^4.0",
"psr/container": "^1.0 || ^2.0",
- "symfony/console": "^3.4|^4.0|^5.0",
- "symfony/config": "^3.4|^4.0|^5.0"
+ "symfony/console": "^3.4|^4.0|^5.0|^6.0",
+ "symfony/config": "^3.4|^4.0|^5.0|^6.0"
},
"require-dev": {
"ext-json": "*",
@@ -65,5 +76,12 @@
"stan-setup": "cp composer.json composer.backup && composer require --dev phpstan/phpstan:^0.12 && mv composer.backup composer.json",
"test": "phpunit --colors=always"
},
- "bin": ["bin/phinx"]
+ "bin": [
+ "bin/phinx"
+ ],
+ "config": {
+ "allow-plugins": {
+ "dealerdirect/phpcodesniffer-composer-installer": true
+ }
+ }
}
diff --git a/phinx.spec b/phinx.spec
index 02a01ee..92960c5 100644
--- a/phinx.spec
+++ b/phinx.spec
@@ -1,6 +1,6 @@
# remirepo/fedora spec file for phinx
#
-# Copyright (c) 2016-2021 Remi Collet
+# Copyright (c) 2016-2022 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -10,7 +10,7 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit 5a0146a74c1bc195d1f5da86afa3b68badf7d90e
+%global gh_commit ad056cff354fc67fedf9bf96c441c2b428afad0c
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner robmorgan
#global gh_date 20150820
@@ -19,7 +19,7 @@
%bcond_without tests
Name: %{gh_project}
-Version: 0.12.9
+Version: 0.12.10
Release: 1%{?gh_date?%{gh_date}git%{gh_short}}%{?dist}
Summary: Manage the database migrations for your PHP app
@@ -75,8 +75,8 @@ BuildRequires: php-composer(fedora/autoloader)
# "php": ">=7.2",
# "cakephp/database": "^4.0",
# "psr/container": "^1.0 || ^2.0",
-# "symfony/console": "^3.4|^4.0|^5.0",
-# "symfony/config": "^3.4|^4.0|^5.0"
+# "symfony/console": "^3.4|^4.0|^5.0|^6.0",
+# "symfony/config": "^3.4|^4.0|^5.0|^6.0"
# From composer.json, "suggest": {
# "ext-json": "Install if using JSON configuration format",
# "ext-pdo": "PDO extension is needed",
@@ -172,7 +172,7 @@ rm tests/Phinx/Db/Adapter/SQLiteAdapterTest.php
: Run upstream test suite
ret=0
-for cmd in "php %{phpunit}" php73 php74 php80 php81; do
+for cmd in "php %{phpunit}" php74 php80 php81; do
if which $cmd; then
set $cmd
$1 ${2:-%{_bindir}/phpunit9} \
@@ -196,6 +196,9 @@ exit $ret
%changelog
+* Mon Jan 24 2022 Remi Collet <remi@remirepo.net> - 0.12.10-1
+- update to 0.12.10
+
* Tue Oct 12 2021 Remi Collet <remi@remirepo.net> - 0.12.9-1
- update to 0.12.9