summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-09-03 10:33:44 +0200
committerRemi Collet <remi@remirepo.net>2021-09-03 10:33:44 +0200
commitb0e5b7b59007d23cba7e67c429f9881cab0ab88e (patch)
treec4356c8b5e313e52e9664e2d2260ba390e7838d8
parent78f0ca92d0f5e2dcabf787ed3bda754127d91e75 (diff)
update to 0.12.8
-rw-r--r--composer.json2
-rw-r--r--phinx.spec21
2 files changed, 13 insertions, 10 deletions
diff --git a/composer.json b/composer.json
index f456f05..8a1b680 100644
--- a/composer.json
+++ b/composer.json
@@ -36,7 +36,7 @@
"ext-pdo": "*",
"phpunit/phpunit": "^8.5|^9.3",
"sebastian/comparator": ">=1.2.3",
- "cakephp/cakephp-codesniffer": "^3.0",
+ "cakephp/cakephp-codesniffer": "^4.0",
"symfony/yaml": "^3.4|^4.0|^5.0"
},
"autoload": {
diff --git a/phinx.spec b/phinx.spec
index 46aa224..dafbe7b 100644
--- a/phinx.spec
+++ b/phinx.spec
@@ -10,7 +10,7 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit bdd8f337fcdf24c20d0b708664a85ca9b8d5dbe2
+%global gh_commit d2ed1b452cc90f4cae4ea6b5976b94fb9e5ed2a2
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner robmorgan
#global gh_date 20150820
@@ -19,7 +19,7 @@
%bcond_without tests
Name: %{gh_project}
-Version: 0.12.7
+Version: 0.12.8
Release: 1%{?gh_date?%{gh_date}git%{gh_short}}%{?dist}
Summary: Manage the database migrations for your PHP app
@@ -44,9 +44,9 @@ BuildRequires: (php-composer(symfony/yaml) >= 3.4 with php-composer(symf
%else
BuildRequires: php-cakephp4-database
BuildRequires: php-psr-container
-BuildRequires: php-symfony3-console >= 3.4
-BuildRequires: php-symfony3-config >= 3.4
-BuildRequires: php-symfony3-yaml >= 3.4
+BuildRequires: php-symfony4-console
+BuildRequires: php-symfony4-config
+BuildRequires: php-symfony4-yaml
%endif
BuildRequires: php-pdo
BuildRequires: php-date
@@ -58,7 +58,7 @@ BuildRequires: php-spl
# "ext-pdo": "*",
# "phpunit/phpunit": ^8.5|^9.3",
# "sebastian/comparator": ">=1.2.3",
-# "cakephp/cakephp-codesniffer": "^3.0",
+# "cakephp/cakephp-codesniffer": "^4.0",
# "symfony/yaml": "^3.4|^4.0|^5.0"
%if 0%{?fedora} >= 32 || 0%{?rhel} >= 9
%global phpunit %{_bindir}/phpunit9
@@ -91,9 +91,9 @@ Requires: (php-composer(symfony/yaml) >= 3.4 with php-composer(symf
%else
Requires: php-cakephp4-database
Requires: php-psr-container
-Requires: php-symfony3-console >= 3.4
-Requires: php-symfony3-config >= 3.4
-Requires: php-symfony3-yaml >= 3.4
+Requires: php-symfony4-console
+Requires: php-symfony4-config
+Requires: php-symfony4-yaml
%endif
# From phpcompatinfo report for 0.6.4
Requires: php-pdo
@@ -196,6 +196,9 @@ exit $ret
%changelog
+* Fri Sep 3 2021 Remi Collet <remi@remirepo.net> - 0.12.8-1
+- update to 0.12.8
+
* Wed May 19 2021 Remi Collet <remi@remirepo.net> - 0.12.7-1
- update to 0.12.7