summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-06-11 12:56:34 +0200
committerRemi Collet <remi@remirepo.net>2018-06-11 12:56:34 +0200
commit27108801e18fcedcfd6883c34c7168b022252cbb (patch)
treeb86511df39f09fce7e80c1b9f3013ae52331d07f
parent89bc3e4440e059a9b2178558bcc01a1a77d82a2a (diff)
update to 0.10.0
drop patch merged upstream raise dependency on PHP 5.6 add dependency on cakephp/collection add dependency on cakephp/database use range dependencies on F27+
-rw-r--r--composer.json13
-rw-r--r--phinx-autoload.php2
-rw-r--r--phinx-tests.patch24
-rw-r--r--phinx-version.patch18
-rw-r--r--phinx.spec88
5 files changed, 78 insertions, 67 deletions
diff --git a/composer.json b/composer.json
index 1c85c43..d266014 100644
--- a/composer.json
+++ b/composer.json
@@ -5,7 +5,7 @@
"keywords": ["phinx", "migrations", "database", "db", "database migrations"],
"homepage": "https://phinx.org",
"license": "MIT",
- "version": "0.9.2",
+ "version": "0.10.0",
"authors": [{
"name": "Rob Morgan",
"email": "robbym@gmail.com",
@@ -25,23 +25,26 @@
"homepage": "https://github.com/cakephp/phinx/graphs/contributors"
}],
"require": {
- "php": ">=5.4",
+ "php": ">=5.6",
+ "cakephp/collection": "^3.6",
+ "cakephp/database": "^3.6",
"symfony/console": "^2.8|^3.0|^4.0",
"symfony/config": "^2.8|^3.0|^4.0",
"symfony/yaml": "^2.8|^3.0|^4.0"
},
"require-dev": {
- "phpunit/phpunit": "^4.8.35|^5.7|^6.5",
+ "phpunit/phpunit": ">=5.7",
+ "sebastian/comparator": ">=1.2.3",
"cakephp/cakephp-codesniffer": "^3.0"
},
"autoload": {
"psr-4": {
- "Phinx\\": "src/Phinx"
+ "Phinx\\": "src/Phinx/"
}
},
"autoload-dev": {
"psr-4": {
- "Test\\Phinx\\": "tests/Phinx"
+ "Test\\Phinx\\": "tests/Phinx/"
}
},
"scripts": {
diff --git a/phinx-autoload.php b/phinx-autoload.php
index 754541a..31846eb 100644
--- a/phinx-autoload.php
+++ b/phinx-autoload.php
@@ -5,6 +5,8 @@ require_once '/usr/share/php/Fedora/Autoloader/autoload.php';
\Fedora\Autoloader\Autoload::addPsr4('Phinx\\', __DIR__);
\Fedora\Autoloader\Dependencies::required(array(
+ '/usr/share/php/Cake/Collection/autoload.php',
+ '/usr/share/php/Cake/Database/autoload.php',
[
'/usr/share/php/Symfony4/Component/Console/autoload.php',
'/usr/share/php/Symfony3/Component/Console/autoload.php',
diff --git a/phinx-tests.patch b/phinx-tests.patch
deleted file mode 100644
index 5db1090..0000000
--- a/phinx-tests.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-diff -up tests/Phinx/Console/Command/CreateTest.php.old tests/Phinx/Console/Command/CreateTest.php
---- tests/Phinx/Console/Command/CreateTest.php.old 2017-12-23 17:43:31.217652943 +0100
-+++ tests/Phinx/Console/Command/CreateTest.php 2017-12-23 17:43:39.896696824 +0100
-@@ -384,7 +384,7 @@ class CreateTest extends TestCase
- {
- if (method_exists($this, 'expectException')) {
- //PHPUnit 5+
-- $this->expectException($exception);
-+ $this->expectException($exceptionName);
- if ($exceptionMessage !== '') {
- $this->expectExceptionMessage($exceptionMessage);
- }
-diff -up tests/Phinx/Migration/ManagerTest.php.old tests/Phinx/Migration/ManagerTest.php
---- tests/Phinx/Migration/ManagerTest.php.old 2017-12-23 17:43:18.862590475 +0100
-+++ tests/Phinx/Migration/ManagerTest.php 2017-12-23 17:43:34.709670598 +0100
-@@ -5710,7 +5710,7 @@ class ManagerTest extends TestCase
- {
- if (method_exists($this, 'expectException')) {
- //PHPUnit 5+
-- $this->expectException($exception);
-+ $this->expectException($exceptionName);
- if ($exceptionMessage !== '') {
- $this->expectExceptionMessage($exceptionMessage);
- }
diff --git a/phinx-version.patch b/phinx-version.patch
index ea1290d..d1410c8 100644
--- a/phinx-version.patch
+++ b/phinx-version.patch
@@ -1,13 +1,13 @@
diff -up src/Phinx/Console/PhinxApplication.php.rpm src/Phinx/Console/PhinxApplication.php
---- src/Phinx/Console/PhinxApplication.php.rpm 2017-12-23 17:33:14.486694897 +0100
-+++ src/Phinx/Console/PhinxApplication.php 2017-12-23 17:33:39.408810505 +0100
-@@ -49,8 +49,7 @@ class PhinxApplication extends Applicati
- */
- public function __construct()
+--- src/Phinx/Console/PhinxApplication.php.rpm 2018-06-11 12:27:52.883341516 +0200
++++ src/Phinx/Console/PhinxApplication.php 2018-06-11 12:28:29.982556962 +0200
+@@ -50,8 +50,7 @@ class PhinxApplication extends Applicati
+ public function __construct($version = null)
{
-- $composerConfig = json_decode(file_get_contents(__DIR__ . '/../../../composer.json'));
-- $version = $composerConfig->version;
-+ $version = '@VERSION@';
+ if ($version === null) {
+- $composerConfig = json_decode(file_get_contents(__DIR__ . '/../../../composer.json'));
+- $version = $composerConfig->version;
++ $version = '@VERSION@';
+ }
parent::__construct('Phinx by CakePHP - https://phinx.org.', $version);
-
diff --git a/phinx.spec b/phinx.spec
index a1fe183..37bf3fd 100644
--- a/phinx.spec
+++ b/phinx.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit e1698319ad55157c233b658c08f7a10617e797ca
+%global gh_commit 21aaad6001e663d0296235d0507ffa4bd8c0d9ce
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner robmorgan
#global gh_date 20150820
@@ -14,14 +14,8 @@
%global psr0 Phinx
%global with_tests 0%{!?_without_tests:1}
-%if 0%{?fedora} >= 27
-%global symfony_max 5
-%else
-%global symfony_max 4
-%endif
-
Name: %{gh_project}
-Version: 0.9.2
+Version: 0.10.0
Release: 1%{?gh_date?%{gh_date}git%{gh_short}}%{?dist}
Summary: Manage the database migrations for your PHP app
@@ -34,43 +28,63 @@ Source2: makesrc.sh
# hardcode version instead of read it from composer.json
Patch0: %{name}-version.patch
-# https://github.com/cakephp/phinx/pull/1278
-Patch1: %{name}-tests.patch
BuildArch: noarch
%if %{with_tests}
-BuildRequires: php(language) >= 5.4
-BuildRequires: php-composer(symfony/console) < %{symfony_max}
-BuildRequires: php-composer(symfony/config) < %{symfony_max}
-BuildRequires: php-composer(symfony/yaml) < %{symfony_max}
+BuildRequires: php(language) >= 5.6
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+BuildRequires: (php-composer(cakephp/collection) >= 3.6 with php-composer(cakephp/collection) < 4)
+BuildRequires: (php-composer(cakephp/database) >= 3.6 with php-composer(cakephp/database) < 4)
+BuildRequires: (php-composer(symfony/console) >= 2.8 with php-composer(symfony/console) < 5)
+BuildRequires: (php-composer(symfony/config) >= 2.8 with php-composer(symfony/config) < 5)
+BuildRequires: (php-composer(symfony/yaml) >= 2.8 with php-composer(symfony/yaml) < 5)
+%else
+BuildRequires: php-cakephp-collection >= 3.6
+BuildRequires: php-cakephp-database >= 3.6
+BuildRequires: php-symfony3-console
+BuildRequires: php-symfony3-config
+BuildRequires: php-symfony3-yaml
+%endif
BuildRequires: php-pdo
BuildRequires: php-date
BuildRequires: php-json
BuildRequires: php-pcre
BuildRequires: php-spl
# For tests, from composer.json "require-dev": {
-# "phpunit/phpunit": "^4.8.35|^5.7|^6.5"
-# "cakephp/cakephp-codesniffer": "^3.0"
-%if 0%{?fedora} >= 26
+# "phpunit/phpunit": ">=5.7",
+# "sebastian/comparator": ">=1.2.3",
+%if 0%{?fedora} >= 26 || 0%{?rhel} >= 8
%global phpunit %{_bindir}/phpunit6
BuildRequires: phpunit6
%else
%global phpunit %{_bindir}/phpunit
-BuildRequires: php-phpunit-PHPUnit >= 4.8.35
+BuildRequires: php-phpunit-PHPUnit >= 5.7
%endif
%endif
# For autoloader
BuildRequires: php-composer(fedora/autoloader)
# From composer.json, "require": {
-# "php": ">=5.4",
+# "php": ">=5.6",
+# "cakephp/collection": "^3.6",
+# "cakephp/database": "^3.6",
# "symfony/console": "~2.8|~3.0|^4.0",
# "symfony/config": "~2.8|~3.0|^4.0",
# "symfony/yaml": "~2.8|~3.0|^4.0"
-Requires: php(language) >= 5.4
-Requires: php-composer(symfony/console) < %{symfony_max}
-Requires: php-composer(symfony/config) < %{symfony_max}
-Requires: php-composer(symfony/yaml) < %{symfony_max}
+Requires: php(language) >= 5.6
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+Requires: (php-composer(cakephp/collection) >= 3.6 with php-composer(cakephp/collection) < 4)
+Requires: (php-composer(cakephp/database) >= 3.6 with php-composer(cakephp/database) < 4)
+Requires: (php-composer(symfony/console) >= 2.8 with php-composer(symfony/console) < 5)
+Requires: (php-composer(symfony/config) >= 2.8 with php-composer(symfony/config) < 5)
+Requires: (php-composer(symfony/yaml) >= 2.8 with php-composer(symfony/yaml) < 5)
+%else
+Requires: php-cakephp-collection >= 3.6
+Requires: php-cakephp-database >= 3.6
+Requires: php-symfony3-console
+Requires: php-symfony3-config
+Requires: php-symfony3-yaml
+%endif
# From phpcompatinfo report for 0.6.4
Requires: php-pdo
Requires: php-date
@@ -101,8 +115,6 @@ Documentation: http://docs.phinx.org
sed -e 's/@VERSION@/%{version}/' \
-i src/Phinx/Console/PhinxApplication.php
-%patch1 -p0 -b .old
-
cp %{SOURCE1} src/%{psr0}/autoload.php
sed -e 's:../data/Phinx:data:' -i src/Phinx/Console/Command/Init.php
@@ -126,8 +138,8 @@ EOF
mkdir -p %{buildroot}%{_datadir}/php
cp -pr src/%{psr0} %{buildroot}%{_datadir}/php/%{psr0}
-: Default config file
-install -Dpm 644 phinx.yml %{buildroot}%{_datadir}/php/%{psr0}/data/phinx.yml
+: Default config files
+cp -pr src/data/%{psr0} %{buildroot}%{_datadir}/php/%{psr0}/data
: The command
install -Dpm 755 phinx %{buildroot}%{_bindir}/phinx
@@ -142,15 +154,25 @@ require '%{buildroot}%{_datadir}/php/%{psr0}/autoload.php';
\Fedora\Autoloader\Autoload::addPsr4('Test\\Phinx\\', dirname(__DIR__).'/tests/Phinx');
EOF
+%if 0%{?rhel} == 6
+: SQLite is too old
+sed -e '/_ENABLED/s/true/false/' \
+ phpunit.xml.dist >phpunit.xml
+%else
sed -e '/_ENABLED/s/true/false/;/SQLITE_ENABLED/s/false/true/' \
phpunit.xml.dist >phpunit.xml
+%endif
: Run upstream test suite
ret=0
-for cmd in "php %{phpunit}" php70 php71 php72; do
+for cmd in "php %{phpunit}" php71 php72 php73; do
if which $cmd; then
set $cmd
- $1 ${2:-%{_bindir}/phpunit6} --no-coverage || ret=1
+ $1 ${2:-%{_bindir}/phpunit6} \
+%if 0%{?fedora} >= 28
+ --filter '^((?!(testChangeColumnWithCommasInCommentsOrDefaultValue)).)*$' \
+%endif
+ --no-coverage || ret=1
fi
done
exit $ret
@@ -170,6 +192,14 @@ exit $ret
%changelog
+* Mon Jun 11 2018 Remi Collet <remi@remirepo.net> - 0.10.0-1
+- update to 0.10.0
+- drop patch merged upstream
+- raise dependency on PHP 5.6
+- add dependency on cakephp/collection
+- add dependency on cakephp/database
+- use range dependencies on F27+
+
* Sat Dec 23 2017 Remi Collet <remi@remirepo.net> - 0.9.2-1
- Update to 0.9.2
- open https://github.com/cakephp/phinx/pull/1278 fix tests