summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-08-19 09:44:21 +0200
committerRemi Collet <remi@remirepo.net>2020-08-19 09:44:21 +0200
commit010318d77ef2f14660d0bb7f1242c9d70c07c476 (patch)
tree4c8e0e11f166e5386f0f593511afeb38123968d1
parentad5fafed6803260b8e89d072c490b04c7dcf7dfe (diff)
update to 0.12.4
drop dependency on cakephp/collection
-rw-r--r--composer.json5
-rw-r--r--phinx-autoload.php1
-rw-r--r--phinx.spec22
3 files changed, 14 insertions, 14 deletions
diff --git a/composer.json b/composer.json
index cd871df..8923623 100644
--- a/composer.json
+++ b/composer.json
@@ -26,7 +26,6 @@
}],
"require": {
"php": ">=7.2",
- "cakephp/collection": "^4.0",
"cakephp/database": "^4.0",
"psr/container": "^1.0",
"symfony/console": "^3.4|^4.0|^5.0",
@@ -60,8 +59,8 @@
"@test",
"@cs-check"
],
- "cs-check": "phpcs --colors -p -n --standard=vendor/cakephp/cakephp-codesniffer/CakePHP --ignore=/tests/Phinx/Config/_rootDirectories/,/tests/log/ src/ tests/ app/",
- "cs-fix": "phpcbf --colors -p --standard=vendor/cakephp/cakephp-codesniffer/CakePHP --ignore=/tests/Phinx/Config/_rootDirectories/,/tests/log/ src/ tests/ app/",
+ "cs-check": "phpcs",
+ "cs-fix": "phpcbf",
"stan": "phpstan analyse src/",
"stan-setup": "cp composer.json composer.backup && composer require --dev phpstan/phpstan:^0.12 && mv composer.backup composer.json",
"test": "phpunit --colors=always"
diff --git a/phinx-autoload.php b/phinx-autoload.php
index 2d0ae77..d6d7d0c 100644
--- a/phinx-autoload.php
+++ b/phinx-autoload.php
@@ -5,7 +5,6 @@ require_once '/usr/share/php/Fedora/Autoloader/autoload.php';
\Fedora\Autoloader\Autoload::addPsr4('Phinx\\', __DIR__);
\Fedora\Autoloader\Dependencies::required(array(
- '/usr/share/php/Cake4/Collection/autoload.php',
'/usr/share/php/Cake4/Database/autoload.php',
'/usr/share/php/Psr/Container/autoload.php',
[
diff --git a/phinx.spec b/phinx.spec
index aa2e58d..b35382c 100644
--- a/phinx.spec
+++ b/phinx.spec
@@ -10,16 +10,16 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit e8ac453951797408275b46a7fa4489dd63a93a67
+%global gh_commit 05902f4a90790ce9db195954e608d5a43d4d6a7d
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner robmorgan
#global gh_date 20150820
%global gh_project phinx
%global psr0 Phinx
-%global with_tests 0%{!?_without_tests:1}
+%bcond_without tests
Name: %{gh_project}
-Version: 0.12.2
+Version: 0.12.4
Release: 1%{?gh_date?%{gh_date}git%{gh_short}}%{?dist}
Summary: Manage the database migrations for your PHP app
@@ -33,17 +33,15 @@ Source2: makesrc.sh
Patch0: %{name}-version.patch
BuildArch: noarch
-%if %{with_tests}
+%if %{with tests}
BuildRequires: php(language) >= 7.2
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: (php-composer(cakephp/collection) >= 4.0 with php-composer(cakephp/collection) < 5)
BuildRequires: (php-composer(cakephp/database) >= 4.0 with php-composer(cakephp/database) < 5)
BuildRequires: (php-composer(psr/container) >= 1.0 with php-composer(psr/container) < 2)
BuildRequires: (php-composer(symfony/console) >= 3.4 with php-composer(symfony/console) < 6)
BuildRequires: (php-composer(symfony/config) >= 3.4 with php-composer(symfony/config) < 6)
BuildRequires: (php-composer(symfony/yaml) >= 3.4 with php-composer(symfony/yaml) < 6)
%else
-BuildRequires: php-cakephp4-collection
BuildRequires: php-cakephp4-database
BuildRequires: php-psr-container
BuildRequires: php-symfony3-console >= 3.4
@@ -70,7 +68,6 @@ BuildRequires: php-composer(fedora/autoloader)
# From composer.json, "require": {
# "php": ">=7.2",
-# "cakephp/collection": "^4.0",
# "cakephp/database": "^4.0",
# "psr/container": "^1.0",
# "symfony/console": "^3.4|^4.0|^5.0",
@@ -81,14 +78,12 @@ BuildRequires: php-composer(fedora/autoloader)
# "symfony/yaml": "Install if using YAML configuration format"
Requires: php(language) >= 7.2
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-Requires: (php-composer(cakephp/collection) >= 4.0 with php-composer(cakephp/collection) < 5)
Requires: (php-composer(cakephp/database) >= 4.0 with php-composer(cakephp/database) < 5)
Requires: (php-composer(psr/container) >= 1.0 with php-composer(psr/container) < 2)
Requires: (php-composer(symfony/console) >= 3.4 with php-composer(symfony/console) < 6)
Requires: (php-composer(symfony/config) >= 3.4 with php-composer(symfony/config) < 6)
Requires: (php-composer(symfony/yaml) >= 3.4 with php-composer(symfony/yaml) < 6)
%else
-Requires: php-cakephp4-collection
Requires: php-cakephp4-database
Requires: php-psr-container
Requires: php-symfony3-console >= 3.4
@@ -156,7 +151,7 @@ install -Dpm 755 phinx %{buildroot}%{_bindir}/phinx
%check
-%if %{with_tests}
+%if %{with tests}
mkdir vendor
cat << 'EOF' | tee vendor/autoload.php
<?php
@@ -200,6 +195,13 @@ exit $ret
%changelog
+* Wed Aug 19 2020 Remi Collet <remi@remirepo.net> - 0.12.4-1
+- update to 0.12.4
+- drop dependency on cakephp/collection
+
+* Mon Jun 29 2020 Remi Collet <remi@remirepo.net> - 0.12.3-1
+- update to 0.12.3
+
* Wed Jun 24 2020 Remi Collet <remi@remirepo.net> - 0.12.2-1
- update to 0.12.2
- add dependency on psr/container