summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-phar-io-version.spec4
1 files changed, 3 insertions, 1 deletions
diff --git a/php-phar-io-version.spec b/php-phar-io-version.spec
index 37371b6..76e7ec7 100644
--- a/php-phar-io-version.spec
+++ b/php-phar-io-version.spec
@@ -57,6 +57,8 @@ Provides: php-composer(%{pk_vendor}/%{pk_project}) = %{version}
%description
Library for handling version information and constraints.
+Autoloader: %{php_home}/%{ns_vendor}/%{ns_project}%{major}/autoload.php
+
%prep
%setup -q -n %{gh_project}-%{gh_commit}
@@ -79,7 +81,7 @@ ret=0
for cmd in php70 php71 php; do
if which $cmd; then
%{_bindir}/php -d include_path=.:%{buildroot}%{_datadir}/php:%{_datadir}/php \
- %{_bindir}/phpunit6 --verbose || ret=1
+ %{_bindir}/phpunit6 --bootstrap %{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}/autoload.php --verbose || ret=1
fi
done
exit $ret