summaryrefslogtreecommitdiffstats
path: root/php-phar-io-version.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-04-07 07:22:47 +0200
committerRemi Collet <remi@remirepo.net>2017-04-07 07:22:47 +0200
commit162657ce81a1f865cffbb44b1237771638b5c0fd (patch)
treef7d4981c9065e58e6a8ee313d3415b1d0c4b392e /php-phar-io-version.spec
new package
Diffstat (limited to 'php-phar-io-version.spec')
-rw-r--r--php-phar-io-version.spec102
1 files changed, 102 insertions, 0 deletions
diff --git a/php-phar-io-version.spec b/php-phar-io-version.spec
new file mode 100644
index 0000000..37371b6
--- /dev/null
+++ b/php-phar-io-version.spec
@@ -0,0 +1,102 @@
+# remirepo/fedora spec file for php-phar-io-version
+#
+# Copyright (c) 2017 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%global bootstrap 0
+%global gh_commit a70c0ced4be299a63d32fa96d9281d03e94041df
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_owner phar-io
+%global gh_project version
+%global pk_vendor %{gh_owner}
+%global pk_project %{gh_project}
+%global ns_vendor PharIo
+%global ns_project Version
+%global major %nil
+%global php_home %{_datadir}/php
+%if %{bootstrap}
+%global with_tests 0%{?_with_tests:1}
+%else
+%global with_tests 0%{!?_without_tests:1}
+%endif
+
+Name: php-%{pk_vendor}-%{pk_project}%{major}
+Version: 1.0.1
+Release: 1%{?dist}
+Summary: Library for handling version information and constraints
+
+Group: Development/Libraries
+License: BSD
+URL: https://github.com/%{gh_owner}/%{gh_project}
+Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{name}-%{version}-%{gh_short}.tar.gz
+
+BuildArch: noarch
+BuildRequires: php(language) >= 5.6
+BuildRequires: php-pcre
+BuildRequires: php-spl
+BuildRequires: php-fedora-autoloader-devel >= 1.0.0
+%if %{with_tests}
+BuildRequires: phpunit6
+%endif
+
+# from composer.json
+# "php": "^5.6 || ^7.0"
+Requires: php(language) >= 5.6
+# from phpcompatinfo report for version 1.0.1
+Requires: php-pcre
+Requires: php-spl
+# Autoloader
+Requires: php-composer(fedora/autoloader)
+
+Provides: php-composer(%{pk_vendor}/%{pk_project}) = %{version}
+
+
+%description
+Library for handling version information and constraints.
+
+
+%prep
+%setup -q -n %{gh_project}-%{gh_commit}
+
+
+%build
+# Generate the Autoloader
+%{_bindir}/phpab --template fedora2 --output src/autoload.php src
+
+
+%install
+mkdir -p %{buildroot}%{php_home}/%{ns_vendor}
+cp -pr src %{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}
+
+
+%check
+%if %{with_tests}
+: Run upstream test suite
+ret=0
+for cmd in php70 php71 php; do
+ if which $cmd; then
+ %{_bindir}/php -d include_path=.:%{buildroot}%{_datadir}/php:%{_datadir}/php \
+ %{_bindir}/phpunit6 --verbose || ret=1
+ fi
+done
+exit $ret
+%else
+: bootstrap build with test suite disabled
+%endif
+
+
+%files
+%{!?_licensedir:%global license %%doc}
+%license LICENSE
+%doc README.md composer.json
+%dir %{php_home}/%{ns_vendor}
+ %{php_home}/%{ns_vendor}/%{ns_project}%{major}
+
+
+%changelog
+* Fri Apr 7 2017 Remi Collet <remi@remirepo.net> - 1.0.1-1
+- initial package
+