summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-07-16 07:09:11 +0200
committerRemi Collet <remi@remirepo.net>2018-07-16 07:09:11 +0200
commit63c6aa9cc82ee64c84cd674b5b5c8c7d44263396 (patch)
tree9ba9675bfddc395de852fce55eeae61f7fc6829e
parentb057152cd147ecb0e9eb0a412f4bfbe69f142185 (diff)
v2.0.1
-rw-r--r--php-phar-io-version.spec18
1 files changed, 11 insertions, 7 deletions
diff --git a/php-phar-io-version.spec b/php-phar-io-version.spec
index 76e7ec7..2158a09 100644
--- a/php-phar-io-version.spec
+++ b/php-phar-io-version.spec
@@ -1,13 +1,13 @@
# remirepo/fedora spec file for php-phar-io-version
#
-# Copyright (c) 2017 Remi Collet
+# Copyright (c) 2017-2018 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit a70c0ced4be299a63d32fa96d9281d03e94041df
+%global gh_commit 45a2ec53a73c70ce41d55cedef9063630abaf1b6
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner phar-io
%global gh_project version
@@ -24,7 +24,7 @@
%endif
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 1.0.1
+Version: 2.0.1
Release: 1%{?dist}
Summary: Library for handling version information and constraints
@@ -34,7 +34,8 @@ URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{name}-%{version}-%{gh_short}.tar.gz
BuildArch: noarch
-BuildRequires: php(language) >= 5.6
+# PHP 7 for phpunit6
+BuildRequires: php(language) >= 7
BuildRequires: php-pcre
BuildRequires: php-spl
BuildRequires: php-fedora-autoloader-devel >= 1.0.0
@@ -78,10 +79,10 @@ cp -pr src %{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}
%if %{with_tests}
: Run upstream test suite
ret=0
-for cmd in php70 php71 php; do
+for cmd in php php70 php71 php72 php73; do
if which $cmd; then
- %{_bindir}/php -d include_path=.:%{buildroot}%{_datadir}/php:%{_datadir}/php \
- %{_bindir}/phpunit6 --bootstrap %{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}/autoload.php --verbose || ret=1
+ $cmd -d auto_prepend_file=%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}/autoload.php \
+ %{_bindir}/phpunit6 --bootstrap %{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}/autoload.php --verbose || ret=1
fi
done
exit $ret
@@ -99,6 +100,9 @@ exit $ret
%changelog
+* Mon Jul 16 2018 Remi Collet <remi@remirepo.net> - 2.0.1-1
+- update to 2.0.1
+
* Fri Apr 7 2017 Remi Collet <remi@remirepo.net> - 1.0.1-1
- initial package