summaryrefslogtreecommitdiffstats
path: root/php-phar-io-manifest.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-phar-io-manifest.spec')
-rw-r--r--php-phar-io-manifest.spec134
1 files changed, 134 insertions, 0 deletions
diff --git a/php-phar-io-manifest.spec b/php-phar-io-manifest.spec
new file mode 100644
index 0000000..6c46b59
--- /dev/null
+++ b/php-phar-io-manifest.spec
@@ -0,0 +1,134 @@
+# remirepo/fedora spec file for php-phar-io-manifest
+#
+# Copyright (c) 2017 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%global bootstrap 0
+%global gh_commit 2df402786ab5368a0169091f61a7c1e0eb6852d0
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_owner phar-io
+%global gh_project manifest
+%global pk_vendor %{gh_owner}
+%global pk_project %{gh_project}
+%global ns_vendor PharIo
+%global ns_project Manifest
+%global major %nil
+%global php_home %{_datadir}/php
+%if %{bootstrap}
+%global with_tests 0%{?_with_tests:1}
+%else
+%global with_tests 0%{!?_without_tests:1}
+%endif
+
+Name: php-%{pk_vendor}-%{pk_project}%{major}
+Version: 1.0.1
+Release: 1%{?dist}
+Summary: Component for reading phar.io manifest information
+
+Group: Development/Libraries
+License: BSD
+URL: https://github.com/%{gh_owner}/%{gh_project}
+Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{name}-%{version}-%{gh_short}.tar.gz
+
+# https://github.com/phar-io/manifest/pull/2
+Patch0: %{name}-pr2.patch
+
+BuildArch: noarch
+BuildRequires: php(language) >= 5.6
+BuildRequires: php-dom
+BuildRequires: php-phar
+BuildRequires: php-composer(%{pk_vendor}/version) < 2
+BuildRequires: php-composer(%{pk_vendor}/version) >= 1.0.1
+BuildRequires: php-filter
+BuildRequires: php-libxml
+BuildRequires: php-pcre
+BuildRequires: php-spl
+BuildRequires: php-xmlwriter
+BuildRequires: php-fedora-autoloader-devel >= 1.0.0
+%if %{with_tests}
+BuildRequires: phpunit6
+%endif
+
+# from composer.json
+# "php": "^5.6 || ^7.0",
+# "ext-dom": "*",
+# "ext-phar": "*",
+# "phar-io/version": "^1.0.1"
+Requires: php(language) >= 5.6
+Requires: php-dom
+Requires: php-phar
+Requires: php-composer(%{pk_vendor}/version) < 2
+Requires: php-composer(%{pk_vendor}/version) >= 1.0.1
+# from phpcompatinfo report for version 1.0.1
+Requires: php-filter
+Requires: php-libxml
+Requires: php-pcre
+Requires: php-spl
+Requires: php-xmlwriter
+# Autoloader
+Requires: php-composer(fedora/autoloader)
+
+Provides: php-composer(%{pk_vendor}/%{pk_project}) = %{version}
+
+
+%description
+Component for reading phar.io manifest information from a PHP Archive (PHAR).
+
+Autoloader: %{php_home}/%{ns_vendor}/%{ns_project}%{major}/autoload.php
+
+
+%prep
+%setup -q -n %{gh_project}-%{gh_commit}
+%patch0 -p1 -b .pr2
+
+
+%build
+# Generate the Autoloader
+%{_bindir}/phpab --template fedora2 --output src/autoload.php src
+
+cat << 'EOF' | tee -a src/autoload.php
+\Fedora\Autoloader\Dependencies::required([
+ '%{ns_vendor}/Version/autoload.php',
+]);
+EOF
+
+
+
+%install
+mkdir -p %{buildroot}%{php_home}/%{ns_vendor}
+cp -pr src %{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}
+
+
+%check
+%if %{with_tests}
+mkdir vendor
+ln -s %{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}/autoload.php vendor/autoload.php
+
+: Run upstream test suite
+ret=0
+for cmd in php70 php71 php; do
+ if which $cmd; then
+ %{_bindir}/php -d include_path=.:%{buildroot}%{_datadir}/php:%{_datadir}/php \
+ %{_bindir}/phpunit6 --verbose || ret=1
+ fi
+done
+exit $ret
+%else
+: bootstrap build with test suite disabled
+%endif
+
+
+%files
+%{!?_licensedir:%global license %%doc}
+%license LICENSE
+%doc README.md composer.json
+%{php_home}/%{ns_vendor}/%{ns_project}%{major}
+
+
+%changelog
+* Fri Apr 7 2017 Remi Collet <remi@remirepo.net> - 1.0.1-1
+- initial package
+