summaryrefslogtreecommitdiffstats
path: root/phan.spec
diff options
context:
space:
mode:
Diffstat (limited to 'phan.spec')
-rw-r--r--phan.spec16
1 files changed, 10 insertions, 6 deletions
diff --git a/phan.spec b/phan.spec
index 657ef8e..ae530cb 100644
--- a/phan.spec
+++ b/phan.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 53d9a6163ab7f9de1fd89b48e56bb5df985950aa
+%global gh_commit df27ddf25fbe01ca97278e31175c458c63f543ad
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner phan
#global gh_date 20150820
@@ -15,8 +15,8 @@
%global with_tests 0%{!?_without_tests:1}
Name: %{gh_project}
-Version: 0.10.2
-Release: 1%{?gh_date?%{gh_date}git%{gh_short}}%{?dist}.7.1
+Version: 0.11.0
+Release: 1%{?gh_date?%{gh_date}git%{gh_short}}%{?dist}.7.2
Summary: A static analyzer for PHP
Group: Development/Libraries
@@ -29,8 +29,8 @@ Patch0: %{name}-autoload.patch
BuildArch: noarch
%if %{with_tests}
-BuildRequires: php(language) < 7.2
-BuildRequires: php(language) >= 7.1
+BuildRequires: php(language) < 7.3
+BuildRequires: php(language) >= 7.2
BuildRequires: php-ast >= 0.1.5
BuildRequires: php-composer(felixfbecker/advanced-json-rpc) < 3
BuildRequires: php-composer(felixfbecker/advanced-json-rpc) >= 2.0
@@ -67,7 +67,7 @@ BuildRequires: php-composer(fedora/autoloader)
# "nikic/PHP-Parser": "~3.1.1",
# "sabre/event": "^5.0",
# "symfony/console": "~2.3|~3.0"
-Requires: php(language) >= 7.1
+Requires: php(language) >= 7.2
Requires: php-ast >= 0.1.5
Requires: php-composer(felixfbecker/advanced-json-rpc) < 3
Requires: php-composer(felixfbecker/advanced-json-rpc) >= 2.0
@@ -178,6 +178,10 @@ rm -rf %{buildroot}
%changelog
+* Sat Nov 18 2017 Remi Collet <remi@remirepo.net> - 0.11.0-1
+- Update to 0.11.0
+- raise dependency on PHP 7.2
+
* Sat Nov 18 2017 Remi Collet <remi@remirepo.net> - 0.10.2-1
- Update to 0.10.2