summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json2
-rw-r--r--phan-autoload.patch33
-rw-r--r--phan.spec16
3 files changed, 32 insertions, 19 deletions
diff --git a/composer.json b/composer.json
index 94b7a4b..f503287 100644
--- a/composer.json
+++ b/composer.json
@@ -37,7 +37,7 @@
"symfony/polyfill-php80": "^1.20.0"
},
"suggest": {
- "ext-ast": "Needed for parsing ASTs (unless --use-fallback-parser is used). 1.0.1+ is needed, 1.0.8+ is recommended.",
+ "ext-ast": "Needed for parsing ASTs (unless --use-fallback-parser is used). 1.0.1+ is needed, 1.0.10+ is recommended.",
"ext-iconv": "Either iconv or mbstring is needed to ensure issue messages are valid utf-8",
"ext-igbinary": "Improves performance of polyfill when ext-ast is unavailable",
"ext-mbstring": "Either iconv or mbstring is needed to ensure issue messages are valid utf-8",
diff --git a/phan-autoload.patch b/phan-autoload.patch
index e063c5e..cf14683 100644
--- a/phan-autoload.patch
+++ b/phan-autoload.patch
@@ -1,8 +1,8 @@
diff -up ./src/Phan/Bootstrap.php.rpm ./src/Phan/Bootstrap.php
---- ./src/Phan/Bootstrap.php.rpm 2020-08-11 11:05:14.019166382 +0200
-+++ ./src/Phan/Bootstrap.php 2020-08-11 11:06:23.713091459 +0200
-@@ -142,24 +142,8 @@ if (extension_loaded('ast')) {
- unset($ast_version);
+--- ./src/Phan/Bootstrap.php.rpm 2021-01-05 09:16:26.831115023 +0100
++++ ./src/Phan/Bootstrap.php 2021-01-05 09:17:54.795753041 +0100
+@@ -102,20 +102,6 @@ EOT
+ fwrite(STDERR, "For more information, see https://github.com/phan/phan/wiki/Getting-Started#installing-dependencies" . PHP_EOL);
}
-// Use the composer autoloader
@@ -18,27 +18,36 @@ diff -up ./src/Phan/Bootstrap.php.rpm ./src/Phan/Bootstrap.php
- break;
- }
-}
+-
+ if (extension_loaded('ast')) {
+ // Warn if the php-ast version is too low.
+ $ast_version = (string)phpversion('ast');
+@@ -162,11 +148,9 @@ if (extension_loaded('ast')) {
+ unset($did_warn);
+ unset($ast_version);
+ }
-unset($file);
-if (!$found_autoloader) {
- fwrite(STDERR, "Could not locate the autoloader\n");
-}
-unset($found_autoloader);
++
+// Use the fedora autoloader
+require_once __DIR__ . '/../autoload.php';
define('EXIT_SUCCESS', 0);
define('EXIT_FAILURE', 1);
diff -up ./src/phan.php.rpm ./src/phan.php
---- ./src/phan.php.rpm 2020-08-11 10:59:01.000000000 +0200
-+++ ./src/phan.php 2020-08-11 11:05:14.019166382 +0200
+--- ./src/phan.php.rpm 2021-01-05 09:15:30.000000000 +0100
++++ ./src/phan.php 2021-01-05 09:16:26.832115019 +0100
@@ -1,3 +1,4 @@
+#!/usr/bin/env php
<?php
declare(strict_types=1);
diff -up ./src/Phan/Plugin/ConfigPluginSet.php.rpm ./src/Phan/Plugin/ConfigPluginSet.php
---- ./src/Phan/Plugin/ConfigPluginSet.php.rpm 2020-08-11 10:59:01.000000000 +0200
-+++ ./src/Phan/Plugin/ConfigPluginSet.php 2020-08-11 11:05:14.019166382 +0200
+--- ./src/Phan/Plugin/ConfigPluginSet.php.rpm 2021-01-05 09:15:30.000000000 +0100
++++ ./src/Phan/Plugin/ConfigPluginSet.php 2021-01-05 09:16:26.832115019 +0100
@@ -904,7 +904,7 @@ final class ConfigPluginSet extends Plug
*/
public static function getBuiltinPluginDirectory(): string
@@ -49,16 +58,16 @@ diff -up ./src/Phan/Plugin/ConfigPluginSet.php.rpm ./src/Phan/Plugin/ConfigPlugi
private function ensurePluginsExist(): void
diff -up ./src/prep.php.rpm ./src/prep.php
---- ./src/prep.php.rpm 2020-08-11 10:59:01.000000000 +0200
-+++ ./src/prep.php 2020-08-11 11:05:14.019166382 +0200
+--- ./src/prep.php.rpm 2021-01-05 09:15:30.000000000 +0100
++++ ./src/prep.php 2021-01-05 09:16:26.832115019 +0100
@@ -1,3 +1,4 @@
+#!/usr/bin/env php
<?php
declare(strict_types=1);
diff -up ./src/requirements.php.rpm ./src/requirements.php
---- ./src/requirements.php.rpm 2020-08-11 10:59:01.000000000 +0200
-+++ ./src/requirements.php 2020-08-11 11:05:14.019166382 +0200
+--- ./src/requirements.php.rpm 2021-01-05 09:15:30.000000000 +0100
++++ ./src/requirements.php 2021-01-05 09:16:26.832115019 +0100
@@ -2,11 +2,11 @@
declare(strict_types=1);
diff --git a/phan.spec b/phan.spec
index be8b042..437d045 100644
--- a/phan.spec
+++ b/phan.spec
@@ -10,14 +10,14 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit 08978125063189a3e43448c99d50afd3b216234c
+%global gh_commit 6f7acd037847d390175e73d71b14f38da037965f
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner phan
#global gh_date 20150820
%global gh_project phan
%global psr0 Phan
%bcond_without tests
-%global upstream_version 3.2.10
+%global upstream_version 4.0.1
#global upstream_prever RC2
Name: %{gh_project}
@@ -36,7 +36,7 @@ Patch0: %{name}-autoload.patch
BuildArch: noarch
%if %{with tests}
BuildRequires: php(language) >= 7.2
-BuildRequires: php-ast >= 1.0.8
+BuildRequires: php-ast >= 1.0.10
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(composer/semver) >= 1.4 with php-composer(composer/semver) < 4)
@@ -105,12 +105,12 @@ Requires: php-json
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
# From composer.json, "suggest": {
-# "ext-ast": "Needed for parsing ASTs (unless --use-fallback-parser is used). 1.0.1+ is needed, 1.0.8+ is recommended.",
+# "ext-ast": "Needed for parsing ASTs (unless --use-fallback-parser is used). 1.0.1+ is needed, 1.0.10+ is recommended.",
# "ext-iconv": "Either iconv or mbstring is needed to ensure issue messages are valid utf-8",
# "ext-igbinary": "Improves performance of polyfill when ext-ast is unavailable",
# "ext-mbstring": "Either iconv or mbstring is needed to ensure issue messages are valid utf-8",
# "ext-tokenizer": "Needed for non-AST support and file/line-based suppressions."
-Recommends: php-ast >= 1.0.8
+Recommends: php-ast >= 1.0.10
Suggests: php-igbinary
Suggests: php-iconv
Requires: (php-composer(composer/semver) >= 1.4 with php-composer(composer/semver) < 4)
@@ -124,7 +124,7 @@ Requires: (php-composer(symfony/console) >= 3.2 with php-
Requires: (php-composer(symfony/polyfill-php80) >= 1.19 with php-composer(symfony/polyfill-php80) < 2)
# remirepo:15
%else
-Requires: php-ast >= 1.0.1
+Requires: php-ast >= 1.0.10
Requires: php-composer(composer/semver) < 4
Requires: php-composer(composer/semver) >= 1.4
Requires: php-composer(composer/xdebug-handler) < 2
@@ -251,6 +251,10 @@ EOF
%changelog
+* Tue Jan 5 2021 Remi Collet <remi@remirepo.net> - 4.0.1-1
+- update to 4.0.1
+- raise dependency on ast 1.0.10
+
* Tue Jan 5 2021 Remi Collet <remi@remirepo.net> - 3.2.10-1
- update to 3.2.10