summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json1
-rw-r--r--phan.spec17
2 files changed, 14 insertions, 4 deletions
diff --git a/composer.json b/composer.json
index c2d6040..bd45601 100644
--- a/composer.json
+++ b/composer.json
@@ -34,6 +34,7 @@
},
"suggest": {
"ext-ast": "Needed for parsing ASTs (unless --use-fallback-parser is used). 1.0.1+ is recommended, php-ast ^0.1.5|^1.0.0 is needed.",
+ "ext-igbinary": "Improves performance of polyfill when ext-ast is unavailable",
"ext-tokenizer": "Needed for non-AST support and file/line-based suppressions."
},
"require-dev": {
diff --git a/phan.spec b/phan.spec
index 038a02e..d5d8aa7 100644
--- a/phan.spec
+++ b/phan.spec
@@ -10,7 +10,7 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit bf1fc09b21e6bb64dca56d0e99a0f3099c00280a
+%global gh_commit c987c6621a8b7595320c851bd8553115e49436b1
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner phan
#global gh_date 20150820
@@ -19,7 +19,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: %{gh_project}
-Version: 1.2.4
+Version: 1.2.5
Release: 1%{?gh_date?%{gh_date}git%{gh_short}}%{?dist}
Summary: A static analyzer for PHP
@@ -62,6 +62,7 @@ BuildRequires: php-ctype
BuildRequires: php-dom
BuildRequires: php-filter
BuildRequires: php-json
+BuildRequires: php-mbstring
BuildRequires: php-pcntl
BuildRequires: php-pcre
BuildRequires: php-posix
@@ -95,8 +96,10 @@ Requires: php-json
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
# From composer.json, "suggest": {
# "ext-ast": "Needed for parsing ASTs (unless --use-fallback-parser is used). php-ast ^0.1.5|^1.0.0 is needed.",
+# "ext-igbinary": "Improves performance of polyfill when ext-ast is unavailable",
# "ext-tokenizer": "Needed for non-AST support and file/line-based suppressions."
Recommends: php-ast >= 0.1.5
+Suggests: php-igbinary
Recommends: php-tokenizer
Requires: (php-composer(composer/semver) >= 1.4 with php-composer(composer/semver) < 2)
Requires: (php-composer(composer/xdebug-handler) >= 1.3.2 with php-composer(composer/xdebug-handler) < 2)
@@ -120,11 +123,12 @@ Requires: php-composer(sabre/event) < 6
Requires: php-composer(sabre/event) >= 5.0
Requires: php-composer(symfony/console) < 4
%endif
-# From phpcompatinfo report for 1.1.1
+# From phpcompatinfo report for 1.2.5
Requires: php-cli
+Requires: php-reflection
Requires: php-ctype
Requires: php-dom
-Requires: php-reflection
+Requires: php-mbstring
Requires: php-pcntl
Requires: php-pcre
Requires: php-posix
@@ -221,6 +225,11 @@ EOF
%changelog
+* Wed Feb 27 2019 Remi Collet <remi@remirepo.net> - 1.2.5-1
+- update to 1.2.5
+- add dependecy on mbstring
+- add weak dependecy on igbinary
+
* Tue Feb 19 2019 Remi Collet <remi@remirepo.net> - 1.2.4-1
- update to 1.2.4
- raise dependency on composer/xdebug-handler 1.3.2