summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-xmakesrc.sh28
-rw-r--r--phan.spec13
2 files changed, 36 insertions, 5 deletions
diff --git a/makesrc.sh b/makesrc.sh
new file mode 100755
index 0000000..37cb6a2
--- /dev/null
+++ b/makesrc.sh
@@ -0,0 +1,28 @@
+#!/bin/bash
+
+NAME=$(basename $PWD)
+OWNER=$(sed -n '/^%global gh_owner/{s/.* //;p}' $NAME.spec)
+PROJECT=$(sed -n '/^%global gh_project/{s/.* //;p}' $NAME.spec)
+VERSION=$(sed -n '/^Version:/{s/.* //;p}' $NAME.spec)
+COMMIT=$(sed -n '/^%global gh_commit/{s/.* //;p}' $NAME.spec)
+SHORT=${COMMIT:0:7}
+
+echo -e "\nCreate git snapshot\nName=$NAME, Owner=$OWNER, Project=$PROJECT, Version=$VERSION\n"
+
+echo "Cloning..."
+rm -rf $PROJECT-$COMMIT
+git clone https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT
+
+echo "Getting commit..."
+pushd $PROJECT-$COMMIT
+git checkout $COMMIT
+cp composer.json ../composer.json
+popd
+
+echo "Archiving..."
+tar czf $NAME-$VERSION-$SHORT.tgz --exclude-vcs $PROJECT-$COMMIT
+
+echo "Cleaning..."
+rm -rf $PROJECT-$COMMIT
+
+echo "Done."
diff --git a/phan.spec b/phan.spec
index 89d7ab7..e8c770f 100644
--- a/phan.spec
+++ b/phan.spec
@@ -10,9 +10,7 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-# Warning, see https://github.com/phan/phan/issues/1986
-# need to use the last commit "before" the tag
-%global gh_commit c37a0532f8c6d1a525a1d1c4f478115d81dc6883
+%global gh_commit 11eb4f3235ccc2ce5a5709bccdbdb674152e36ba
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner phan
#global gh_date 20150820
@@ -21,13 +19,14 @@
%global with_tests 0%{!?_without_tests:1}
Name: %{gh_project}
-Version: 1.0.5
+Version: 1.0.6
Release: 1%{?gh_date?%{gh_date}git%{gh_short}}%{?dist}
Summary: A static analyzer for PHP
License: MIT
URL: https://github.com/%{gh_owner}/%{gh_project}
-Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{?gh_short}.tar.gz
+Source0: %{name}-%{version}-%{?gh_short}.tgz
+Source1: makesrc.sh
# Use fedora autoloader
Patch0: %{name}-autoload.patch
@@ -216,6 +215,10 @@ EOF
%changelog
+* Wed Sep 26 2018 Remi Collet <remi@remirepo.net> - 1.0.6-1
+- update to 1.0.6
+- sources from git snapshot
+
* Sat Sep 22 2018 Remi Collet <remi@remirepo.net> - 1.0.5-1
- update to 1.0.5
- open https://github.com/phan/phan/issues/1986 keep the tests