summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--phan-autoload.patch28
-rw-r--r--phan.spec7
2 files changed, 19 insertions, 16 deletions
diff --git a/phan-autoload.patch b/phan-autoload.patch
index 4ae0120..9bc9d26 100644
--- a/phan-autoload.patch
+++ b/phan-autoload.patch
@@ -1,6 +1,6 @@
diff -up ./src/codebase.php.rpm ./src/codebase.php
---- ./src/codebase.php.rpm 2019-02-04 09:48:33.000000000 +0100
-+++ ./src/codebase.php 2019-02-04 09:48:43.437084347 +0100
+--- ./src/codebase.php.rpm 2019-02-11 17:22:46.000000000 +0100
++++ ./src/codebase.php 2019-02-11 17:22:57.300333846 +0100
@@ -6,15 +6,8 @@ $internal_interface_name_list = get_decl
$internal_trait_name_list = get_declared_traits();
$internal_function_name_list = get_defined_functions()['internal'];
@@ -20,8 +20,8 @@ diff -up ./src/codebase.php.rpm ./src/codebase.php
use Composer\XdebugHandler\XdebugHandler;
use Phan\CodeBase;
diff -up ./src/Phan/Bootstrap.php.rpm ./src/Phan/Bootstrap.php
---- ./src/Phan/Bootstrap.php.rpm 2019-02-04 09:48:33.000000000 +0100
-+++ ./src/Phan/Bootstrap.php 2019-02-04 09:48:43.437084347 +0100
+--- ./src/Phan/Bootstrap.php.rpm 2019-02-11 17:22:46.000000000 +0100
++++ ./src/Phan/Bootstrap.php 2019-02-11 17:22:57.300333846 +0100
@@ -13,16 +13,8 @@ ini_set("memory_limit", '-1');
define('CLASS_DIR', __DIR__ . '/../');
set_include_path(get_include_path() . PATH_SEPARATOR . CLASS_DIR);
@@ -42,36 +42,36 @@ diff -up ./src/Phan/Bootstrap.php.rpm ./src/Phan/Bootstrap.php
define('EXIT_SUCCESS', 0);
define('EXIT_FAILURE', 1);
diff -up ./src/phan.php.rpm ./src/phan.php
---- ./src/phan.php.rpm 2019-02-04 09:48:33.000000000 +0100
-+++ ./src/phan.php 2019-02-04 09:48:43.437084347 +0100
+--- ./src/phan.php.rpm 2019-02-11 17:22:46.000000000 +0100
++++ ./src/phan.php 2019-02-11 17:22:57.300333846 +0100
@@ -1,3 +1,4 @@
+#!/usr/bin/env php
<?php declare(strict_types=1);
// Phan does a ton of GC and this offers a major speed
diff -up ./src/Phan/Plugin/ConfigPluginSet.php.rpm ./src/Phan/Plugin/ConfigPluginSet.php
---- ./src/Phan/Plugin/ConfigPluginSet.php.rpm 2019-02-04 09:48:43.437084347 +0100
-+++ ./src/Phan/Plugin/ConfigPluginSet.php 2019-02-04 09:50:11.185598376 +0100
-@@ -727,7 +727,7 @@ final class ConfigPluginSet extends Plug
+--- ./src/Phan/Plugin/ConfigPluginSet.php.rpm 2019-02-11 17:22:57.300333846 +0100
++++ ./src/Phan/Plugin/ConfigPluginSet.php 2019-02-11 17:23:39.638557107 +0100
+@@ -732,7 +732,7 @@ final class ConfigPluginSet extends Plug
public static function normalizePluginPath(string $plugin_file_name) : string
{
if (\preg_match('@^[a-zA-Z_\x7f-\xff][a-zA-Z0-9_\x7f-\xff]*$@', $plugin_file_name) > 0) {
-- return dirname(dirname(dirname(__DIR__))) . '/.phan/plugins/' . $plugin_file_name . '.php';
+- return dirname(__DIR__, 3) . '/.phan/plugins/' . $plugin_file_name . '.php';
+ return '/usr/share/php/Phan/plugins/' . $plugin_file_name . '.php';
}
return $plugin_file_name;
}
diff -up ./src/prep.php.rpm ./src/prep.php
---- ./src/prep.php.rpm 2019-02-04 09:48:33.000000000 +0100
-+++ ./src/prep.php 2019-02-04 09:48:43.437084347 +0100
+--- ./src/prep.php.rpm 2019-02-11 17:22:46.000000000 +0100
++++ ./src/prep.php 2019-02-11 17:22:57.300333846 +0100
@@ -1,3 +1,4 @@
+#!/usr/bin/env php
<?php declare(strict_types=1);
// Phan does a ton of GC and this offers a major speed
diff -up ./src/requirements.php.rpm ./src/requirements.php
---- ./src/requirements.php.rpm 2019-02-04 09:48:33.000000000 +0100
-+++ ./src/requirements.php 2019-02-04 09:48:43.438084353 +0100
+--- ./src/requirements.php.rpm 2019-02-11 17:22:46.000000000 +0100
++++ ./src/requirements.php 2019-02-11 17:22:57.300333846 +0100
@@ -8,10 +8,10 @@ if ((int)phpversion()[0] < 7) {
exit(1);
}
diff --git a/phan.spec b/phan.spec
index bae7853..ce8b35e 100644
--- a/phan.spec
+++ b/phan.spec
@@ -10,7 +10,7 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit ef46ee68afecf9e0188e9329dd922b346876a00a
+%global gh_commit 532c43562af1206f68b504a89cc71737063b3972
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner phan
#global gh_date 20150820
@@ -19,7 +19,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: %{gh_project}
-Version: 1.2.2
+Version: 1.2.3
Release: 1%{?gh_date?%{gh_date}git%{gh_short}}%{?dist}
Summary: A static analyzer for PHP
@@ -221,6 +221,9 @@ EOF
%changelog
+* Mon Feb 11 2019 Remi Collet <remi@remirepo.net> - 1.2.3-1
+- update to 1.2.3
+
* Mon Feb 4 2019 Remi Collet <remi@remirepo.net> - 1.2.2-1
- update to 1.2.2