summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json2
-rw-r--r--phan.spec13
2 files changed, 9 insertions, 6 deletions
diff --git a/composer.json b/composer.json
index d8bac11..5781780 100644
--- a/composer.json
+++ b/composer.json
@@ -38,7 +38,7 @@
"tysonandre/var_representation_polyfill": "^0.0.2"
},
"suggest": {
- "ext-ast": "Needed for parsing ASTs (unless --use-fallback-parser is used). 1.0.1+ is needed, 1.0.10+ is recommended.",
+ "ext-ast": "Needed for parsing ASTs (unless --use-fallback-parser is used). 1.0.1+ is needed, 1.0.14+ is recommended.",
"ext-iconv": "Either iconv or mbstring is needed to ensure issue messages are valid utf-8",
"ext-igbinary": "Improves performance of polyfill when ext-ast is unavailable",
"ext-mbstring": "Either iconv or mbstring is needed to ensure issue messages are valid utf-8",
diff --git a/phan.spec b/phan.spec
index e63f6b6..3f2f5d8 100644
--- a/phan.spec
+++ b/phan.spec
@@ -10,7 +10,7 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit 938daa040d31b446210afa2563386d5e41b0a6de
+%global gh_commit 1eb3c31ef21d2d4dcc3ea6079dc1a251ceb81a9d
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner phan
#global gh_date 20150820
@@ -18,7 +18,7 @@
%global psr0 Phan
%bcond_without tests
%global upstream_version 5.0.0
-%global upstream_prever a3
+%global upstream_prever a4
Name: %{gh_project}
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
@@ -36,7 +36,7 @@ Patch0: %{name}-autoload.patch
BuildArch: noarch
%if %{with tests}
BuildRequires: php(language) >= 7.2
-BuildRequires: php-ast >= 1.0.10
+BuildRequires: php-ast >= 1.0.14
BuildRequires: php-var_representation
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
@@ -108,12 +108,12 @@ Requires: php-var_representation
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
# From composer.json, "suggest": {
-# "ext-ast": "Needed for parsing ASTs (unless --use-fallback-parser is used). 1.0.1+ is needed, 1.0.10+ is recommended.",
+# "ext-ast": "Needed for parsing ASTs (unless --use-fallback-parser is used). 1.0.1+ is needed, 1.0.14+ is recommended.",
# "ext-iconv": "Either iconv or mbstring is needed to ensure issue messages are valid utf-8",
# "ext-igbinary": "Improves performance of polyfill when ext-ast is unavailable",
# "ext-mbstring": "Either iconv or mbstring is needed to ensure issue messages are valid utf-8",
# "ext-tokenizer": "Needed for non-AST support and file/line-based suppressions."
-Recommends: php-ast >= 1.0.10
+Recommends: php-ast >= 1.0.14
Suggests: php-igbinary
Suggests: php-iconv
Requires: (php-composer(composer/semver) >= 1.4 with php-composer(composer/semver) < 4)
@@ -253,6 +253,9 @@ EOF
%changelog
+* Mon Jul 26 2021 Remi Collet <remi@remirepo.net> - 5.0.0~a4-1
+- update to 5.0.0a4
+
* Mon Jul 19 2021 Remi Collet <remi@remirepo.net> - 5.0.0~a3-1
- update to 5.0.0a3