summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json2
-rw-r--r--phan.spec11
2 files changed, 10 insertions, 3 deletions
diff --git a/composer.json b/composer.json
index c1675f3..31f549d 100644
--- a/composer.json
+++ b/composer.json
@@ -23,7 +23,6 @@
},
"require": {
"php": "^7.0.0",
- "ext-ast": "^0.1.5",
"ext-filter": "*",
"ext-json": "*",
"composer/semver": "^1.4",
@@ -34,6 +33,7 @@
"symfony/console": "^2.3|^3.0|~4.0"
},
"suggest": {
+ "ext-ast": "^0.1.5",
"ext-tokenizer": "Needed for non-AST support and file/line-based suppressions"
},
"require-dev": {
diff --git a/phan.spec b/phan.spec
index 9a62142..89d7ab7 100644
--- a/phan.spec
+++ b/phan.spec
@@ -10,7 +10,9 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit d1573162443915fca6e7cd4add15af77ab168525
+# Warning, see https://github.com/phan/phan/issues/1986
+# need to use the last commit "before" the tag
+%global gh_commit c37a0532f8c6d1a525a1d1c4f478115d81dc6883
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner phan
#global gh_date 20150820
@@ -19,7 +21,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: %{gh_project}
-Version: 1.0.4
+Version: 1.0.5
Release: 1%{?gh_date?%{gh_date}git%{gh_short}}%{?dist}
Summary: A static analyzer for PHP
@@ -214,6 +216,11 @@ EOF
%changelog
+* Sat Sep 22 2018 Remi Collet <remi@remirepo.net> - 1.0.5-1
+- update to 1.0.5
+- open https://github.com/phan/phan/issues/1986 keep the tests
+- keep ast mandatory despite it is now optional
+
* Mon Sep 10 2018 Remi Collet <remi@remirepo.net> - 1.0.4-1
- update to 1.0.4
- add the upstream plugins