summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json4
-rw-r--r--phan-autoload.patch56
-rw-r--r--phan.spec18
3 files changed, 33 insertions, 45 deletions
diff --git a/composer.json b/composer.json
index e19564e..c2d6040 100644
--- a/composer.json
+++ b/composer.json
@@ -26,14 +26,14 @@
"ext-filter": "*",
"ext-json": "*",
"composer/semver": "^1.4",
- "composer/xdebug-handler": "^1.3",
+ "composer/xdebug-handler": "^1.3.2",
"felixfbecker/advanced-json-rpc": "^3.0.3",
"microsoft/tolerant-php-parser": "0.0.16",
"sabre/event": "^5.0",
"symfony/console": "^2.3|^3.0|~4.0"
},
"suggest": {
- "ext-ast": "Needed for parsing ASTs (unless --use-fallback-parser is used). php-ast ^0.1.5|^1.0.0 is needed.",
+ "ext-ast": "Needed for parsing ASTs (unless --use-fallback-parser is used). 1.0.1+ is recommended, php-ast ^0.1.5|^1.0.0 is needed.",
"ext-tokenizer": "Needed for non-AST support and file/line-based suppressions."
},
"require-dev": {
diff --git a/phan-autoload.patch b/phan-autoload.patch
index 9bc9d26..4ea6d9e 100644
--- a/phan-autoload.patch
+++ b/phan-autoload.patch
@@ -1,77 +1,61 @@
-diff -up ./src/codebase.php.rpm ./src/codebase.php
---- ./src/codebase.php.rpm 2019-02-11 17:22:46.000000000 +0100
-+++ ./src/codebase.php 2019-02-11 17:22:57.300333846 +0100
-@@ -6,15 +6,8 @@ $internal_interface_name_list = get_decl
- $internal_trait_name_list = get_declared_traits();
- $internal_function_name_list = get_defined_functions()['internal'];
-
--
--// @phan-file-suppress PhanMissingRequireFile one of these will be missing
--if (file_exists(__DIR__ . '/../vendor/autoload.php')) {
-- // This is the path to autoload.php when Phan is installed globally.
-- require_once __DIR__ . '/../vendor/autoload.php';
--} else {
-- // This is the normal path when Phan is installed only in the scope of a project.
-- require_once __DIR__ . '/../../../autoload.php';
--}
-+// Use the fedora autoloader
-+require_once __DIR__ . '/autoload.php';
-
- use Composer\XdebugHandler\XdebugHandler;
- use Phan\CodeBase;
diff -up ./src/Phan/Bootstrap.php.rpm ./src/Phan/Bootstrap.php
---- ./src/Phan/Bootstrap.php.rpm 2019-02-11 17:22:46.000000000 +0100
-+++ ./src/Phan/Bootstrap.php 2019-02-11 17:22:57.300333846 +0100
-@@ -13,16 +13,8 @@ ini_set("memory_limit", '-1');
+--- ./src/Phan/Bootstrap.php.rpm 2019-02-19 07:22:34.639868164 +0100
++++ ./src/Phan/Bootstrap.php 2019-02-19 07:25:01.412126803 +0100
+@@ -14,21 +14,8 @@ ini_set("memory_limit", '-1');
define('CLASS_DIR', __DIR__ . '/../');
set_include_path(get_include_path() . PATH_SEPARATOR . CLASS_DIR);
-// Use the composer autoloader
+-$found_autoloader = false;
-foreach ([
-- __DIR__ . '/../../vendor/autoload.php', // autoloader is in this project
-- __DIR__ . '/../../../../../vendor/autoload.php', // autoloader is in parent project
+- dirname(__DIR__, 2) . '/vendor/autoload.php', // autoloader is in this project (we're in src/Phan and want vendor/autoload.php)
+- dirname(__DIR__, 5) . '/vendor/autoload.php', // autoloader is in parent project (we're in vendor/phan/phan/src/Phan/Bootstrap.php and want autoload.php
- ] as $file) {
- if (file_exists($file)) {
- require_once($file);
+- $found_autoloader = true;
- break;
- }
-}
+-if (!$found_autoloader) {
+- fwrite(STDERR, "Could not locate the autoloader\n");
+-}
+// Use the fedora autoloader
+require_once __DIR__ . '/../autoload.php';
define('EXIT_SUCCESS', 0);
define('EXIT_FAILURE', 1);
diff -up ./src/phan.php.rpm ./src/phan.php
---- ./src/phan.php.rpm 2019-02-11 17:22:46.000000000 +0100
-+++ ./src/phan.php 2019-02-11 17:22:57.300333846 +0100
+--- ./src/phan.php.rpm 2019-02-19 07:20:58.000000000 +0100
++++ ./src/phan.php 2019-02-19 07:22:34.639868164 +0100
@@ -1,3 +1,4 @@
+#!/usr/bin/env php
<?php declare(strict_types=1);
// Phan does a ton of GC and this offers a major speed
diff -up ./src/Phan/Plugin/ConfigPluginSet.php.rpm ./src/Phan/Plugin/ConfigPluginSet.php
---- ./src/Phan/Plugin/ConfigPluginSet.php.rpm 2019-02-11 17:22:57.300333846 +0100
-+++ ./src/Phan/Plugin/ConfigPluginSet.php 2019-02-11 17:23:39.638557107 +0100
-@@ -732,7 +732,7 @@ final class ConfigPluginSet extends Plug
+--- ./src/Phan/Plugin/ConfigPluginSet.php.rpm 2019-02-19 07:20:58.000000000 +0100
++++ ./src/Phan/Plugin/ConfigPluginSet.php 2019-02-19 07:22:34.640868166 +0100
+@@ -739,7 +739,7 @@ final class ConfigPluginSet extends Plug
public static function normalizePluginPath(string $plugin_file_name) : string
{
if (\preg_match('@^[a-zA-Z_\x7f-\xff][a-zA-Z0-9_\x7f-\xff]*$@', $plugin_file_name) > 0) {
- return dirname(__DIR__, 3) . '/.phan/plugins/' . $plugin_file_name . '.php';
-+ return '/usr/share/php/Phan/plugins/' . $plugin_file_name . '.php';
++ return dirname(__DIR__, 2) . '/plugins/' . $plugin_file_name . '.php';
}
return $plugin_file_name;
}
diff -up ./src/prep.php.rpm ./src/prep.php
---- ./src/prep.php.rpm 2019-02-11 17:22:46.000000000 +0100
-+++ ./src/prep.php 2019-02-11 17:22:57.300333846 +0100
+--- ./src/prep.php.rpm 2019-02-19 07:20:58.000000000 +0100
++++ ./src/prep.php 2019-02-19 07:22:34.640868166 +0100
@@ -1,3 +1,4 @@
+#!/usr/bin/env php
<?php declare(strict_types=1);
// Phan does a ton of GC and this offers a major speed
diff -up ./src/requirements.php.rpm ./src/requirements.php
---- ./src/requirements.php.rpm 2019-02-11 17:22:46.000000000 +0100
-+++ ./src/requirements.php 2019-02-11 17:22:57.300333846 +0100
+--- ./src/requirements.php.rpm 2019-02-19 07:20:58.000000000 +0100
++++ ./src/requirements.php 2019-02-19 07:22:34.640868166 +0100
@@ -8,10 +8,10 @@ if ((int)phpversion()[0] < 7) {
exit(1);
}
diff --git a/phan.spec b/phan.spec
index ce8b35e..038a02e 100644
--- a/phan.spec
+++ b/phan.spec
@@ -10,7 +10,7 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit 532c43562af1206f68b504a89cc71737063b3972
+%global gh_commit bf1fc09b21e6bb64dca56d0e99a0f3099c00280a
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner phan
#global gh_date 20150820
@@ -19,7 +19,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: %{gh_project}
-Version: 1.2.3
+Version: 1.2.4
Release: 1%{?gh_date?%{gh_date}git%{gh_short}}%{?dist}
Summary: A static analyzer for PHP
@@ -38,7 +38,7 @@ BuildRequires: php-ast >= 0.1.5
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(composer/semver) >= 1.4 with php-composer(composer/semver) < 2)
-BuildRequires: (php-composer(composer/xdebug-handler) >= 1.3 with php-composer(composer/xdebug-handler) < 2)
+BuildRequires: (php-composer(composer/xdebug-handler) >= 1.3.2 with php-composer(composer/xdebug-handler) < 2)
BuildRequires: (php-composer(felixfbecker/advanced-json-rpc) >= 3.0.3 with php-composer(felixfbecker/advanced-json-rpc) < 4)
BuildRequires: (php-composer(microsoft/tolerant-php-parser) >= 0.0.16 with php-composer(microsoft/tolerant-php-parser) < 1)
BuildRequires: (php-composer(sabre/event) >= 5.0 with php-composer(sabre/event) < 6)
@@ -48,7 +48,7 @@ BuildRequires: (php-composer(symfony/console) >= 2.8 with php-
BuildRequires: php-composer(composer/semver) < 2
BuildRequires: php-composer(composer/semver) >= 1.4
BuildRequires: php-composer(composer/xdebug-handler) < 2
-BuildRequires: php-composer(composer/xdebug-handler) >= 1.3
+BuildRequires: php-composer(composer/xdebug-handler) >= 1.3.2
BuildRequires: php-composer(felixfbecker/advanced-json-rpc) < 4
BuildRequires: php-composer(felixfbecker/advanced-json-rpc) >= 3.0.3
BuildRequires: php-composer(microsoft/tolerant-php-parser) < 1
@@ -83,7 +83,7 @@ BuildRequires: php-composer(fedora/autoloader)
# "ext-filter": "*",
# "ext-json": "*",
# "composer/semver": "^1.4",
-# "composer/xdebug-handler": "^1.3",
+# "composer/xdebug-handler": "^1.3.2",
# "felixfbecker/advanced-json-rpc": "^3.0.3",
# "microsoft/tolerant-php-parser": "0.0.16",
# "sabre/event": "^5.0",
@@ -99,7 +99,7 @@ Requires: php-json
Recommends: php-ast >= 0.1.5
Recommends: php-tokenizer
Requires: (php-composer(composer/semver) >= 1.4 with php-composer(composer/semver) < 2)
-Requires: (php-composer(composer/xdebug-handler) >= 1.3 with php-composer(composer/xdebug-handler) < 2)
+Requires: (php-composer(composer/xdebug-handler) >= 1.3.2 with php-composer(composer/xdebug-handler) < 2)
Requires: (php-composer(felixfbecker/advanced-json-rpc) >= 3.0.3 with php-composer(felixfbecker/advanced-json-rpc) < 4)
Requires: (php-composer(nikic/php-parser) >= 3.1.1 with php-composer(nikic/php-parser) < 4)
Requires: (php-composer(microsoft/tolerant-php-parser) >= 0.0.16 with php-composer(microsoft/tolerant-php-parser) < 1)
@@ -111,7 +111,7 @@ Requires: php-ast >= 0.1.5
Requires: php-composer(composer/semver) < 2
Requires: php-composer(composer/semver) >= 1.4
Requires: php-composer(composer/xdebug-handler) < 2
-Requires: php-composer(composer/xdebug-handler) >= 1.3
+Requires: php-composer(composer/xdebug-handler) >= 1.3.2
Requires: php-composer(felixfbecker/advanced-json-rpc) < 4
Requires: php-composer(felixfbecker/advanced-json-rpc) >= 3.0.3
Requires: php-composer(microsoft/tolerant-php-parser) < 1
@@ -221,6 +221,10 @@ EOF
%changelog
+* Tue Feb 19 2019 Remi Collet <remi@remirepo.net> - 1.2.4-1
+- update to 1.2.4
+- raise dependency on composer/xdebug-handler 1.3.2
+
* Mon Feb 11 2019 Remi Collet <remi@remirepo.net> - 1.2.3-1
- update to 1.2.3