summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-10-23 10:41:07 +0200
committerRemi Collet <remi@remirepo.net>2018-10-23 10:41:07 +0200
commit330c9abbaa5ff78f6815705820150ca73b19e361 (patch)
tree058d27539c9f644fcce4952eb3678071318debd5
parenteb320088811c78de2be4a094d958770ada14376f (diff)
v1.1.1
-rw-r--r--composer.json4
-rw-r--r--phan-autoload.patch56
-rw-r--r--phan.spec18
3 files changed, 44 insertions, 34 deletions
diff --git a/composer.json b/composer.json
index 08dd618..cf10eee 100644
--- a/composer.json
+++ b/composer.json
@@ -33,8 +33,8 @@
"symfony/console": "^2.3|^3.0|~4.0"
},
"suggest": {
- "ext-ast": "^0.1.5",
- "ext-tokenizer": "Needed for non-AST support and file/line-based suppressions"
+ "ext-ast": "Needed for parsing ASTs (unless --use-fallback-parser is used). php-ast ^0.1.5|^1.0.0 is needed.",
+ "ext-tokenizer": "Needed for non-AST support and file/line-based suppressions."
},
"require-dev": {
"phpunit/phpunit": "^6.3.0"
diff --git a/phan-autoload.patch b/phan-autoload.patch
index 14642fd..eed0e93 100644
--- a/phan-autoload.patch
+++ b/phan-autoload.patch
@@ -1,15 +1,17 @@
diff -up ./src/codebase.php.rpm ./src/codebase.php
---- ./src/codebase.php.rpm 2018-08-27 03:28:15.000000000 +0200
-+++ ./src/codebase.php 2018-08-27 06:58:20.113887853 +0200
-@@ -6,13 +6,8 @@ $internal_interface_name_list = get_decl
+--- ./src/codebase.php.rpm 2018-10-23 10:37:31.657768196 +0200
++++ ./src/codebase.php 2018-10-23 10:38:09.371967988 +0200
+@@ -6,15 +6,8 @@ $internal_interface_name_list = get_decl
$internal_trait_name_list = get_declared_traits();
$internal_function_name_list = get_defined_functions()['internal'];
-if (file_exists(__DIR__ . '/../vendor/autoload.php')) {
-- // This is the normal path when Phan is installed only in the scope of a project.
+- // This is the path to autoload.php when Phan is installed globally.
+- // @phan-suppress-next-line PhanMissingRequireFile
- require_once __DIR__ . '/../vendor/autoload.php';
-} else {
-- // This is the path to autoload.php when Phan is installed globally.
+- // This is the normal path when Phan is installed only in the scope of a project.
+- // @phan-suppress-next-line PhanMissingRequireFile
- require_once __DIR__ . '/../../../autoload.php';
-}
+// Use the fedora autoloader
@@ -18,9 +20,9 @@ diff -up ./src/codebase.php.rpm ./src/codebase.php
use Composer\XdebugHandler\XdebugHandler;
use Phan\CodeBase;
diff -up ./src/Phan/Bootstrap.php.rpm ./src/Phan/Bootstrap.php
---- ./src/Phan/Bootstrap.php.rpm 2018-08-27 03:28:15.000000000 +0200
-+++ ./src/Phan/Bootstrap.php 2018-08-27 06:58:20.114887859 +0200
-@@ -12,16 +12,8 @@ ini_set("memory_limit", '-1');
+--- ./src/Phan/Bootstrap.php.rpm 2018-10-23 10:27:56.000000000 +0200
++++ ./src/Phan/Bootstrap.php 2018-10-23 10:37:31.657768196 +0200
+@@ -13,16 +13,8 @@ ini_set("memory_limit", '-1');
define('CLASS_DIR', __DIR__ . '/../');
set_include_path(get_include_path() . PATH_SEPARATOR . CLASS_DIR);
@@ -40,24 +42,36 @@ diff -up ./src/Phan/Bootstrap.php.rpm ./src/Phan/Bootstrap.php
define('EXIT_SUCCESS', 0);
define('EXIT_FAILURE', 1);
diff -up ./src/phan.php.rpm ./src/phan.php
---- ./src/phan.php.rpm 2018-08-27 03:28:15.000000000 +0200
-+++ ./src/phan.php 2018-08-27 06:58:20.114887859 +0200
+--- ./src/phan.php.rpm 2018-10-23 10:27:56.000000000 +0200
++++ ./src/phan.php 2018-10-23 10:37:31.657768196 +0200
@@ -1,3 +1,4 @@
+#!/usr/bin/env php
<?php declare(strict_types=1);
// Phan does a ton of GC and this offers a major speed
+diff -up ./src/Phan/Plugin/ConfigPluginSet.php.rpm ./src/Phan/Plugin/ConfigPluginSet.php
+--- ./src/Phan/Plugin/ConfigPluginSet.php.rpm 2018-10-23 10:27:56.000000000 +0200
++++ ./src/Phan/Plugin/ConfigPluginSet.php 2018-10-23 10:37:31.657768196 +0200
+@@ -702,7 +702,7 @@ final class ConfigPluginSet extends Plug
+ // E.g. 'AlwaysReturnPlugin' becomes /path/to/phan/.phan/plugins/AlwaysReturnPlugin.php
+ // (Useful when using phan.phar, etc.)
+ if (\preg_match('@^[a-zA-Z_\x7f-\xff][a-zA-Z0-9_\x7f-\xff]*$@', $plugin_file_name) > 0) {
+- $plugin_file_name = __DIR__ . '/../../../.phan/plugins/' . $plugin_file_name . '.php';
++ $plugin_file_name = '/usr/share/php/Phan/plugins/' . $plugin_file_name . '.php';
+ }
+
+ try {
diff -up ./src/prep.php.rpm ./src/prep.php
---- ./src/prep.php.rpm 2018-08-27 03:28:15.000000000 +0200
-+++ ./src/prep.php 2018-08-27 06:58:20.114887859 +0200
+--- ./src/prep.php.rpm 2018-10-23 10:27:56.000000000 +0200
++++ ./src/prep.php 2018-10-23 10:37:31.657768196 +0200
@@ -1,3 +1,4 @@
+#!/usr/bin/env php
<?php declare(strict_types=1);
// Phan does a ton of GC and this offers a major speed
diff -up ./src/requirements.php.rpm ./src/requirements.php
---- ./src/requirements.php.rpm 2018-08-27 06:58:20.114887859 +0200
-+++ ./src/requirements.php 2018-08-27 06:59:57.839473923 +0200
+--- ./src/requirements.php.rpm 2018-10-23 10:37:31.657768196 +0200
++++ ./src/requirements.php 2018-10-23 10:38:38.126120310 +0200
@@ -8,10 +8,10 @@ if ((int)phpversion()[0] < 7) {
exit(1);
}
@@ -66,20 +80,8 @@ diff -up ./src/requirements.php.rpm ./src/requirements.php
+if (!(file_exists(__DIR__ . '/autoload.php'))) {
fwrite(
STDERR,
-- 'Autoloader not found. Make sure you run `composer install` before running Phan. See https://github.com/phan/phan#getting-it-running for more details.'
+- 'Autoloader not found. Make sure you run `composer install` before running Phan. See https://github.com/phan/phan#getting-started for more details.'
+ 'Autoloader not found.'
);
exit(1);
}
-diff -up ./src/Phan/Plugin/ConfigPluginSet.php.rpm ./src/Phan/Plugin/ConfigPluginSet.php
---- ./src/Phan/Plugin/ConfigPluginSet.php.rpm 2018-09-10 15:46:45.304166390 +0200
-+++ ./src/Phan/Plugin/ConfigPluginSet.php 2018-09-10 15:47:16.265325009 +0200
-@@ -687,7 +687,7 @@ final class ConfigPluginSet extends Plug
- // E.g. 'AlwaysReturnPlugin' becomes /path/to/phan/.phan/plugins/AlwaysReturnPlugin.php
- // (Useful when using phan.phar, etc.)
- if (\preg_match('@^[a-zA-Z_\x7f-\xff][a-zA-Z0-9_\x7f-\xff]*$@', $plugin_file_name) > 0) {
-- $plugin_file_name = __DIR__ . '/../../../.phan/plugins/' . $plugin_file_name . '.php';
-+ $plugin_file_name = '/usr/share/php/Phan/plugins/' . $plugin_file_name . '.php';
- }
-
- try {
diff --git a/phan.spec b/phan.spec
index dd9d20c..6d02bdc 100644
--- a/phan.spec
+++ b/phan.spec
@@ -10,7 +10,7 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit aba95779b350f8b19a86d498c141bec2e105a556
+%global gh_commit d8e38b53093677da1e190663c89bdb1087c14046
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner phan
#global gh_date 20150820
@@ -19,7 +19,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: %{gh_project}
-Version: 1.1.0
+Version: 1.1.1
Release: 1%{?gh_date?%{gh_date}git%{gh_short}}%{?dist}
Summary: A static analyzer for PHP
@@ -58,6 +58,7 @@ BuildRequires: php-composer(sabre/event) >= 5.0
BuildRequires: php-composer(symfony/console) < 4
%endif
BuildRequires: php-reflection
+BuildRequires: php-ctype
BuildRequires: php-dom
BuildRequires: php-filter
BuildRequires: php-json
@@ -79,7 +80,6 @@ BuildRequires: php-composer(fedora/autoloader)
# From composer.json, "require": {
# "php": "^7.0.0",
-# "ext-ast": "^0.1.5",
# "ext-filter": "*",
# "ext-json": "*",
# "composer/semver": "^1.4",
@@ -87,13 +87,17 @@ BuildRequires: php-composer(fedora/autoloader)
# "felixfbecker/advanced-json-rpc": "^3.0.3",
# "microsoft/tolerant-php-parser": "0.0.15",
# "sabre/event": "^5.0",
-# "symfony/console": "~2.3|~3.0|~4.0"
+# "symfony/console": "^2.3|^3.0|~4.0"
Requires: php(language) >= 7.0.0
Requires: php-filter
Requires: php-json
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+# From composer.json, "suggest": {
+# "ext-ast": "Needed for parsing ASTs (unless --use-fallback-parser is used). php-ast ^0.1.5|^1.0.0 is needed.",
+# "ext-tokenizer": "Needed for non-AST support and file/line-based suppressions."
Recommends: php-ast >= 0.1.5
+Recommends: php-tokenizer
Requires: (php-composer(composer/semver) >= 1.4 with php-composer(composer/semver) < 2)
Requires: (php-composer(composer/xdebug-handler) >= 1.3 with php-composer(composer/xdebug-handler) < 2)
Requires: (php-composer(felixfbecker/advanced-json-rpc) >= 3.0.3 with php-composer(felixfbecker/advanced-json-rpc) < 4)
@@ -116,8 +120,9 @@ Requires: php-composer(sabre/event) < 6
Requires: php-composer(sabre/event) >= 5.0
Requires: php-composer(symfony/console) < 4
%endif
-# From phpcompatinfo report for 0.8.0
+# From phpcompatinfo report for 1.1.1
Requires: php-cli
+Requires: php-ctype
Requires: php-dom
Requires: php-reflection
Requires: php-pcntl
@@ -216,6 +221,9 @@ EOF
%changelog
+* Tue Oct 23 2018 Remi Collet <remi@remirepo.net> - 1.1.1-1
+- update to 1.1.1
+
* Tue Oct 9 2018 Remi Collet <remi@remirepo.net> - 1.1.0-1
- update to 1.1.0