summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-07-02 07:24:24 +0200
committerRemi Collet <remi@remirepo.net>2020-07-02 07:24:24 +0200
commit12969e0ac7a77009f3670b833e0d4780cb567240 (patch)
treede8a0bcdef30cf863d2715d3b84202b5215641e4
parenteb018a2820a4528e4f1d72b57ad54a0641c8f866 (diff)
update to 3.0.4
-rw-r--r--phan-autoload.patch31
-rw-r--r--phan.spec13
2 files changed, 24 insertions, 20 deletions
diff --git a/phan-autoload.patch b/phan-autoload.patch
index 719ab99..98f39a7 100644
--- a/phan-autoload.patch
+++ b/phan-autoload.patch
@@ -1,7 +1,7 @@
diff -up ./src/Phan/Bootstrap.php.rpm ./src/Phan/Bootstrap.php
---- ./src/Phan/Bootstrap.php.rpm 2020-05-04 10:28:21.581423051 +0200
-+++ ./src/Phan/Bootstrap.php 2020-05-04 10:30:07.345999193 +0200
-@@ -135,22 +135,8 @@ if (extension_loaded('ast')) {
+--- ./src/Phan/Bootstrap.php.rpm 2020-07-02 07:19:00.000000000 +0200
++++ ./src/Phan/Bootstrap.php 2020-07-02 07:19:12.412846692 +0200
+@@ -141,22 +141,8 @@ if (extension_loaded('ast')) {
}
}
@@ -27,17 +27,17 @@ diff -up ./src/Phan/Bootstrap.php.rpm ./src/Phan/Bootstrap.php
define('EXIT_SUCCESS', 0);
define('EXIT_FAILURE', 1);
diff -up ./src/phan.php.rpm ./src/phan.php
---- ./src/phan.php.rpm 2020-05-04 10:26:34.000000000 +0200
-+++ ./src/phan.php 2020-05-04 10:28:21.581423051 +0200
+--- ./src/phan.php.rpm 2020-07-02 07:19:00.000000000 +0200
++++ ./src/phan.php 2020-07-02 07:19:12.412846692 +0200
@@ -1,3 +1,4 @@
+#!/usr/bin/env php
<?php
declare(strict_types=1);
diff -up ./src/Phan/Plugin/ConfigPluginSet.php.rpm ./src/Phan/Plugin/ConfigPluginSet.php
---- ./src/Phan/Plugin/ConfigPluginSet.php.rpm 2020-05-04 10:26:34.000000000 +0200
-+++ ./src/Phan/Plugin/ConfigPluginSet.php 2020-05-04 10:28:21.581423051 +0200
-@@ -820,7 +820,7 @@ final class ConfigPluginSet extends Plug
+--- ./src/Phan/Plugin/ConfigPluginSet.php.rpm 2020-07-02 07:19:00.000000000 +0200
++++ ./src/Phan/Plugin/ConfigPluginSet.php 2020-07-02 07:19:12.412846692 +0200
+@@ -903,7 +903,7 @@ final class ConfigPluginSet extends Plug
*/
public static function getBuiltinPluginDirectory(): string
{
@@ -47,22 +47,23 @@ diff -up ./src/Phan/Plugin/ConfigPluginSet.php.rpm ./src/Phan/Plugin/ConfigPlugi
private function ensurePluginsExist(): void
diff -up ./src/prep.php.rpm ./src/prep.php
---- ./src/prep.php.rpm 2020-05-04 10:26:34.000000000 +0200
-+++ ./src/prep.php 2020-05-04 10:28:21.581423051 +0200
+--- ./src/prep.php.rpm 2020-07-02 07:19:00.000000000 +0200
++++ ./src/prep.php 2020-07-02 07:19:12.412846692 +0200
@@ -1,3 +1,4 @@
+#!/usr/bin/env php
<?php
declare(strict_types=1);
diff -up ./src/requirements.php.rpm ./src/requirements.php
---- ./src/requirements.php.rpm 2020-05-04 10:26:34.000000000 +0200
-+++ ./src/requirements.php 2020-05-04 10:28:21.581423051 +0200
-@@ -10,10 +10,10 @@ if ((int)phpversion()[0] < 7) {
- exit(1);
- }
+--- ./src/requirements.php.rpm 2020-07-02 07:19:12.412846692 +0200
++++ ./src/requirements.php 2020-07-02 07:20:08.066622708 +0200
+@@ -2,11 +2,11 @@
+
+ declare(strict_types=1);
-if (!(file_exists(__DIR__ . '/../vendor/autoload.php') || file_exists(__DIR__ . '/../../../autoload.php'))) {
+if (!(file_exists(__DIR__ . '/autoload.php'))) {
+ // @phan-suppress-next-line PhanPluginRemoveDebugCall
fwrite(
STDERR,
- 'Autoloader not found. Make sure you run `composer install` before running Phan. See https://github.com/phan/phan#getting-started for more details.'
diff --git a/phan.spec b/phan.spec
index 2c2f315..fca13bc 100644
--- a/phan.spec
+++ b/phan.spec
@@ -10,14 +10,14 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit b15141e68e1eb954aba9e30d3875ad91af6ac951
+%global gh_commit ba01d4a56fcb2019d79dc7ce63dc0151d1cc41f7
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner phan
#global gh_date 20150820
%global gh_project phan
%global psr0 Phan
-%global with_tests 0%{!?_without_tests:1}
-%global upstream_version 3.0.3
+%bcond_without tests
+%global upstream_version 3.0.4
#global upstream_prever RC2
Name: %{gh_project}
@@ -34,7 +34,7 @@ Source1: makesrc.sh
Patch0: %{name}-autoload.patch
BuildArch: noarch
-%if %{with_tests}
+%if %{with tests}
BuildRequires: php(language) >= 7.2
BuildRequires: php-ast >= 1.0.6
# remirepo:1
@@ -220,7 +220,7 @@ install -Dpm 755 phan_client %{buildroot}%{_bindir}/phan-client
%check
-%if %{with_tests}
+%if %{with tests}
cat << 'EOF' | tee tests/autoload.php
<?php
require '%{buildroot}%{_datadir}/php/%{psr0}/Phan/Bootstrap.php';
@@ -249,6 +249,9 @@ EOF
%changelog
+* Thu Jul 2 2020 Remi Collet <remi@remirepo.net> - 3.0.4-1
+- update to 3.0.4
+
* Mon Jun 22 2020 Remi Collet <remi@remirepo.net> - 3.0.3-1
- update to 3.0.3