summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2010-08-15 20:43:34 +0200
committerRemi Collet <fedora@famillecollet.com>2010-08-15 20:43:34 +0200
commit29c77d76c3a8854d4ab8d0e746067f166599c13f (patch)
tree7a22cdba554ebcaa9d3dbb6a12ccf72c1e2f9b05
rename
-rw-r--r--Makefile4
-rw-r--r--perl-FusionInventory-Agent-Task-SNMPQuery.spec70
2 files changed, 74 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..1e65467
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../common/Makefile
+
diff --git a/perl-FusionInventory-Agent-Task-SNMPQuery.spec b/perl-FusionInventory-Agent-Task-SNMPQuery.spec
new file mode 100644
index 0000000..5e478af
--- /dev/null
+++ b/perl-FusionInventory-Agent-Task-SNMPQuery.spec
@@ -0,0 +1,70 @@
+Name: perl-FusionInventory-Agent-Task-SNMPQuery
+Version: 1.1
+Release: 1%{?dist}
+Summary: SNMP Query support for FusionInventory Agent
+License: GPLv2+
+Group: Development/Libraries
+
+URL: http://forge.fusioninventory.org/projects/fusioninventory-agent-task-snmpquery
+Source0: http://forge.fusioninventory.org/attachments/download/35/FusionInventory-Agent-Task-SNMPQuery-1.1.tar.gz
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildArch: noarch
+
+BuildRequires: perl(ExtUtils::MakeMaker) perl(Module::Install)
+# For tests
+BuildRequires: perl(FusionInventory::Agent) >= 2.0
+BuildRequires: perl(Test::More)
+
+Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
+Requires: perl(FusionInventory::Agent) >= 2.0
+# Optional (but recommended) dependencies
+Requires: perl(Parallel::ForkManager)
+Requires: perl(Net::SNMP)
+
+%{?perl_default_filter}
+
+
+%description
+SNMP Query support for FusionInventory Agent
+
+
+%prep
+%setup -q -n FusionInventory-Agent-Task-SNMPQuery-%{version}
+
+
+%build
+%{__perl} Makefile.PL INSTALLDIRS=vendor
+make %{?_smp_mflags}
+
+
+%install
+rm -rf $RPM_BUILD_ROOT
+
+make pure_install DESTDIR=$RPM_BUILD_ROOT
+
+find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} \;
+find $RPM_BUILD_ROOT -depth -type d -exec rmdir {} 2>/dev/null \;
+
+%{_fixperms} $RPM_BUILD_ROOT/*
+
+
+%check
+make test
+
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+
+%files
+%defattr(-,root,root,-)
+%doc AUTHORS Changes LICENSE README THANKS
+%{perl_vendorlib}/FusionInventory/Agent/Task/SNMPQuery*
+
+
+%changelog
+* Tue May 18 2010 http://blog.famillecollet.com 1.1-1
+- Specfile autogenerated by cpanspec 1.78.
+- spec cleanup
+