summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-05-30 17:32:44 +0200
committerRemi Collet <fedora@famillecollet.com>2012-05-30 17:32:44 +0200
commit539443449ae0cd58864836b4a0cd6401b9d7a743 (patch)
tree573c0a33b169ad4a11ad6c71547733d0a66a9732
parent25cedbef221167fb849c80638957466f2a191f0e (diff)
perl-FusionInventory-Agent-Task-Deploy: fix BuildRequires/Requires from review #812587HEADmaster
-rw-r--r--perl-FusionInventory-Agent-Task-Deploy.spec27
1 files changed, 22 insertions, 5 deletions
diff --git a/perl-FusionInventory-Agent-Task-Deploy.spec b/perl-FusionInventory-Agent-Task-Deploy.spec
index 1de2d82..6c2d372 100644
--- a/perl-FusionInventory-Agent-Task-Deploy.spec
+++ b/perl-FusionInventory-Agent-Task-Deploy.spec
@@ -1,6 +1,6 @@
Name: perl-FusionInventory-Agent-Task-Deploy
Version: 2.0.0
-Release: 2%{?dist}
+Release: 3%{?dist}
Summary: Software deployment support for FusionInventory Agent
License: GPLv2+
Group: Development/Libraries
@@ -10,24 +10,38 @@ Source0: http://search.cpan.org/CPAN/authors/id/F/FU/FUSINV/FusionInvento
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
BuildRequires: perl >= 1:5.8.0
+BuildRequires: perl(base)
BuildRequires: perl(inc::Module::Install)
BuildRequires: perl(Archive::Extract)
BuildRequires: perl(Archive::Tar)
+BuildRequires: perl(Compress::Zlib)
+BuildRequires: perl(Cwd)
+BuildRequires: perl(Data::Dumper)
BuildRequires: perl(Digest::SHA)
+BuildRequires: perl(Exporter)
BuildRequires: perl(File::Copy::Recursive)
+BuildRequires: perl(File::Path)
+BuildRequires: perl(File::Spec)
+BuildRequires: perl(File::Which)
+BuildRequires: perl(HTTP::Request)
+BuildRequires: perl(HTTP::Request::Common)
+BuildRequires: perl(HTTP::Server::Simple::CGI)
BuildRequires: perl(JSON)
+BuildRequires: perl(LWP)
+BuildRequires: perl(Net::IP)
+BuildRequires: perl(POE)
BuildRequires: perl(POE::Component::Client::Ping)
+BuildRequires: perl(POE::Component::Client::TCP)
BuildRequires: perl(Test::Compile)
BuildRequires: perl(Test::HTTP::Server::Simple)
+BuildRequires: perl(Test::More)
+BuildRequires: perl(UNIVERSAL::require)
BuildRequires: perl(URI::Escape)
BuildRequires: fusioninventory-agent >= 2.2.0
-%if 0%{?fedora} >= 14
-BuildRequires: perl(HTTP::Server::Simple::Authen) perl(CGI)
-%endif
Requires: fusioninventory-agent >= 2.2.0
-Requires: perl(Digest::SHA)
Requires: perl(POE::Component::Client::Ping)
+Requires: perl(POE::Component::Client::TCP)
Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
# RPM 4.8
@@ -88,6 +102,9 @@ rm -rf %{buildroot}
%changelog
+* Wed May 30 2012 Remi Collet <remi@fedoraproject.org> - 2.0.0-3
+- fix BuildRequires/Requires from review #812587
+
* Fri May 11 2012 Remi Collet <remi@fedoraproject.org> - 2.0.0-2
- filter private provides/requires