summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-06-29 18:25:20 +0200
committerRemi Collet <fedora@famillecollet.com>2012-06-29 18:25:20 +0200
commit489240607087db067fc99a184e64d75b90ef351c (patch)
tree8f3b646fcf8307ff22328b34b00bd69d3d820e76
perl-Data-Flow: import from rawhide
-rw-r--r--Makefile4
-rw-r--r--perl-Data-Flow.spec44
2 files changed, 48 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..1e65467
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../common/Makefile
+
diff --git a/perl-Data-Flow.spec b/perl-Data-Flow.spec
new file mode 100644
index 0000000..f71cfe2
--- /dev/null
+++ b/perl-Data-Flow.spec
@@ -0,0 +1,44 @@
+Name: perl-Data-Flow
+Version: 1.02
+Release: 1%{?dist}
+Summary: Perl extension for simple-minded recipe-controlled build of data
+# Author declared license there:
+# <https://rt.cpan.org/Public/Bug/Display.html?id=18068#txn-175743>
+License: GPL+ or Artistic
+Group: Development/Libraries
+URL: http://search.cpan.org/dist/Data-Flow/
+Source0: http://www.cpan.org/authors/id/I/IL/ILYAZ/modules/Data-Flow-%{version}.tar.gz
+BuildArch: noarch
+BuildRequires: perl(ExtUtils::MakeMaker)
+# Run-time
+BuildRequires: perl(Exporter)
+BuildRequires: perl(AutoLoader)
+Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
+
+%description
+%{summary}.
+
+%prep
+%setup -q -n Data-Flow-%{version}
+
+%build
+%{__perl} Makefile.PL INSTALLDIRS=vendor
+make %{?_smp_mflags}
+
+%install
+make pure_install PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
+find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} \;
+find $RPM_BUILD_ROOT -depth -type d -exec rmdir {} 2>/dev/null \;
+%{_fixperms} $RPM_BUILD_ROOT/*
+
+%check
+make test
+
+%files
+%doc Changes
+%{perl_vendorlib}/*
+%{_mandir}/man3/*
+
+%changelog
+* Tue Jun 26 2012 Petr Pisar <ppisar@redhat.com> 1.02-1
+- Specfile autogenerated by cpanspec 1.78.