summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2017-02-04 08:57:33 +0100
committerRemi Collet <fedora@famillecollet.com>2017-02-04 08:57:33 +0100
commit80eecebe2a2a99d31f865e37a738c9e9daa80f00 (patch)
tree6a79bf2a5bfaf067a2234c5decbab5909407df1f
parent6d524694b2b348da5c636308a40a57faf5031433 (diff)
owncloud: 9.1.4 (backported from Fedora)
-rw-r--r--owncloud-9.1.4-dont_warn_about_php_versions.patch (renamed from owncloud-9.1.2-dont_warn_about_php_versions.patch)41
-rw-r--r--owncloud.spec16
2 files changed, 25 insertions, 32 deletions
diff --git a/owncloud-9.1.2-dont_warn_about_php_versions.patch b/owncloud-9.1.4-dont_warn_about_php_versions.patch
index 8788818..bef22bb 100644
--- a/owncloud-9.1.2-dont_warn_about_php_versions.patch
+++ b/owncloud-9.1.4-dont_warn_about_php_versions.patch
@@ -1,8 +1,8 @@
diff --git a/console.php b/console.php
-index 7235965..1f4b721 100644
+index 2bb3a2b..0df5343 100644
--- a/console.php
+++ b/console.php
-@@ -33,21 +33,6 @@ use Symfony\Component\Console\Output\ConsoleOutput;
+@@ -33,22 +33,6 @@ use Symfony\Component\Console\Output\ConsoleOutput;
define('OC_CONSOLE', 1);
@@ -15,29 +15,21 @@ index 7235965..1f4b721 100644
-}
-
-// Show warning if PHP 7.1 is used as ownCloud is not compatible with PHP 7.1 until
--// version 9.2.0.
+-// version 10.0.0.
-if (version_compare(PHP_VERSION, '7.1.0') !== -1) {
- echo 'This version of ownCloud is not compatible with PHP 7.1.<br/>';
-- echo 'You are currently running ' . PHP_VERSION . '. Please use at least ownCloud 9.2.0.';
+- echo 'You are currently running ' . PHP_VERSION . '. Please use at least ownCloud 10.0.0.';
- return;
-}
-
+-
function exceptionHandler($exception) {
echo "An unhandled exception has been thrown:" . PHP_EOL;
-@@ -78,7 +63,7 @@ try {
- echo "Console has to be executed with the user that owns the file config/config.php" . PHP_EOL;
- echo "Current user: " . $user['name'] . PHP_EOL;
- echo "Owner of config.php: " . $configUser['name'] . PHP_EOL;
-- echo "Try adding 'sudo -u " . $configUser['name'] . " ' to the beginning of the command (without the single quotes)" . PHP_EOL;
-+ echo "Try adding 'sudo -u " . $configUser['name'] . " ' to the beginning of the command (without the single quotes)" . PHP_EOL;
- exit(0);
- }
- }
+ echo $exception;
diff --git a/index.php b/index.php
-index 136ddcb..5230cb2 100644
+index ad33ad9..1210e4b 100644
--- a/index.php
+++ b/index.php
-@@ -24,31 +24,9 @@
+@@ -24,28 +24,6 @@
*
*/
@@ -50,10 +42,10 @@ index 136ddcb..5230cb2 100644
-}
-
-// Show warning if PHP 7.1 is used as ownCloud is not compatible with PHP 7.1 until
--// version 9.2.0.
+-// version 10.0.0.
-if (version_compare(PHP_VERSION, '7.1.0') !== -1) {
- echo 'This version of ownCloud is not compatible with PHP 7.1.<br/>';
-- echo 'You are currently running ' . PHP_VERSION . '. Please use at least ownCloud 9.2.0.';
+- echo 'You are currently running ' . PHP_VERSION . '. Please use at least ownCloud 10.0.0.';
- return;
-}
-
@@ -65,16 +57,12 @@ index 136ddcb..5230cb2 100644
-}
try {
--
-+
- require_once 'lib/base.php';
-
- OC::handleRequest();
+
diff --git a/settings/Controller/CheckSetupController.php b/settings/Controller/CheckSetupController.php
-index 52ef34d..e39fdf2 100644
+index 52ef34d..bdb2a3a 100644
--- a/settings/Controller/CheckSetupController.php
+++ b/settings/Controller/CheckSetupController.php
-@@ -349,11 +349,7 @@ Raw output
+@@ -349,11 +349,8 @@ Raw output
protected function isEndOfLive() {
$eol = false;
@@ -83,7 +71,8 @@ index 52ef34d..e39fdf2 100644
- $eol = true;
- return $eol;
- }
-+ // Red Hat support PHP so don't EOL
++ // Red Hat support PHP so don't EOL
++
return $eol;
}
}
diff --git a/owncloud.spec b/owncloud.spec
index 5d97283..a51bb49 100644
--- a/owncloud.spec
+++ b/owncloud.spec
@@ -8,8 +8,8 @@
# Please preserve changelog entries
#
Name: owncloud
-Version: 9.1.3
-Release: 2%{?dist}
+Version: 9.1.4
+Release: 1%{?dist}
Summary: Private file sync and share server
Group: Applications/Internet
@@ -62,7 +62,7 @@ Patch6: %{name}-8.2.3-correct-cli-upgrade-command.patch
Patch7: %{name}-9.1.0-default_integrity_check_disabled.patch
# No need to check PHP versions, Fedora maintainers are on the job
-Patch8: %{name}-9.1.2-dont_warn_about_php_versions.patch
+Patch8: %{name}-9.1.4-dont_warn_about_php_versions.patch
#Backport of php7.1 fixes
Patch9: %{name}-b129d5d-php71-backport.patch
@@ -108,7 +108,7 @@ BuildRequires: php-composer(pimple/pimple) < 4.0
BuildRequires: php-composer(ircmaxell/password-compat) >= 1.0.0
BuildRequires: php-composer(nikic/php-parser) >= 1.4.1
BuildRequires: php-composer(nikic/php-parser) < 2.0
-BuildRequires: php-composer(icewind/streams) >= 0.4.1
+BuildRequires: php-composer(icewind/streams) >= 0.5.2
BuildRequires: php-composer(swiftmailer/swiftmailer) >= 5.4.1
BuildRequires: php-composer(guzzlehttp/guzzle) >= 5.3.0
BuildRequires: php-composer(guzzlehttp/guzzle) < 6.0
@@ -222,8 +222,8 @@ Requires: php-composer(ircmaxell/password-compat) >= 1.0.0
Requires: php-composer(nikic/php-parser) >= 1.4.1
Requires: php-composer(nikic/php-parser) < 2.0
-# "icewind/Streams": "0.4.1"
-Requires: php-composer(icewind/streams) >= 0.4.1
+# "icewind/Streams": "0.5.2"
+Requires: php-composer(icewind/streams) >= 0.5.2
# "swiftmailer/swiftmailer": "@stable"
# Version 5.4.1 for autoloader in /usr/share/php
@@ -746,6 +746,10 @@ rm -rf %{buildroot}
%changelog
+* Fri Feb 03 2017 James Hogarth <james.hogarth@gmail.com> - 9.1.4-1
+- Update to 9.1.4
+- Fix guzzle autoloader ordering dependency issue
+
* Wed Dec 14 2016 James Hogarth <james.hogarth@gmail.com> - 9.1.3-1
- Fix bz#1404441 - php7 does not get the httpd php settings
- No need to check PHP versions within the code