summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-06-29 14:59:24 +0200
committerRemi Collet <fedora@famillecollet.com>2016-06-29 14:59:24 +0200
commit78bd1f6fd020c35b10e29965ca3124a92cefa5bc (patch)
treee95205ba2a4aad07e18327b73e9f92ba51cbc2c3
parent080867c4c5625b6eced80d1ba298846f6430cd89 (diff)
owncloud: 9.0.3
-rw-r--r--owncloud-9.0.2-core-23066-infinite-loop-share-link.patch79
-rw-r--r--owncloud-9.0.2-no_need_for_broken_updater_repair.patch12
-rw-r--r--owncloud-9.0.3-dropbox-autoloader.patch (renamed from owncloud-9.0.1-dropbox-autoloader.patch)4
-rw-r--r--owncloud.spec17
4 files changed, 8 insertions, 104 deletions
diff --git a/owncloud-9.0.2-core-23066-infinite-loop-share-link.patch b/owncloud-9.0.2-core-23066-infinite-loop-share-link.patch
deleted file mode 100644
index 28b39e9..0000000
--- a/owncloud-9.0.2-core-23066-infinite-loop-share-link.patch
+++ /dev/null
@@ -1,79 +0,0 @@
-diff --git a/apps/dav/lib/connector/publicauth.php b/apps/dav/lib/connector/publicauth.php
-index f069a21..36da649 100644
---- a/apps/dav/lib/connector/publicauth.php
-+++ b/apps/dav/lib/connector/publicauth.php
-@@ -89,7 +89,7 @@ class PublicAuth extends \Sabre\DAV\Auth\Backend\AbstractBasic {
- }
- return true;
- } else if (\OC::$server->getSession()->exists('public_link_authenticated')
-- && \OC::$server->getSession()->get('public_link_authenticated') === $linkItem['id']) {
-+ && \OC::$server->getSession()->get('public_link_authenticated') === (string)$linkItem['id']) {
- return true;
- } else {
- return false;
-diff --git a/apps/files_sharing/lib/helper.php b/apps/files_sharing/lib/helper.php
-index e857974..3dfbf8f 100644
---- a/apps/files_sharing/lib/helper.php
-+++ b/apps/files_sharing/lib/helper.php
-@@ -131,7 +131,7 @@ class Helper {
- $newHash = '';
- if(\OC::$server->getHasher()->verify($password, $linkItem['share_with'], $newHash)) {
- // Save item id in session for future requests
-- \OC::$server->getSession()->set('public_link_authenticated', $linkItem['id']);
-+ \OC::$server->getSession()->set('public_link_authenticated', (string)$linkItem['id']);
-
- /**
- * FIXME: Migrate old hashes to new hash format
-@@ -161,7 +161,7 @@ class Helper {
- else {
- // not authenticated ?
- if ( ! \OC::$server->getSession()->exists('public_link_authenticated')
-- || \OC::$server->getSession()->get('public_link_authenticated') !== $linkItem['id']) {
-+ || \OC::$server->getSession()->get('public_link_authenticated') !== (string)$linkItem['id']) {
- return false;
- }
- }
-diff --git a/apps/gallery/middleware/envcheckmiddleware.php b/apps/gallery/middleware/envcheckmiddleware.php
-index 8364e52..086da2f 100644
---- a/apps/gallery/middleware/envcheckmiddleware.php
-+++ b/apps/gallery/middleware/envcheckmiddleware.php
-@@ -274,7 +274,7 @@ class EnvCheckMiddleware extends CheckMiddleware {
- $newHash = '';
- if ($this->hasher->verify($password, $linkItem['share_with'], $newHash)) {
- // Save item id in session for future requests
-- $this->session->set('public_link_authenticated', $linkItem['id']);
-+ $this->session->set('public_link_authenticated', (string)$linkItem['id']);
- // @codeCoverageIgnoreStart
- if (!empty($newHash)) {
- // For future use
-@@ -296,7 +296,7 @@ class EnvCheckMiddleware extends CheckMiddleware {
- private function checkSession($linkItem) {
- // Not authenticated ?
- if (!$this->session->exists('public_link_authenticated')
-- || $this->session->get('public_link_authenticated') !== $linkItem['id']
-+ || $this->session->get('public_link_authenticated') !== (string)$linkItem['id']
- ) {
- throw new CheckException("Missing password", Http::STATUS_UNAUTHORIZED);
- }
-diff --git a/lib/private/share/share.php b/lib/private/share/share.php
-index 3dcfa14..fcd013c 100644
---- a/lib/private/share/share.php
-+++ b/lib/private/share/share.php
-@@ -2477,7 +2477,7 @@ class Share extends Constants {
- }
-
- if ( \OC::$server->getSession()->exists('public_link_authenticated')
-- && \OC::$server->getSession()->get('public_link_authenticated') === $linkItem['id'] ) {
-+ && \OC::$server->getSession()->get('public_link_authenticated') === (string)$linkItem['id'] ) {
- return true;
- }
-
-@@ -2767,7 +2767,7 @@ class Share extends Constants {
-
- /**
- * @param IConfig $config
-- * @return bool
-+ * @return bool
- */
- public static function enforcePassword(IConfig $config) {
- $enforcePassword = $config->getAppValue('core', 'shareapi_enforce_links_password', 'no');
diff --git a/owncloud-9.0.2-no_need_for_broken_updater_repair.patch b/owncloud-9.0.2-no_need_for_broken_updater_repair.patch
deleted file mode 100644
index 9661d1c..0000000
--- a/owncloud-9.0.2-no_need_for_broken_updater_repair.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/lib/private/repair.php b/lib/private/repair.php
-index 63b569b..d8e213a 100644
---- a/lib/private/repair.php
-+++ b/lib/private/repair.php
-@@ -115,7 +115,6 @@ class Repair extends BasicEmitter {
- new RemoveGetETagEntries(\OC::$server->getDatabaseConnection()),
- new UpdateOutdatedOcsIds(\OC::$server->getConfig()),
- new RepairInvalidShares(\OC::$server->getConfig(), \OC::$server->getDatabaseConnection()),
-- new BrokenUpdaterRepair(),
- ];
- }
-
diff --git a/owncloud-9.0.1-dropbox-autoloader.patch b/owncloud-9.0.3-dropbox-autoloader.patch
index 8b94444..5789db2 100644
--- a/owncloud-9.0.1-dropbox-autoloader.patch
+++ b/owncloud-9.0.3-dropbox-autoloader.patch
@@ -14,9 +14,9 @@ diff --git a/apps/files_external/lib/dropbox.php b/apps/files_external/lib/dropb
index 8381ccb..174baec 100644
--- a/apps/files_external/lib/dropbox.php
+++ b/apps/files_external/lib/dropbox.php
-@@ -33,8 +33,6 @@ use GuzzleHttp\Exception\RequestException;
- use Icewind\Streams\IteratorDirectory;
+@@ -34,8 +34,6 @@ use Icewind\Streams\IteratorDirectory;
use Icewind\Streams\RetryWrapper;
+ use OCP\Files\StorageNotAvailableException;
-require_once __DIR__ . '/../3rdparty/Dropbox/autoload.php';
-
diff --git a/owncloud.spec b/owncloud.spec
index ec22dca..71e9717 100644
--- a/owncloud.spec
+++ b/owncloud.spec
@@ -8,8 +8,8 @@
# Please preserve changelog entries
#
Name: owncloud
-Version: 9.0.2
-Release: 4%{?dist}
+Version: 9.0.3
+Release: 1%{?dist}
Summary: Private file sync and share server
Group: Applications/Internet
@@ -47,7 +47,7 @@ Source8: %{name}-fedora-autoloader.php
Patch2: %{name}-9.0.1-dont_update_htacess.patch
# Remove explicit load of dropbox
-Patch3: %{name}-9.0.1-dropbox-autoloader.patch
+Patch3: %{name}-9.0.3-dropbox-autoloader.patch
# Remove explicit load of google
Patch4: %{name}-9.0.1-google-autoloader.patch
@@ -58,15 +58,9 @@ Patch5: %{name}-8.2.3-amazon-autoloader.patch
# Display the appropriate upgrade command for fedora/epel users bz#1321417
Patch6: %{name}-8.2.3-correct-cli-upgrade-command.patch
-# The broken updater repair step gets upset we unbundle
-Patch7: %{name}-9.0.2-no_need_for_broken_updater_repair.patch
-
# Disable the integrity checking whilst a better way to deal with it is found
Patch8: %{name}-9.0.2-default_integrity_check_disabled.patch
-# Backport patch from future 9.0.3 to handle broken shared link issue bz#1346233
-Patch9: %{name}-9.0.2-core-23066-infinite-loop-share-link.patch
-
# Need to work around an NSS issue in el7.2, due to be fix el7.3 bz#1241172
Patch10: %{name}-8.1.6-work-arround-nss-issue.patch
@@ -429,9 +423,7 @@ work with an SQLite 3 database stored on the local system.
%patch4 -p1
%patch5 -p1
%patch6 -p1
-%patch7 -p1
%patch8 -p1
-%patch9 -p1
%if 0%{?rhel}
%patch10 -p1
%patch11 -p1
@@ -746,6 +738,9 @@ rm -rf %{buildroot}
%changelog
+* Wed Jun 29 2016 Remi Collet <remi@fedoraproject.org> - 9.0.3-1
+- Update to 9.0.3
+
* Tue Jun 14 2016 James Hogarth <james.hogarth@gmail.com> - 9.0.2-4
- Fix an infinite loop on a shared link with password and postgres bz#1346233