summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-06-01 17:42:23 +0200
committerRemi Collet <fedora@famillecollet.com>2016-06-01 17:42:23 +0200
commit47102d03ab8ef1137a01de831f4e304a0d31117a (patch)
tree39fbde4e37cd789ca12268bed622beea7da46c70
parentf1fa70fa218396f039f14d1e3f6783e322c51158 (diff)
owncloud: more cleanup
-rw-r--r--owncloud.spec6
1 files changed, 5 insertions, 1 deletions
diff --git a/owncloud.spec b/owncloud.spec
index 350652b..bd88af0 100644
--- a/owncloud.spec
+++ b/owncloud.spec
@@ -433,6 +433,9 @@ work with an SQLite 3 database stored on the local system.
%patch10 -p1
%endif
+# patch backup files
+find . -name \*.orig -type f -exec rm {} \;
+
# prepare package doc
cp %{SOURCE3} README.fedora
cp %{SOURCE4} README.mysql
@@ -512,6 +515,7 @@ EOF
# remove gallery external bundled libraries
rm -r apps/gallery/vendor/{symfony,composer*}
+rm apps/gallery/composer.lock
# create autoloader, from composer.json, "require": {
# "symfony/yaml": "_2.6"
@@ -565,7 +569,7 @@ fi
php %{buildroot}%{_datadir}/%{name}/3rdparty/autoload.php
# There should not be an composer.json files remaining
-nb=$(find -name "composer.json" | wc -l)
+nb=$(find -name 'composer.*'| wc -l)
if [ $nb -gt 0 ]
then
false found unexpected composer.json files