summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-07-17 09:19:21 +0200
committerRemi Collet <fedora@famillecollet.com>2014-07-17 09:19:21 +0200
commita6c4e4c455046e8f291a04453983103a7774a722 (patch)
tree4c774201a30d9f49cd6b6c10117018039ccfeec3
php-ocramius-instantiator: 1.0.0 - New Package
-rw-r--r--Makefile4
-rw-r--r--php-ocramius-instantiator.spec99
2 files changed, 103 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..91b0fd5
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../common/Makefile
+
diff --git a/php-ocramius-instantiator.spec b/php-ocramius-instantiator.spec
new file mode 100644
index 0000000..3d603ef
--- /dev/null
+++ b/php-ocramius-instantiator.spec
@@ -0,0 +1,99 @@
+# spec file for php-ocramius-instantiator
+#
+# Copyright (c) 2014 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/3.0/
+#
+# Please, preserve the changelog entries
+#
+%global gh_commit cc754c2289ffd4483c319f6ed6ee88ce21676f64
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_owner Ocramius
+%global gh_project Instantiator
+%global with_tests %{?_without_tests:0}%{!?_without_tests:1}
+
+Name: php-ocramius-instantiator
+Version: 1.0.0
+Release: 1%{?dist}
+Summary: Instantiate objects in PHP without invoking their constructors
+
+Group: Development/Libraries
+# https://github.com/Ocramius/Instantiator/issues/9
+# License is missing but included in each file (headers)
+License: MIT
+URL: https://github.com/%{gh_owner}/%{gh_project}
+Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}.tar.gz
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildArch: noarch
+BuildRequires: php(language) >= 5.3.3
+BuildRequires: php-phpunit-PHPUnit
+BuildRequires: php-theseer-autoload
+BuildRequires: php-composer(ocramius/lazy-map) >= 1.0.0
+BuildRequires: php-composer(ocramius/lazy-map) < 1.1
+
+# From composer.json
+# "php": ">=5.3.3"
+# "ocramius/lazy-map": "1.0.*"
+Requires: php(language) >= 5.3.3
+Requires: php-composer(ocramius/lazy-map) >= 1.0.0
+Requires: php-composer(ocramius/lazy-map) < 1.1
+# From phpcompatinfo report for version 1.0.0
+Requires: php-reflection
+
+Provides: php-composer(ocramius/instantiator) = %{version}
+
+
+%description
+This library provides a way of avoiding usage of constructors when
+instantiating PHP classes.
+
+
+%prep
+%setup -q -n %{gh_project}-%{gh_commit}
+
+
+%build
+# Nothing
+
+
+%install
+rm -rf %{buildroot}
+mkdir -p %{buildroot}%{_datadir}/php
+cp -pr src/* %{buildroot}%{_datadir}/php
+
+
+%check
+%if %{with_tests}
+: Generate autoloader
+phpab \
+ --basedir $PWD \
+ --output autoload.php \
+ src tests %{_datadir}/php/LazyMap
+
+: Disabled known to fail tests
+sed -e '/Phar/d' \
+ -i tests/InstantiatorTest/InstantiatorTest.php
+
+: Run test suite
+phpunit \
+ --bootstrap autoload.php \
+ -d date.timezone=UTC
+%else
+: Test suite disabled
+%endif
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%files
+%defattr(-,root,root,-)
+%doc *.md
+%{_datadir}/php/Instantiator/
+
+
+%changelog
+* Thu Jul 17 2014 Remi Collet <remi@fedoraproject.org> - 1.0.0-1
+- initial package \ No newline at end of file