summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--my.cnf13
-rw-r--r--mysql.init2
-rw-r--r--mysql.sysconfig11
-rw-r--r--mysql55.spec20
4 files changed, 31 insertions, 15 deletions
diff --git a/my.cnf b/my.cnf
index d8fe399..5f815ea 100644
--- a/my.cnf
+++ b/my.cnf
@@ -5,15 +5,12 @@ user=mysql
# Disabling symbolic-links is recommended to prevent assorted security risks
symbolic-links=0
-# Additional storage engines and plugins
-plugin-load=archive=ha_archive.so;blackhole=ha_blackhole.so
-
-# Add to the above plugin-load option, if needed
-# http://dev.mysql.com/doc/refman/5.5/en/federated-storage-engine.html
-;federated=ha_federated.so
+# Semisynchronous Replication
# http://dev.mysql.com/doc/refman/5.5/en/replication-semisync.html
-;rpl_semi_sync_master=semisync_master.so
-;rpl_semi_sync_slave=semisync_slave.so
+# uncomment next line on MASTER
+;plugin-load=rpl_semi_sync_master=semisync_master.so
+# uncomment next line on SLAVE
+;plugin-load=rpl_semi_sync_slave=semisync_slave.so
# Others options for Semisynchronous Replication
;rpl_semi_sync_master_enabled=1
diff --git a/mysql.init b/mysql.init
index b405fbd..237e5f9 100644
--- a/mysql.init
+++ b/mysql.init
@@ -22,6 +22,7 @@ prog="mysqld"
# Set timeouts here so they can be overridden from /etc/sysconfig/mysqld
STARTTIMEOUT=120
STOPTIMEOUT=60
+MYOPTIONS=
[ -e /etc/sysconfig/$prog ] && . /etc/sysconfig/$prog
@@ -102,6 +103,7 @@ start(){
# alarms, per bug #547485
$exec --datadir="$datadir" --socket="$socketfile" \
--pid-file="$mypidfile" \
+ $MYOPTIONS \
--basedir=/usr --user=mysql >/dev/null 2>&1 &
safe_pid=$!
# Spin for a maximum of N seconds waiting for the server to come up;
diff --git a/mysql.sysconfig b/mysql.sysconfig
new file mode 100644
index 0000000..db9a809
--- /dev/null
+++ b/mysql.sysconfig
@@ -0,0 +1,11 @@
+# Configuration file for the mysqld service.
+
+# Server timeout during service start
+STARTTIMEOUT=120
+
+# Server timeout during service stop
+STOPTIMEOUT=60
+
+# Other options to pass to the server (p.e. --federated)
+MYOPTIONS=
+
diff --git a/mysql55.spec b/mysql55.spec
index babc1a0..19cef5b 100644
--- a/mysql55.spec
+++ b/mysql55.spec
@@ -1,5 +1,5 @@
Name: mysql
-Version: 5.5.9
+Version: 5.5.10
Release: 1%{?dist}
Summary: MySQL client programs and shared libraries
Group: Applications/Databases
@@ -20,6 +20,7 @@ Source0: mysql-%{version}.tar.gz
# the tarball into the current directory:
# ./generate-tarball.sh $VERSION
# Source1: generate-tarball.sh not used for remi repo
+Source1: mysql.sysconfig
Source2: mysql.init
Source3: my.cnf
Source4: scriptstub.c
@@ -183,11 +184,6 @@ the MySQL sources.
# Can't provide this file (by licence)
rm -f Docs/mysql.info
-# change libmysqlclient.so soname to 161
-# to allow install with libmysqlclient16 (from 5.1.x branch)
-# and solves broken dependencies
-sed -i -e '/SHARED_LIB_MAJOR_VERSION/s/16/161/' cmake/mysql_version.cmake
-
%patch1 -p1
%patch2 -p1
@@ -375,7 +371,9 @@ touch $RPM_BUILD_ROOT/var/log/mysqld.log
mkdir -p $RPM_BUILD_ROOT/etc/rc.d/init.d
mkdir -p $RPM_BUILD_ROOT/var/run/mysqld
+mkdir -p $RPM_BUILD_ROOT/etc/sysconfig
install -m 0755 -d $RPM_BUILD_ROOT/var/lib/mysql
+install -m 0644 %{SOURCE1} $RPM_BUILD_ROOT/etc/sysconfig/mysqld
install -m 0755 %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/mysqld
install -m 0644 %{SOURCE3} $RPM_BUILD_ROOT/etc/my.cnf
@@ -527,7 +525,7 @@ fi
# libs package because it can be used for client settings too.
%config(noreplace) /etc/my.cnf
%dir %{_libdir}/mysql
-%{_libdir}/mysql/libmysqlclient.so.*
+%{_libdir}/mysql/libmysqlclient.so.18.*
/etc/ld.so.conf.d/*
%dir %{_datadir}/mysql
@@ -633,6 +631,7 @@ fi
%attr(0755,mysql,mysql) %dir /var/run/mysqld
%attr(0755,mysql,mysql) %dir /var/lib/mysql
%attr(0640,mysql,mysql) %config(noreplace) %verify(not md5 size mtime) /var/log/mysqld.log
+%config(noreplace) /etc/sysconfig/mysqld
%files devel
%defattr(-,root,root)
@@ -667,6 +666,13 @@ fi
%{_mandir}/man1/mysql_client_test.1*
%changelog
+* Tue Mar 15 2011 Remi Collet <RPMS@FamilleCollet.com> - 5.5.10-1
+- update to MySQL 5.5.10 Community Server GA
+ http://dev.mysql.com/doc/refman/5.5/en/news-5-5-10.html
+- provides /etc/sysconfig/mysqld
+- fix default my.cnf
+- client ABI bump to .18 by upstream
+
* Mon Feb 07 2011 Remi Collet <RPMS@FamilleCollet.com> - 5.5.9-1
- sync with rawhide (latest patches for 5.5.8)
- update to MySQL 5.5.9 Community Server GA