summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--mysql-innodbwarn.patch20
-rw-r--r--mysql55.spec28
2 files changed, 42 insertions, 6 deletions
diff --git a/mysql-innodbwarn.patch b/mysql-innodbwarn.patch
new file mode 100644
index 0000000..c513442
--- /dev/null
+++ b/mysql-innodbwarn.patch
@@ -0,0 +1,20 @@
+Test case rpl.rpl_daedlock_innodb fails when dropping tables because some
+warnings are generated in the slave server. The test is working fine when
+running alone, but fails when all tests are running, so it seems not to be
+so bad thing to ignore that warnings.
+
+http://bugs.mysql.com/bug.php?id=69458
+
+diff -up mysql-5.5.32/mysql-test/include/mtr_warnings.sql.innodbwarn mysql-5.5.32/mysql-test/include/mtr_warnings.sql
+--- mysql-5.5.32/mysql-test/include/mtr_warnings.sql.innodbwarn 2013-06-13 16:45:27.723525133 +0200
++++ mysql-5.5.32/mysql-test/include/mtr_warnings.sql 2013-06-13 16:46:24.879524133 +0200
+@@ -162,6 +162,9 @@ INSERT INTO global_suppressions VALUES
+ ("InnoDB: Error: in RENAME TABLE table `test`.`t1`"),
+ ("InnoDB: Error: table `test`.`t[123]` does not exist in the InnoDB internal"),
+
++ /* rpl.rpl_deadlock_innodb fails when trying DROP tables */
++ ("InnoDB: Error: table `mysqld.2`.`#sql.*` does not exist in the InnoDB internal"),
++
+ /*
+ BUG#32080 - Excessive warnings on Solaris: setrlimit could not
+ change the size of core files
diff --git a/mysql55.spec b/mysql55.spec
index bb34c4e..59d9121 100644
--- a/mysql55.spec
+++ b/mysql55.spec
@@ -18,7 +18,9 @@ Group: Applications/Databases
URL: http://www.mysql.com
# exceptions allow client libraries to be linked with most open source SW,
# not only GPL code. See README.mysql-license
-License: GPLv2 with exceptions
+# Some innobase code from Percona and Google is under BSD license
+# Some code related to test-suite is under LGPLv2
+License: GPLv2 with exceptions and LGPLv2 and BSD
# Regression tests take a long time, you can skip 'em with this
%{!?runselftest:%global runselftest 1}
@@ -70,8 +72,9 @@ Patch18: mysql-cipherspec.patch
Patch19: mysql-file-contents.patch
Patch20: mysql-string-overflow.patch
Patch21: mysql-dh1024.patch
+Patch22: mysql-innodbwarn.patch
# http://bugs.mysql.com/68999
-Patch22: mysql-openssl.patch
+Patch23: mysql-openssl.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildRequires: gperf
@@ -274,6 +277,7 @@ rm -f Docs/mysql.info
%patch20 -p1
%patch21 -p1
%patch22 -p1
+%patch23 -p1
# workaround for upstream bug #56342
rm -f mysql-test/t/ssl_8k_key-master.opt
@@ -370,7 +374,7 @@ cd ../..
%if %runselftest
# hack to let 32- and 64-bit tests run concurrently on same build machine
case `uname -m` in
- ppc64 | s390x | x86_64 | sparc64 )
+ ppc64 | ppc64p7 | s390x | x86_64 | sparc64 )
MTR_BUILD_THREAD=7
;;
*)
@@ -383,7 +387,7 @@ cd ../..
LD_LIBRARY_PATH=$PWD/libservices
export LD_LIBRARY_PATH
- make test
+ make test VERBOSE=1
# The cmake build scripts don't provide any simple way to control the
# options for mysql-test-run, so ignore the make target and just call it
@@ -416,7 +420,7 @@ find $RPM_BUILD_ROOT -print | sed "s|^$RPM_BUILD_ROOT||" | sort > ROOTFILES
# multilib header hacks
# we only apply this to known Red Hat multilib arches, per bug #181335
case `uname -i` in
- i386 | x86_64 | ppc | ppc64 | s390 | s390x | sparc | sparc64 )
+ i386 | x86_64 | ppc | ppc64 | ppc64p7 | s390 | s390x | sparc | sparc64 )
mv $RPM_BUILD_ROOT/usr/include/mysql/my_config.h $RPM_BUILD_ROOT/usr/include/mysql/my_config_`uname -i`.h
install -m 644 %{SOURCE5} $RPM_BUILD_ROOT/usr/include/mysql/
;;
@@ -509,7 +513,6 @@ rm -f ${RPM_BUILD_ROOT}/usr/INSTALL-BINARY
rm -f ${RPM_BUILD_ROOT}/usr/docs/ChangeLog
rm -f ${RPM_BUILD_ROOT}/usr/data/mysql/.empty
rm -f ${RPM_BUILD_ROOT}/usr/data/test/.empty
-rm -f ${RPM_BUILD_ROOT}%{_datadir}/mysql/solaris/*
# should move this to /etc/ ?
rm -f ${RPM_BUILD_ROOT}%{_bindir}/mysqlaccess.conf
rm -f ${RPM_BUILD_ROOT}%{_bindir}/mysql_embedded
@@ -538,6 +541,9 @@ cp %{SOURCE7} README.mysql-license
# install the list of skipped tests to be available for user runs
install -m 0644 mysql-test/rh-skipped-tests.list ${RPM_BUILD_ROOT}%{_datadir}/mysql-test
+# we don't care about scripts for solaris
+rm -f ${RPM_BUILD_ROOT}%{_datadir}/mysql/solaris/postinstall-solaris
+
%clean
rm -rf $RPM_BUILD_ROOT
@@ -834,10 +840,20 @@ fi
%{_mandir}/man1/mysql_client_test.1*
%changelog
+* Fri Jun 14 2013 Honza Horak <hhorak@redhat.com> 5.5.32-1
+- Use man pages from 5.5.30, because their license do not
+ allow us to ship them since 5.5.31
+- Update to MySQL 5.5.32, for various fixes described at
+ http://dev.mysql.com/doc/relnotes/mysql/5.5/en/news-5-5-32.html
+
* Tue Jun 4 2013 Remi Collet <RPMS@FamilleCollet.com> - 5.5.32-1
- update to MySQL 5.5.32 Community Server GA
http://dev.mysql.com/doc/relnotes/mysql/5.5/en/news-5-5-32.html
+* Fri Apr 19 2013 Honza Horak <hhorak@redhat.com> 5.5.31-1
+- Update to MySQL 5.5.31, for various fixes described at
+ http://dev.mysql.com/doc/relnotes/mysql/5.5/en/news-5-5-31.html
+
* Thu Feb 29 2013 Remi Collet <RPMS@FamilleCollet.com> - 5.5.31-1
- update to MySQL 5.5.31 Community Server GA
http://dev.mysql.com/doc/relnotes/mysql/5.5/en/news-5-5-31.html