summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2011-05-31 18:04:52 +0200
committerRemi Collet <fedora@famillecollet.com>2011-05-31 18:04:52 +0200
commite101711a96d0dfee6d458a077d9462afde0ba527 (patch)
treebcefc9a04e4c0d346f0aad0ae40a1c52ffd12b48
parent770610310272f771215928aad63da56b2044498d (diff)
mysql: sync with f15
-rw-r--r--mysql-disable-test.patch15
-rw-r--r--mysql.init23
-rw-r--r--mysql55.spec23
3 files changed, 43 insertions, 18 deletions
diff --git a/mysql-disable-test.patch b/mysql-disable-test.patch
index 48020b8..cc80d2f 100644
--- a/mysql-disable-test.patch
+++ b/mysql-disable-test.patch
@@ -12,25 +12,20 @@ Also disable perfschema.binlog_mix and perfschema.binlog_row, which have
expected output that doesn't match when openssl is in use. Upstream at
http://bugs.mysql.com/bug.php?id=59091
-Also disable gis, which expects the results of floating-point calculations
-to match to seventeen digits precision everywhere. Of course they won't.
-Upstream at http://bugs.mysql.com/bug.php?id=59908
-
Also disable innodb.innodb, which is showing platform-dependent results
as of 5.5.9. Upstream at http://bugs.mysql.com/bug.php?id=60155
-diff -Naur mysql-5.5.9.orig/mysql-test/t/disabled.def mysql-5.5.9/mysql-test/t/disabled.def
---- mysql-5.5.9.orig/mysql-test/t/disabled.def 2011-01-19 17:37:09.000000000 -0500
-+++ mysql-5.5.9/mysql-test/t/disabled.def 2011-02-16 23:19:34.844378338 -0500
-@@ -18,3 +18,10 @@
- sum_distinct-big : Bug#56927 2010-11-15 mattiasj was not tested
+diff -Naur mysql-5.5.12.orig/mysql-test/t/disabled.def mysql-5.5.12/mysql-test/t/disabled.def
+--- mysql-5.5.12.orig/mysql-test/t/disabled.def 2011-04-11 06:44:01.000000000 -0400
++++ mysql-5.5.12/mysql-test/t/disabled.def 2011-05-10 18:42:11.742438341 -0400
+@@ -17,3 +17,9 @@
alter_table-big : Bug#37248 2010-11-15 mattiasj was not tested
create-big : Bug#37248 2010-11-15 mattiasj was not tested
+ archive-big : Bug#11817185 2011-03-10 Anitha Disabled since this leads to timeout on Solaris Sparc
+#
+outfile_loaddata : bug#46895 code wrong, expected results wrong too
+sys_vars.plugin_dir_basic : bug#52223 fails for lib64 library directory
+perfschema.binlog_mix : bug#59091 fails with openssl
+perfschema.binlog_row : bug#59091 fails with openssl
-+gis : bug#59908 has platform-dependent results
+innodb.innodb : bug#60155 has platform-dependent results
diff --git a/mysql.init b/mysql.init
index e9daedc..99c3c61 100644
--- a/mysql.init
+++ b/mysql.init
@@ -8,6 +8,15 @@
# processname: mysqld
# config: /etc/my.cnf
# pidfile: /var/run/mysqld/mysqld.pid
+### BEGIN INIT INFO
+# Provides: mysqld
+# Required-Start: $local_fs $remote_fs $network $named $syslog $time
+# Required-Stop: $local_fs $remote_fs $network $named $syslog $time
+# Default-Start: 2 3 4 5
+# Default-Stop: 0 1 6
+# Short-Description: start and stop MySQL server
+# Description: MySQL database server
+### END INIT INFO
# Source function library.
. /etc/rc.d/init.d/functions
@@ -113,7 +122,19 @@ start(){
ret=0
TIMEOUT="$STARTTIMEOUT"
while [ $TIMEOUT -gt 0 ]; do
- RESPONSE=`/usr/bin/mysqladmin --socket="$socketfile" --user=UNKNOWN_MYSQL_USER ping 2>&1` && break
+ RESPONSE=`/usr/bin/mysqladmin --socket="$socketfile" --user=UNKNOWN_MYSQL_USER ping 2>&1`
+ mret=$?
+ if [ $mret -eq 0 ]; then
+ break
+ fi
+ # exit codes 1, 11 (EXIT_CANNOT_CONNECT_TO_SERVICE) are expected,
+ # anything else suggests a configuration error
+ if [ $mret -ne 1 -a $mret -ne 11 ]; then
+ echo "$RESPONSE"
+ echo "Cannot check for MySQL Daemon startup because of mysqladmin failure."
+ ret=1
+ break
+ fi
echo "$RESPONSE" | grep -q "Access denied for user" && break
if ! /bin/kill -0 $safe_pid 2>/dev/null; then
echo "MySQL Daemon failed to start."
diff --git a/mysql55.spec b/mysql55.spec
index 84e029c..e2789e0 100644
--- a/mysql55.spec
+++ b/mysql55.spec
@@ -43,9 +43,8 @@ Patch7: mysql-versioning.patch
Patch8: mysql-dubious-exports.patch
# Patch9: mysql-disable-test.patch
Patch10: mysql-embedded-crash.patch
-# Patch11: mysql-home.patch
-Patch12: mysql-plugin-bool.patch
-Patch13: mysql-s390-tsc.patch
+Patch11: mysql-plugin-bool.patch
+Patch12: mysql-s390-tsc.patch
# RC patch for backports
Patch21: mysql-readline.patch
@@ -199,11 +198,9 @@ rm -f Docs/mysql.info
%patch6 -p1
%patch7 -p1
%patch8 -p1
-# %patch9 -p1
%patch10 -p1
-# %patch11 -p1
+%patch11 -p1
%patch12 -p1
-%patch13 -p1
# Backports specific patches
%patch21 -p1 -b .readline
@@ -220,7 +217,6 @@ outfile_loaddata : bug#46895 code wrong, expected results wrong too
sys_vars.plugin_dir_basic : bug#52223 fails for lib64 library directory
perfschema.binlog_mix : bug#59091 fails with openssl
perfschema.binlog_row : bug#59091 fails with openssl
-gis : bug#59908 has platform-dependent results
innodb.innodb : bug#60155 has platform-dependent results
main.information_schema : fails in mock, ok after install :(
EOF
@@ -682,6 +678,19 @@ fi
%{_mandir}/man1/mysql_client_test.1*
%changelog
+* Tue May 10 2011 Tom Lane <tgl@redhat.com> 5.5.12-1
+- Update to MySQL 5.5.12, for various fixes described at
+ http://dev.mysql.com/doc/refman/5.5/en/news-5-5-12.html
+
+* Tue May 10 2011 Tom Lane <tgl@redhat.com> 5.5.10-3
+- Add LSB init block to initscript, to ensure sane ordering at system boot
+Resolves: #703214
+- Improve initscript start action to notice when mysqladmin is failing
+ because of configuration problems
+Related: #703476
+- Remove exclusion of "gis" regression test, since upstream bug 59908
+ is fixed (for some value of "fixed") as of 5.5.10.
+
* Mon May 09 2011 Remi Collet <RPMS@FamilleCollet.com> - 5.5.12-1
- update to MySQL 5.5.12 Community Server GA
http://dev.mysql.com/doc/refman/5.5/en/news-5-5-12.html