summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-09-24 09:37:01 +0200
committerRemi Collet <fedora@famillecollet.com>2014-09-24 09:37:01 +0200
commit46309a60a4968904cc5c04cbcc5873516474085e (patch)
treedc0877ccce62913940e37a026c5ceb85ee6caf07
parent64692e617d3be58c39b48e1e739696a3ce720245 (diff)
MySQL 5.5.40
-rw-r--r--my.cnf5
-rw-r--r--mysql.5.5.40.spec (renamed from mysql.5.5.39.spec)19
-rw-r--r--mysql55.spec10
3 files changed, 25 insertions, 9 deletions
diff --git a/my.cnf b/my.cnf
index 8219d8b..dc6848a 100644
--- a/my.cnf
+++ b/my.cnf
@@ -31,3 +31,8 @@ user=mysql
log-error=/var/log/mysqld.log
pid-file=/var/run/mysqld/mysqld.pid
+
+#
+# include all files from the config directory
+#
+!includedir /etc/my.cnf.d
diff --git a/mysql.5.5.39.spec b/mysql.5.5.40.spec
index c9ded68..ec562ff 100644
--- a/mysql.5.5.39.spec
+++ b/mysql.5.5.40.spec
@@ -24,13 +24,13 @@
%global mysql_vendor_2 Sun Microsystems, Inc.
%global mysql_vendor Oracle and/or its affiliates
-%global mysql_version 5.5.39
+%global mysql_version 5.5.40
%global mysqld_user mysql
%global mysqld_group mysql
%global mysqldatadir /var/lib/mysql
-%global release 2
+%global release 1
#
@@ -142,9 +142,9 @@
%else
%if %(test -f /etc/oracle-release && echo 1 || echo 0)
%define elver %(rpm -qf --qf '%%{version}\\n' /etc/oracle-release | sed -e 's/^\\([0-9]*\\).*/\\1/g')
- %if "%elver" == "6"
- %define distro_description Oracle Linux 6
- %define distro_releasetag el6
+ %if "%elver" == "6" || "%elver" == "7"
+ %define distro_description Oracle Linux %elver
+ %define distro_releasetag el%elver
%define distro_buildreq gcc-c++ ncurses-devel perl readline-devel time zlib-devel cmake libaio-devel
%define distro_requires chkconfig coreutils grep procps shadow-utils net-tools
%else
@@ -242,7 +242,7 @@
Name: MySQL%{product_suffix}
Summary: MySQL: a very fast and reliable SQL database server
Group: Applications/Databases
-Version: 5.5.39
+Version: 5.5.40
Release: %{release}%{?distro_releasetag:.%{distro_releasetag}}
Distribution: %{distro_description}
License: Copyright (c) 2000, 2014, %{mysql_vendor}. All rights reserved. Under %{license_type} license as shown in the Description field.
@@ -251,6 +251,7 @@ URL: http://www.mysql.com/
Packager: MySQL Release Engineering <mysql-build@oss.oracle.com>
Vendor: %{mysql_vendor}
BuildRequires: %{distro_buildreq}
+%{?el7:Patch0: mysql-5.5-libmysqlclient-symbols.patch}
# Regression tests may take a long time, override the default to skip them
%{!?runselftest:%global runselftest 1}
@@ -443,7 +444,8 @@ For a description of MySQL see the base MySQL RPM or http://www.mysql.com/
##############################################################################
%prep
%setup -T -a 0 -c -n %{src_dir}
-
+pushd %{src_dir}
+%{?el7:%patch0 -p1}
##############################################################################
%build
@@ -559,6 +561,8 @@ install -d $RBR%{_libdir}
install -d $RBR%{_mandir}
install -d $RBR%{_sbindir}
+mkdir -p $RBR%{_sysconfdir}/my.cnf.d
+
# Install all binaries
(
cd $MBD/release
@@ -1094,6 +1098,7 @@ echo "=====" >> $STATUS_HISTORY
%doc %attr(644, root, man) %{_mandir}/man1/resolveip.1*
%ghost %config(noreplace,missingok) %{_sysconfdir}/my.cnf
+%dir %{_sysconfdir}/my.cnf.d
%attr(755, root, root) %{_bindir}/innochecksum
%attr(755, root, root) %{_bindir}/my_print_defaults
diff --git a/mysql55.spec b/mysql55.spec
index 30bda25..d4c6cf0 100644
--- a/mysql55.spec
+++ b/mysql55.spec
@@ -10,7 +10,7 @@
#endif
Name: mysql
-Version: 5.5.39
+Version: 5.5.40
Release: 1%{?dist}
Summary: MySQL client programs and shared libraries
@@ -452,7 +452,7 @@ touch $RPM_BUILD_ROOT/var/log/mysqld.log
mkdir -p $RPM_BUILD_ROOT/var/run/mysqld
install -m 0755 -d $RPM_BUILD_ROOT/var/lib/mysql
-mkdir -p $RPM_BUILD_ROOT/etc
+mkdir -p $RPM_BUILD_ROOT/etc/my.cnf.d
install -m 0644 %{SOURCE3} $RPM_BUILD_ROOT/etc/my.cnf
%if %{with_systemd}
sed -i -e '/user=mysql/d' $RPM_BUILD_ROOT/etc/my.cnf
@@ -687,6 +687,7 @@ fi
%doc README COPYING README.mysql-license
# although the default my.cnf contains only server settings, we put it in the
# libs package because it can be used for client settings too.
+%dir /etc/my.cnf.d
%config(noreplace) /etc/my.cnf
%dir %{_libdir}/mysql
%{_libdir}/mysql/libmysqlclient.so.18*
@@ -844,6 +845,11 @@ fi
%{_mandir}/man1/mysql_client_test.1*
%changelog
+* Wed Sep 24 2014 Remi Collet <RPMS@FamilleCollet.com> - 5.5.40-1
+- update to MySQL 5.5.40 Community Server GA
+ http://dev.mysql.com/doc/relnotes/mysql/5.5/en/news-5-5-40.html
+- add /etc/my.cnf.d for split configuration files
+
* Sat Aug 2 2014 Remi Collet <RPMS@FamilleCollet.com> - 5.5.39-1
- update to MySQL 5.5.39 Community Server GA
http://dev.mysql.com/doc/relnotes/mysql/5.5/en/news-5-5-39.html