summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-05-03 08:03:18 +0200
committerRemi Collet <remi@remirepo.net>2017-05-03 08:03:18 +0200
commit2f48deb55c30bd700d6297e7ddd841630c2159bc (patch)
tree63f682fb821493dabaabccd85b1edbdaa5df5f75
parentb96e027aafa81a9bafce37981ba66c4b891c7ea2 (diff)
v5.5.56
-rw-r--r--mysql.5.5.55.spec4
-rw-r--r--mysql55.spec115
2 files changed, 7 insertions, 112 deletions
diff --git a/mysql.5.5.55.spec b/mysql.5.5.55.spec
index 149e552..d25e8b9 100644
--- a/mysql.5.5.55.spec
+++ b/mysql.5.5.55.spec
@@ -24,7 +24,7 @@
%global mysql_vendor_2 Sun Microsystems, Inc.
%global mysql_vendor Oracle and/or its affiliates
-%global mysql_version 5.5.55
+%global mysql_version 5.5.56
%global mysqld_user mysql
%global mysqld_group mysql
@@ -242,7 +242,7 @@
Name: MySQL%{product_suffix}
Summary: MySQL: a very fast and reliable SQL database server
Group: Applications/Databases
-Version: 5.5.55
+Version: 5.5.56
Release: %{release}%{?distro_releasetag:.%{distro_releasetag}}
Distribution: %{distro_description}
License: Copyright (c) 2000, 2017, %{mysql_vendor}. All rights reserved. Under %{license_type} license as shown in the Description field.
diff --git a/mysql55.spec b/mysql55.spec
index 8a309e9..6e8f4da 100644
--- a/mysql55.spec
+++ b/mysql55.spec
@@ -1,12 +1,5 @@
-%if 0%{?fedora} >= 15 || 0%{?rhel} >= 7
-%global with_systemd 1
-%else
-%global with_systemd 0
-%endif
-%global with_dtrace 0
-
Name: mysql
-Version: 5.5.55
+Version: 5.5.56
Release: 1%{?dist}
Summary: MySQL client programs and shared libraries
@@ -72,16 +65,10 @@ Patch24: mysql-ssltest.patch
BuildRequires: gperf
BuildRequires: perl, readline-devel, openssl-devel
BuildRequires: gcc-c++, cmake, ncurses-devel, zlib-devel, libaio-devel
-%if %{with_dtrace}
-BuildRequires: systemtap-sdt-devel >= 1.3
-%endif
# make test requires time and ps
BuildRequires: time procps
# Socket and Time::HiRes are needed to run regression tests
BuildRequires: perl(Socket), perl(Time::HiRes)
-%if %{with_systemd}
-BuildRequires: systemd-units
-%endif
Requires: grep, fileutils
Requires: real-%{name}-libs%{?_isa} = %{version}-%{release}
@@ -143,22 +130,9 @@ Requires: sh-utils
Requires(pre): /usr/sbin/useradd
Requires(post): chkconfig
Requires(preun): chkconfig
-%if %{with_systemd}
-# We require this to be present for %%{_prefix}/lib/tmpfiles.d
-Requires: systemd-units
-# Make sure it's there when scriptlets run, too
-Requires(post): systemd-units
-Requires(preun): systemd-units
-Requires(postun): systemd-units
-# This is actually needed for the %%triggerun script but Requires(triggerun)
-# is not valid. We can use %%post because this particular %%triggerun script
-# should fire just after this package is installed.
-Requires(post): systemd-sysv
-%else
# This is for /sbin/service
Requires(preun): initscripts
Requires(postun): initscripts
-%endif
# mysqlhotcopy needs DBI/DBD support
Requires: perl-DBI, perl-DBD-MySQL
Conflicts: MySQL-server
@@ -331,11 +305,7 @@ cmake . -DBUILD_CONFIG=mysql_release \
-DMYSQL_UNIX_ADDR="/var/lib/mysql/mysql.sock" \
-DINSTALL_SECURE_FILE_PRIVDIR="/var/lib/mysql-files" \
-DENABLED_LOCAL_INFILE=ON \
-%if %{with_dtrace}
- -DENABLE_DTRACE=ON \
-%else
-DENABLE_DTRACE=OFF \
-%endif
-DWITH_EMBEDDED_SERVER=ON \
-DWITH_READLINE=ON \
-DWITH_SSL=system \
@@ -353,9 +323,6 @@ ar -x ../libmysqld.a
rm -f sql_binlog.cc.o rpl_utility.cc.o
gcc $CFLAGS $LDFLAGS -shared -Wl,-soname,libmysqld.so.0 -o libmysqld.so.0.0.1 \
*.o \
-%if %{with_dtrace}
- ../../probes_mysql.o \
-%endif
-lpthread -laio -lcrypt -lssl -lcrypto -lz -lrt -lstdc++ -ldl -lm -lc
# this is to check that we built a complete library
cp %{SOURCE9} .
@@ -442,32 +409,13 @@ install -m 0750 -d $RPM_BUILD_ROOT/var/lib/mysql-files
mkdir -p $RPM_BUILD_ROOT/etc/my.cnf.d
install -m 0644 %{SOURCE3} $RPM_BUILD_ROOT/etc/my.cnf
-%if %{with_systemd}
-sed -i -e '/user=mysql/d' $RPM_BUILD_ROOT/etc/my.cnf
-%endif
-
-%if %{with_systemd}
-# install systemd unit files and scripts for handling server startup
-mkdir -p ${RPM_BUILD_ROOT}%{_unitdir}
-install -m 644 %{SOURCE11} ${RPM_BUILD_ROOT}%{_unitdir}/
-%if 0%{?fedora} == 15
-# PrivateTmp only work on fedora >= 16
-sed -i -e '/PrivateTmp/s/true/false/' ${RPM_BUILD_ROOT}%{_unitdir}/mysqld.service
-%endif
-install -m 755 %{SOURCE12} ${RPM_BUILD_ROOT}%{_libexecdir}/
-install -m 755 %{SOURCE13} ${RPM_BUILD_ROOT}%{_libexecdir}/
-mkdir -p $RPM_BUILD_ROOT%{_prefix}/lib/tmpfiles.d
-install -m 0644 %{SOURCE10} $RPM_BUILD_ROOT%{_prefix}/lib/tmpfiles.d/mysql.conf
-
-%else
mkdir -p $RPM_BUILD_ROOT/etc/rc.d/init.d
install -m 0755 %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/mysqld
# sysconfig is only provided by remi
mkdir -p $RPM_BUILD_ROOT/etc/sysconfig
install -m 0644 %{SOURCE1} $RPM_BUILD_ROOT/etc/sysconfig/mysqld
-%endif
# Fix funny permissions that cmake build scripts apply to config files
chmod 644 ${RPM_BUILD_ROOT}%{_datadir}/mysql/config.*.ini
@@ -563,53 +511,19 @@ echo -e "You should consider upgrading to a supported release.\n"
/sbin/ldconfig
%post server
-%if 0%{?systemd_post:1}
-%systemd_post mysqld.service
-%else
if [ $1 = 1 ]; then
# Initial installation
-%if %{with_systemd}
- /bin/systemctl daemon-reload >/dev/null 2>&1 || :
-%else
/sbin/chkconfig --add mysqld
-%endif
fi
-%endif
/bin/chmod 0755 /var/lib/mysql
/bin/touch /var/log/mysqld.log
-# Handle upgrading from SysV initscript to native systemd unit.
-# We can tell if a SysV version of mysql was previously installed by
-# checking to see if the initscript is present.
-%triggerun server -- mysql-server
-%if %{with_systemd}
-if [ -f /etc/rc.d/init.d/mysqld ]; then
- # Save the current service runlevel info
- # User must manually run systemd-sysv-convert --apply mysqld
- # to migrate them to systemd targets
- /usr/bin/systemd-sysv-convert --save mysqld >/dev/null 2>&1 || :
-
- # Run these because the SysV package being removed won't do them
- /sbin/chkconfig --del mysqld >/dev/null 2>&1 || :
- /bin/systemctl try-restart mysqld.service >/dev/null 2>&1 || :
-fi
-%endif
-
%preun server
-%if 0%{?systemd_preun:1}
-%systemd_preun mysqld.service
-%else
if [ $1 = 0 ]; then
# Package removal, not upgrade
-%if %{with_systemd}
- /bin/systemctl --no-reload disable mysqld.service >/dev/null 2>&1 || :
- /bin/systemctl stop mysqld.service >/dev/null 2>&1 || :
-%else
/sbin/service mysqld stop >/dev/null 2>&1
/sbin/chkconfig --del mysqld
-%endif
fi
-%endif
%postun libs
if [ $1 = 0 ] ; then
@@ -617,25 +531,12 @@ if [ $1 = 0 ] ; then
fi
%postun server
-%if 0%{?systemd_postun_with_restart:1}
-%systemd_postun_with_restart mysqld.service
-%else
-%if %{with_systemd}
-/bin/systemctl daemon-reload >/dev/null 2>&1 || :
-if [ $1 -ge 1 ]; then
- # Package upgrade, not uninstall
- /bin/systemctl try-restart mysqld.service >/dev/null 2>&1 || :
-fi
-%else
if [ $1 -ge 1 ]; then
/sbin/service mysqld condrestart >/dev/null 2>&1 || :
fi
-%endif
-%endif
%files
-%defattr(-,root,root)
%doc README COPYING README.mysql-license
%doc README.mysql-docs
%doc Docs
@@ -669,7 +570,6 @@ fi
%{_libdir}/mysql/mysql_config
%files libs
-%defattr(-,root,root)
%doc README COPYING README.mysql-license
# although the default my.cnf contains only server settings, we put it in the
# libs package because it can be used for client settings too.
@@ -706,7 +606,6 @@ fi
%{_datadir}/mysql/charsets
%files server
-%defattr(-,root,root)
%doc support-files/*.cnf
%{_bindir}/myisamchk
@@ -783,16 +682,8 @@ fi
%{_datadir}/mysql/my-*.cnf
%{_datadir}/mysql/config.*.ini
-%if %{with_systemd}
-%{_unitdir}/mysqld.service
-%{_libexecdir}/mysqld-prepare-db-dir
-%{_libexecdir}/mysqld-wait-ready
-
-%{_prefix}/lib/tmpfiles.d/mysql.conf
-%else
/etc/rc.d/init.d/mysqld
%config(noreplace) /etc/sysconfig/mysqld
-%endif
%attr(0755,mysql,mysql) %dir /var/run/mysqld
%attr(0755,mysql,mysql) %dir /var/lib/mysql
%attr(0750,mysql,mysql) %dir /var/lib/mysql-files
@@ -827,6 +718,10 @@ fi
%{_mandir}/man1/mysql_client_test.1*
%changelog
+* Wed May 3 2017 Remi Collet <remi@remirepo.net> - 5.5.56-1
+- update to MySQL 5.5.56 Community Server GA
+ http://dev.mysql.com/doc/relnotes/mysql/5.5/en/news-5-5-56.html
+
* Tue Apr 11 2017 Remi Collet <remi@remirepo.net> - 5.5.55-1
- update to MySQL 5.5.55 Community Server GA
http://dev.mysql.com/doc/relnotes/mysql/5.5/en/news-5-5-55.html