summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2013-02-08 18:54:33 +0100
committerRemi Collet <fedora@famillecollet.com>2013-02-08 18:54:33 +0100
commit2ca30afff3e168933508df3c17c8887bbdc1961f (patch)
tree3d6b1c76034d538bbf6164ab2043d97d7b57ea8b
parent0603c4871846766a684067d02ba293000b726a56 (diff)
mysql: sync with rawhide
-rw-r--r--my.cnf12
-rw-r--r--mysql55.spec11
-rw-r--r--mysqld-wait-ready2
3 files changed, 15 insertions, 10 deletions
diff --git a/my.cnf b/my.cnf
index aa5efe7..8219d8b 100644
--- a/my.cnf
+++ b/my.cnf
@@ -1,16 +1,16 @@
[mysqld]
-# Settings user and group are ignored when systemd is used (fedora >= 15).
-# If you need to run mysqld under different user or group,
-# customize your systemd unit file for mysqld according to the
-# instructions in http://fedoraproject.org/wiki/Systemd
-user=mysql
-
datadir=/var/lib/mysql
socket=/var/lib/mysql/mysql.sock
# Disabling symbolic-links is recommended to prevent assorted security risks
symbolic-links=0
+# Settings user and group are ignored when systemd is used (fedora >= 15).
+# If you need to run mysqld under a different user or group,
+# customize your systemd unit file for mysqld according to the
+# instructions in http://fedoraproject.org/wiki/Systemd
+user=mysql
+
# Semisynchronous Replication
# http://dev.mysql.com/doc/refman/5.5/en/replication-semisync.html
# uncomment next line on MASTER
diff --git a/mysql55.spec b/mysql55.spec
index c560e02..152b8c4 100644
--- a/mysql55.spec
+++ b/mysql55.spec
@@ -101,9 +101,8 @@ Provides: mysql-client = %{version}-%{release}
%global __perl_requires %{SOURCE999}
%global __perllib_requires %{SOURCE999}
-# patch utility does automatically back-up of chunks that didn't apply
-# smoothly, but we don't want to create that files because they could be
-# included in RPM incorrectly
+# By default, patch(1) creates backup files when chunks apply with offsets.
+# Turn that off to ensure such files don't get included in RPMs (cf bz#884755).
%global _default_patch_flags --no-backup-if-mismatch
%description
@@ -812,6 +811,12 @@ fi
%{_mandir}/man1/mysql_client_test.1*
%changelog
+* Wed Jan 2 2013 Tom Lane <tgl@redhat.com> 5.5.29-1
+- Update to MySQL 5.5.29, for various fixes described at
+ http://dev.mysql.com/doc/refman/5.5/en/news-5-5-29.html
+- Fix inaccurate default for socket location in mysqld-wait-ready
+Resolves: #890535
+
* Fri Dec 28 2012 Remi Collet <RPMS@FamilleCollet.com> - 5.5.29-1
- update to MySQL 5.5.29 Community Server GA
http://dev.mysql.com/doc/refman/5.5/en/news-5-5-29.html
diff --git a/mysqld-wait-ready b/mysqld-wait-ready
index 9b0fd0c..9e5d3e4 100644
--- a/mysqld-wait-ready
+++ b/mysqld-wait-ready
@@ -25,7 +25,7 @@ get_mysql_option(){
# Defaults here had better match what mysqld_safe will default to
get_mysql_option mysqld datadir "/var/lib/mysql"
datadir="$result"
-get_mysql_option mysqld socket "$datadir/mysql.sock"
+get_mysql_option mysqld socket "/var/lib/mysql/mysql.sock"
socketfile="$result"
# Wait for the server to come up or for the mysqld process to disappear