summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-07-24 16:01:05 +0200
committerRemi Collet <fedora@famillecollet.com>2015-07-24 16:01:05 +0200
commit2c85065b92e76be2eb8c7a76bcb2424f797d8549 (patch)
tree408ee0021a147ad911c5faacaab4465cd9df282b
parent231728fe453f170cd181d810a834ce5751da42be (diff)
mysql 5.5.45
-rw-r--r--mysql-dh1024.patch63
-rw-r--r--mysql.5.5.45.spec (renamed from mysql.5.5.44.spec)4
-rw-r--r--mysql55.spec8
3 files changed, 7 insertions, 68 deletions
diff --git a/mysql-dh1024.patch b/mysql-dh1024.patch
deleted file mode 100644
index 620ee0b..0000000
--- a/mysql-dh1024.patch
+++ /dev/null
@@ -1,63 +0,0 @@
-Change the DH key length from 512 to 1024 bits to meet minimum requirements
-of FIPS 140-2. (In principle we could use the larger size only when FIPS
-mode is on, but it doesn't seem worth the trouble.)
-
-The new parameter value was generated using "openssl dhparam -C 1024".
-
-
-diff -Naur mysql-5.5.28.orig/vio/viosslfactories.c mysql-5.5.28/vio/viosslfactories.c
---- mysql-5.5.28.orig/vio/viosslfactories.c 2012-08-29 04:50:46.000000000 -0400
-+++ mysql-5.5.28/vio/viosslfactories.c 2012-11-15 11:19:38.575701435 -0500
-@@ -20,27 +20,32 @@
- static my_bool ssl_algorithms_added = FALSE;
- static my_bool ssl_error_strings_loaded= FALSE;
-
--static unsigned char dh512_p[]=
-+static unsigned char dh1024_p[]=
- {
-- 0xDA,0x58,0x3C,0x16,0xD9,0x85,0x22,0x89,0xD0,0xE4,0xAF,0x75,
-- 0x6F,0x4C,0xCA,0x92,0xDD,0x4B,0xE5,0x33,0xB8,0x04,0xFB,0x0F,
-- 0xED,0x94,0xEF,0x9C,0x8A,0x44,0x03,0xED,0x57,0x46,0x50,0xD3,
-- 0x69,0x99,0xDB,0x29,0xD7,0x76,0x27,0x6B,0xA2,0xD3,0xD4,0x12,
-- 0xE2,0x18,0xF4,0xDD,0x1E,0x08,0x4C,0xF6,0xD8,0x00,0x3E,0x7C,
-- 0x47,0x74,0xE8,0x33,
-+ 0xBF,0x5C,0xFA,0xD1,0xDD,0xBB,0xB3,0x0A,0x58,0x29,0x05,0xF5,
-+ 0x7D,0x64,0xB2,0xE1,0xCE,0xE8,0xE0,0xE1,0x7A,0xB6,0xBC,0x5B,
-+ 0x21,0x56,0xDF,0x2C,0x82,0x60,0xDC,0x31,0xCA,0x1E,0x02,0xFE,
-+ 0xC4,0xE7,0x24,0x63,0x31,0xE4,0x67,0x1C,0x0B,0xFF,0x86,0x12,
-+ 0x0D,0x2E,0xE6,0x35,0x0A,0x07,0x4F,0xE7,0x3F,0xDE,0xFE,0xF0,
-+ 0x13,0x1C,0xA2,0x2B,0xF4,0xEE,0x2C,0x90,0x10,0x57,0x6B,0x2B,
-+ 0xB9,0x1E,0x1B,0x47,0xB0,0x25,0xBF,0x45,0x86,0xDA,0x87,0x35,
-+ 0x2C,0xF5,0x6A,0x41,0xA2,0x57,0xD8,0x16,0x5E,0x82,0x91,0x99,
-+ 0x33,0xA0,0x8B,0x9D,0x34,0xCE,0x03,0x01,0x80,0x32,0x07,0x3B,
-+ 0xF2,0x93,0xFC,0x3A,0x25,0xEC,0xB3,0xED,0x5C,0x4E,0x57,0xF2,
-+ 0x3C,0x2E,0x0D,0xB1,0x59,0xA2,0x08,0x93,
- };
-
--static unsigned char dh512_g[]={
-+static unsigned char dh1024_g[]={
- 0x02,
- };
-
--static DH *get_dh512(void)
-+static DH *get_dh1024(void)
- {
- DH *dh;
- if ((dh=DH_new()))
- {
-- dh->p=BN_bin2bn(dh512_p,sizeof(dh512_p),NULL);
-- dh->g=BN_bin2bn(dh512_g,sizeof(dh512_g),NULL);
-+ dh->p=BN_bin2bn(dh1024_p,sizeof(dh1024_p),NULL);
-+ dh->g=BN_bin2bn(dh1024_g,sizeof(dh1024_g),NULL);
- if (! dh->p || ! dh->g)
- {
- DH_free(dh);
-@@ -255,7 +260,7 @@
- }
-
- /* DH stuff */
-- dh=get_dh512();
-+ dh=get_dh1024();
- SSL_CTX_set_tmp_dh(ssl_fd->ssl_context, dh);
- DH_free(dh);
-
diff --git a/mysql.5.5.44.spec b/mysql.5.5.45.spec
index ae91e7e..dbc78df 100644
--- a/mysql.5.5.44.spec
+++ b/mysql.5.5.45.spec
@@ -24,7 +24,7 @@
%global mysql_vendor_2 Sun Microsystems, Inc.
%global mysql_vendor Oracle and/or its affiliates
-%global mysql_version 5.5.44
+%global mysql_version 5.5.45
%global mysqld_user mysql
%global mysqld_group mysql
@@ -242,7 +242,7 @@
Name: MySQL%{product_suffix}
Summary: MySQL: a very fast and reliable SQL database server
Group: Applications/Databases
-Version: 5.5.44
+Version: 5.5.45
Release: %{release}%{?distro_releasetag:.%{distro_releasetag}}
Distribution: %{distro_description}
License: Copyright (c) 2000, 2015, %{mysql_vendor}. All rights reserved. Under %{license_type} license as shown in the Description field.
diff --git a/mysql55.spec b/mysql55.spec
index da65eb3..85dea9f 100644
--- a/mysql55.spec
+++ b/mysql55.spec
@@ -10,7 +10,7 @@
#endif
Name: mysql
-Version: 5.5.44
+Version: 5.5.45
Release: 1%{?dist}
Summary: MySQL client programs and shared libraries
@@ -70,7 +70,6 @@ Patch17: mysql-plugin-test.patch
Patch18: mysql-cipherspec.patch
Patch19: mysql-file-contents.patch
Patch20: mysql-string-overflow.patch
-Patch21: mysql-dh1024.patch
Patch22: mysql-innodbwarn.patch
Patch24: mysql-ssltest.patch
@@ -272,7 +271,6 @@ rm -f Docs/mysql.info
%patch18 -p1
%patch19 -p1
%patch20 -p1
-%patch21 -p1
%patch22 -p1
%patch24 -p1
@@ -840,6 +838,10 @@ fi
%{_mandir}/man1/mysql_client_test.1*
%changelog
+* Fri Jul 24 2015 Remi Collet <RPMS@FamilleCollet.com> - 5.5.45-1
+- update to MySQL 5.5.45 Community Server GA
+ http://dev.mysql.com/doc/relnotes/mysql/5.5/en/news-5-5-45.html
+
* Fri May 29 2015 Remi Collet <RPMS@FamilleCollet.com> - 5.5.44-1
- update to MySQL 5.5.44 Community Server GA
http://dev.mysql.com/doc/relnotes/mysql/5.5/en/news-5-5-44.html