summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-02-03 14:48:45 +0100
committerRemi Collet <fedora@famillecollet.com>2014-02-03 14:48:45 +0100
commit1cbf8a67a046e049bdf21167e75aefe519703a18 (patch)
treefa9180064e20a65e22c0e4bcc8fbea73e50fb515
parent165556dbfd2532ff8ba4c4d9eaa3c5d49bb28696 (diff)
Mysql: fix build with recent openssl
-rw-r--r--mysql-ssltest.patch30
-rw-r--r--mysql55.spec2
2 files changed, 32 insertions, 0 deletions
diff --git a/mysql-ssltest.patch b/mysql-ssltest.patch
new file mode 100644
index 0000000..6fdd271
--- /dev/null
+++ b/mysql-ssltest.patch
@@ -0,0 +1,30 @@
+Don't test EDH-RSA-DES-CBC-SHA cipher, it seems to be removed from openssl
+which now makes mariadb/mysql FTBFS because openssl_1 test fails
+
+Related: #1044565
+
+
+diff -up mariadb-5.5.34/mysql-test/r/openssl_1.result.p20 mariadb-5.5.34/mysql-test/r/openssl_1.result
+--- mariadb-5.5.34/mysql-test/r/openssl_1.result.p20 2014-01-06 11:51:18.878640731 +0100
++++ mariadb-5.5.34/mysql-test/r/openssl_1.result 2014-01-06 11:51:45.364678942 +0100
+@@ -196,8 +196,6 @@ Ssl_cipher DHE-RSA-AES256-SHA
+ Variable_name Value
+ Ssl_cipher EDH-RSA-DES-CBC3-SHA
+ Variable_name Value
+-Ssl_cipher EDH-RSA-DES-CBC-SHA
+-Variable_name Value
+ Ssl_cipher RC4-SHA
+ select 'is still running; no cipher request crashed the server' as result from dual;
+ result
+diff -up mariadb-5.5.34/mysql-test/t/openssl_1.test.p20 mariadb-5.5.34/mysql-test/t/openssl_1.test
+--- mariadb-5.5.34/mysql-test/t/openssl_1.test.p20 2014-01-06 11:51:18.830640662 +0100
++++ mariadb-5.5.34/mysql-test/t/openssl_1.test 2014-01-06 11:51:18.879640733 +0100
+@@ -218,7 +218,7 @@ DROP TABLE t1;
+ # Common ciphers to openssl and yassl
+ --exec $MYSQL --host=localhost -e "SHOW STATUS LIKE 'Ssl_cipher';" --ssl-cipher=DHE-RSA-AES256-SHA
+ --exec $MYSQL --host=localhost -e "SHOW STATUS LIKE 'Ssl_cipher';" --ssl-cipher=EDH-RSA-DES-CBC3-SHA
+---exec $MYSQL --host=localhost -e "SHOW STATUS LIKE 'Ssl_cipher';" --ssl-cipher=EDH-RSA-DES-CBC-SHA
++#--exec $MYSQL --host=localhost -e "SHOW STATUS LIKE 'Ssl_cipher';" --ssl-cipher=EDH-RSA-DES-CBC-SHA
+ --exec $MYSQL --host=localhost -e "SHOW STATUS LIKE 'Ssl_cipher';" --ssl-cipher=RC4-SHA
+ --disable_query_log
+ --disable_result_log
diff --git a/mysql55.spec b/mysql55.spec
index 6372055..40c1fda 100644
--- a/mysql55.spec
+++ b/mysql55.spec
@@ -75,6 +75,7 @@ Patch21: mysql-dh1024.patch
Patch22: mysql-innodbwarn.patch
# http://bugs.mysql.com/68999
Patch23: mysql-openssl.patch
+Patch24: mysql-ssltest.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildRequires: gperf
@@ -278,6 +279,7 @@ rm -f Docs/mysql.info
%patch21 -p1
%patch22 -p1
%patch23 -p1
+%patch24 -p1
# workaround for upstream bug #56342
rm -f mysql-test/t/ssl_8k_key-master.opt