summaryrefslogtreecommitdiffstats
path: root/mysql-missing-string-code.patch
diff options
context:
space:
mode:
Diffstat (limited to 'mysql-missing-string-code.patch')
-rw-r--r--mysql-missing-string-code.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/mysql-missing-string-code.patch b/mysql-missing-string-code.patch
new file mode 100644
index 0000000..d251f81
--- /dev/null
+++ b/mysql-missing-string-code.patch
@@ -0,0 +1,14 @@
+Crude workaround for bug #587170. There are probably better ways ...
+
+
+diff -Naur mysql-5.1.47.orig/storage/federated/Makefile.am mysql-5.1.47/storage/federated/Makefile.am
+--- mysql-5.1.47.orig/storage/federated/Makefile.am 2010-05-06 11:27:38.000000000 -0400
++++ mysql-5.1.47/storage/federated/Makefile.am 2010-06-04 14:57:36.000000000 -0400
+@@ -38,6 +38,7 @@
+ ha_federated_la_CXXFLAGS= $(AM_CFLAGS) -DMYSQL_DYNAMIC_PLUGIN
+ ha_federated_la_CFLAGS = $(AM_CFLAGS) -DMYSQL_DYNAMIC_PLUGIN
+ ha_federated_la_SOURCES = ha_federated.cc
++ha_federated_la_LIBADD = ../../mysys/string.o
+
+
+ EXTRA_LIBRARIES = libfederated.a