summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2011-01-12 18:35:08 +0100
committerRemi Collet <fedora@famillecollet.com>2011-01-12 18:35:08 +0100
commite04b6e74d7f6b494fc235e1a81937370e54834e9 (patch)
tree146056a663e0822148ca07d59fe70e5671e2ea13
parentcbfea94e7e4bec6d5f20eb27dbb40e9a4ba9a693 (diff)
mysql 5.5, fix EL4 build
-rw-r--r--mysql-dev.spec14
1 files changed, 9 insertions, 5 deletions
diff --git a/mysql-dev.spec b/mysql-dev.spec
index 7de54c5..238d509 100644
--- a/mysql-dev.spec
+++ b/mysql-dev.spec
@@ -55,7 +55,7 @@ BuildRequires: time procps
# Socket is needed to run regression tests
BuildRequires: perl(Socket)
# This is required old EL4
-BuildRequires: perl(Time::HiRes)
+BuildRequires: perl(Time::HiRes), bison
Requires: grep, fileutils
Requires: %{name}-libs = %{version}-%{release}
@@ -256,7 +256,11 @@ cmake . -DBUILD_CONFIG=mysql_release \
%endif
-DWITH_EMBEDDED_SERVER=ON \
-DWITH_READLINE=ON \
+%if 0%{?rhel} <= 4
+ -DWITH_SSL=bundled \
+%else
-DWITH_SSL=system \
+%endif
-DWITH_ZLIB=system
gcc $CFLAGS $LDFLAGS -o scriptstub "-DLIBDIR=\"%{_libdir}/mysql\"" %{SOURCE4}
@@ -308,14 +312,14 @@ cd ../..
# test SSL with --ssl
# avoid redundant test runs with --binlog-format=mixed
# increase timeouts to prevent unwanted failures during mass rebuilds
+ cd mysql-test
(
- cd mysql-test
# perl ./mysql-test-run.pl --force --retry=0 --ssl --mysqld=--binlog-format=mixed --suite-timeout=720 --testcase-timeout=30
# Run less test to speed up build process
- %{__perl} ./mysql-test-run.pl --ssl --mysqld=--binlog-format=mixed --suite=main
- # cmake build scripts will install the var cruft if left alone :-(
- rm -rf var
+ %{__perl} ./mysql-test-run.pl --force --ssl --mysqld=--binlog-format=mixed --suite=main
)
+ # cmake build scripts will install the var cruft if left alone :-(
+ rm -rf var
%endif
%install