summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2011-01-08 08:23:46 +0100
committerRemi Collet <fedora@famillecollet.com>2011-01-08 08:23:46 +0100
commit8c27fa9ad83b0c6b241a907141fda9457bff50b9 (patch)
tree0277f695a3c86144eb2be945c978b7ca20438e17
parentccb0cfc6e9c7ee189f3a2eee5830880a93a81186 (diff)
mysql: improved patch from f14
-rw-r--r--mysql-setschedparam.patch19
1 files changed, 15 insertions, 4 deletions
diff --git a/mysql-setschedparam.patch b/mysql-setschedparam.patch
index 3b0e518..24645cb 100644
--- a/mysql-setschedparam.patch
+++ b/mysql-setschedparam.patch
@@ -2,12 +2,14 @@ mysql tries to use pthread_setschedparam() with policy = SCHED_OTHER,
which is not standardized and is not presently supported on Red Hat
platforms; in fact it generates lots of SELinux warnings (bug #477624).
Easiest fix is to disable the configure test for it.
+We have to zap the test for pthread_setschedprio too, else it will try
+to fall back on that.
-diff -Naur mysql-5.1.33.orig/configure.in mysql-5.1.33/configure.in
---- mysql-5.1.33.orig/configure.in 2009-03-13 17:48:52.000000000 -0400
-+++ mysql-5.1.33/configure.in 2009-04-07 19:27:25.000000000 -0400
-@@ -2046,10 +2046,10 @@
+diff -Naur mysql-5.1.52.orig/configure.in mysql-5.1.52/configure.in
+--- mysql-5.1.52.orig/configure.in 2010-10-11 16:34:15.000000000 -0400
++++ mysql-5.1.52/configure.in 2011-01-05 22:36:53.249411523 -0500
+@@ -2079,10 +2079,10 @@
localtime_r gethrtime gmtime_r \
locking longjmp lrand48 madvise mallinfo memcpy memmove \
mkstemp mlockall perror poll pread pthread_attr_create mmap mmap64 getpagesize \
@@ -20,3 +22,12 @@ diff -Naur mysql-5.1.33.orig/configure.in mysql-5.1.33/configure.in
realpath rename rint rwlock_init setupterm \
shmget shmat shmdt shmctl sigaction sigemptyset sigaddset \
sighold sigset sigthreadmask port_create sleep \
+@@ -2128,7 +2128,7 @@
+ [Define to 1 if you have the `pthread_setschedprio' function.])
+ fi
+ ;;
+- *) AC_CHECK_FUNCS(pthread_setschedprio)
++ *) :
+ ;;
+ esac
+