summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2010-11-10 18:13:56 +0100
committerRemi Collet <fedora@famillecollet.com>2010-11-10 18:13:56 +0100
commit3cbea88e8e54e9af560bfeadf99428bd3fe5544f (patch)
treea63df3617376fff0cceca98188ca48a62acff210
parenta1e7cdf66b93d2c3891be31cce28b99e1ed2fe02 (diff)
MySQL 5.5.7 RC
-rw-r--r--mysql-5.5-abi.patch10
-rw-r--r--mysql-dev.spec15
-rw-r--r--mysql.init7
3 files changed, 29 insertions, 3 deletions
diff --git a/mysql-5.5-abi.patch b/mysql-5.5-abi.patch
new file mode 100644
index 0000000..871a9b4
--- /dev/null
+++ b/mysql-5.5-abi.patch
@@ -0,0 +1,10 @@
+--- mysql-5.5.7-rc/Makefile.am.orig 2010-11-10 17:13:07.506287855 +0100
++++ mysql-5.5.7-rc/Makefile.am 2010-11-10 17:13:27.982746445 +0100
+@@ -269,7 +269,6 @@
+ $(top_srcdir)/include/mysql.h \
+ $(top_srcdir)/include/mysql/psi/psi_abi_v1.h \
+ $(top_srcdir)/include/mysql/psi/psi_abi_v2.h \
+- $(top_srcdir)/include/mysql/client_plugin.h \
+ $(top_srcdir)/include/mysql/plugin_auth.h
+
+ #
diff --git a/mysql-dev.spec b/mysql-dev.spec
index c77d770..9eb637e 100644
--- a/mysql-dev.spec
+++ b/mysql-dev.spec
@@ -1,6 +1,6 @@
%global postver -rc
Name: mysql
-Version: 5.5.6
+Version: 5.5.7
Release: 1%{?dist}
Summary: MySQL client programs and shared libraries
Group: Applications/Databases
@@ -45,9 +45,11 @@ Patch14: mysql-missing-string-code.patch
Patch15: mysql-lowercase-bug.patch
Patch16: mysql-chain-certs.patch
# mysql.sock path
-Patch17: mysql-5.5-tests.patch
+#Patch17: mysql-5.5-tests.patch
# missing rpl_reporting in embedded lib
Patch18: mysql-5.5-report.patch
+# ABI check fails on client_plugin.h (seems a preprocessor issue)
+Patch19: mysql-5.5-abi.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildRequires: gperf, perl, readline-devel, openssl-devel
@@ -194,11 +196,14 @@ the MySQL sources.
%patch14 -p1
%patch15 -p1
%patch16 -p1
-%patch17 -p1
+# %patch17 -p1
%patch18 -p1
+%patch19 -p1
# workaround for upstream bug #56342
rm -f mysql-test/t/ssl_8k_key-master.opt
+# Stupid test which rely on hostname to be "unknown"
+rm -f mysql-test/t/plugin_auth.test
libtoolize --force
aclocal
@@ -613,6 +618,10 @@ fi
%{_mandir}/man1/mysql_client_test.1*
%changelog
+* Wed Nov 10 2010 Remi Collet <RPMS@FamilleCollet.com> - 5.5.7-1
+- Update to MySQL Community Server 5.5.7 RC
+- add startsos to init script (--skip-grant-tables --skip-networking)
+
* Fri Sep 24 2010 Remi Collet <RPMS@FamilleCollet.com> - 5.5.6-1
- Update to MySQL Community Server 5.5.6 RC
diff --git a/mysql.init b/mysql.init
index 1661f3b..81b1f85 100644
--- a/mysql.init
+++ b/mysql.init
@@ -89,6 +89,10 @@ start(){
fi
chown mysql:mysql "$datadir"
chmod 0755 "$datadir"
+ # If startsos
+ if [ "$1" = "sos" ] ; then
+ exec="$exec --skip-grant-tables --skip-networking"
+ fi
# Pass all the options determined above, to ensure consistent behavior.
# In many cases mysqld_safe would arrive at the same conclusions anyway
# but we need to be sure. (An exception is that we don't force the
@@ -183,6 +187,9 @@ case "$1" in
start)
start
;;
+ startsos)
+ start sos
+ ;;
stop)
stop
;;